Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Issue with .exe and Command Prompt


17 Nov 2012   #1

Windows 7 Home Premium 64bit
 
 
.exe Files replaced by something else, Command Prompt doesn't work.

Ok, I've done something completely terrible, changed all of my .exe files into something else (By accident, I'm gifted). I was trying to open a .exe file to modify it to allocate more memory to it, Minecraft, and didn't have the right program, it was Java SDK apparently, but could only find Java JDK upon searching, and now no programs will open, or rather, they will open, but through the path that I accidentally changed it to. Which happens to be the command prompt currently, and before it was notepad, and before it was JDK Development tools (I didn't know what was happening, so kept changing it) (And command prompt was broken before I changed programs to open through it. I must stress though, this isn't a virus, this is my own stupid mistake.

To get internet to open (to post this), I had to find a file my computer didn't recognize, and try to open it, prompting me to see if I wanted to search the internet for it, and voila, I got this open.

If there is anyone, who may have an knowledge of how to fix this problem, without using command prompt, a .exe program (regedit is un-openable as well), if you could enlighten me I would be most grateful.

If you need screenshots of anything I will be happy to take some and get them here.

Edit: I've also tried copying the regedit program from another computer to this one via flash drive but it lost it's .exe upon opening on my computer.

Thanks - Hastings

My System SpecsSystem Spec
.

17 Nov 2012   #2
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello Hastings, and welcome to Seven Forums.

Don't worry. You just messed up the associations for exe files. You could download and merge the .reg file for the listed EXE option in the tutorial below to fix this. It will restore the default associations for .exe files.
Default File Type Associations - Restore
Hope this helps,
Shawn
My System SpecsSystem Spec
17 Nov 2012   #3

Windows 7 Home Premium 64bit
 
 

Thanks Brink, that solved the issue!
My System SpecsSystem Spec
.


17 Nov 2012   #4
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

You're most welcome. I'm glad to hear it's fixed now.
My System SpecsSystem Spec
Reply

 Issue with .exe and Command Prompt




Thread Tools



Similar help and support threads for2: Issue with .exe and Command Prompt
Thread Forum
Command prompt - taking ownership - issue General Discussion
Help needed executing command prompt command General Discussion
I have an issue with the command prompt General Discussion
Run administrative command prompt from command prompt General Discussion
Command Prompt Build Issue General Discussion
Command Prompt command <ipconfig> not working Network & Sharing
Strange Command Prompt Issue General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:22 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33