Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: A couple problems I've been having..


10 Dec 2012   #1

Windows 7 Home Premium 64bit
 
 
A couple problems I've been having..

Hi,

So this is my first post on the forum. I'm sorry that the title of the thread is really non-specific but there's a couple of issues and so I felt like I better just let you experts see what you think

Firstly, I have the quite common issue of the date and time resetting everytime I switch my computer on. I realise that people refer to the CMOS battery and that it probably needs changing but I just wanted to add that sometimes the date completely disappears, some of the icons at the bottom right of my screen get all jumbled, even the volume icon (amongst others) decides not to work every now and again and I have to change it via the control panel. Are these things all inter related? What do you suggest?

My second issue is with Google Chrome and I was just wondering if there is perhaps a compatibility issue with this particular browser and Windows 7 (plus if anyone else has had the same problems). It's generally mind-numbingly slow even when my internet has a strong signal and often crashes, citing a Shockwave Flash crash (poetry!) as the issue. Is there any way to sort this out?

My computer is just generally being really slow at the moment too...should I defrag it? I've not done it on this laptop yet but it used to work very well for the desktop downstairs when my Dad used to do it.

Thanks for your time and any help would be greatly appreciated! P.S nice forum

My System SpecsSystem Spec
.

10 Dec 2012   #2
Microsoft MVP

 

Is this preinstalled Windows 7 which has never had a Clean Reinstall - Factory OEM Windows 7
to get rid of the corrupting factory bloatware?

If so at the minimum I'd Clean Up Factory Bloatware.

Then Optimize Windows 7 - Windows 7 Forums.

If this doesn't resolve your problems work through the Troubleshooting Steps for Windows 7
My System SpecsSystem Spec
Reply

 A couple problems I've been having..




Thread Tools



Similar help and support threads for2: A couple problems I've been having..
Thread Forum
Couple BSOD Problems BSOD Help and Support
Couple different problems: One with AIM 7 and another with Windows 7 General Discussion
Couple of Annoying Little Problems General Discussion
Couple of problems Windows 7 Installation & Setup
couple of problems with network bridge Network & Sharing
Couple Of Problems General Discussion
A couple odd problems with WMC Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:34 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33