Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Symbolic Link not working


20 Dec 2012   #1

Windows 7 Starter Edition 64 Bit
 
 
Symbolic Link not working

Hello,

I recently got a small sdd for my system. However, being a heavy gamer, my appdata folder is starting to get quite large and I do not want to "waste" all the writes on my sdd. I used this guide to move my entire user file over. User Profile - Change Default Location

After finishing that I realized my programs might still be trying to reference my old appdata folder and tried to make a symbolic link

mklink/J D:\Frederick C:\Users\Frederick\Appdata

Where D is my new user file after I moved it. It keeps telling me "Cannot create a file when that file already exists." I checked the path myself (typed C:\Users\Frederick\Appdata) and it told me it did not exist, so... how do I fix this?

Thanks.


My System SpecsSystem Spec
.

20 Dec 2012   #2

Windows 7 Pro. 64/SP-1
 
 

Warning
Before doing this, you should create a system image to be safe. This way you can do a system image recovery to undo any mistake you might make in the instructions below that could result in the user profile you are moving, or Windows, to no longer work.
-------------------------
This is the way I would do it.
Change Default Location
My System SpecsSystem Spec
20 Dec 2012   #3

Windows 7 Starter Edition 64 Bit
 
 

Layback, I did that first (Succesfully). But I am unsure if some programs will still reference my old apdata which is no longer there.
My System SpecsSystem Spec
.


20 Dec 2012   #4

Windows 7 Pro. 64/SP-1
 
 

System Restore
^Another option.
v Many options.
Tutorial search - Windows 7 Forums
My System SpecsSystem Spec
20 Dec 2012   #5

Windows 7 Starter Edition 64 Bit
 
 

I have no idea how that is supposed to help me. I am simply having trouble getting a symbolic link to work properly.
My System SpecsSystem Spec
20 Dec 2012   #6

Windows 7 Pro. 64/SP-1
 
 

Well if you go to a restore point before you made changes you could give a try again.
Something went wrong on the first try. If you use your image that you made you could also go back to the way your system was before the changes.
Just suggestion.
Have a nice day.
My System SpecsSystem Spec
Reply

 Symbolic Link not working




Thread Tools



Similar help and support threads for2: Symbolic Link not working
Thread Forum
Is it possible to Create a Symbolic Link to a Non-Specific Directory? General Discussion
Change folder/file location - use Move, Symbolic link or Junction? General Discussion
RocketDock Docklets and 64bit programs (symbolic link) Software
Directory junction/symbolic link not working General Discussion
Link not working General Discussion
Symbolic link across drives? General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33