Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Major Mouse Lag/Stuttering


26 Dec 2012   #1

Windows 7 Home x64
 
 
Major Mouse Lag/Stuttering

I've been having this problem for the past couple of months and it's driving me insane. I've searched for hours on end without any luck of a fix.

The problem is that my mouse lags (or stutters) every 5 seconds. The lag can sometimes be so bad that the mouse completely stops working for a few seconds.

I've gone through 3 mice and they've all had the same problem so it can't be because of the mouse.

The mouse I'm currently using is the Logitech Anywhere MX.

Please help me, this is driving me insane!

Thanks,
Feriscool.

My System SpecsSystem Spec
.

26 Dec 2012   #2

Windows 7 Professional x64 Linux Mint 16
 
 

Run sfc /scannow

SFC /SCANNOW Command - System File Checker

I would also suggest uninstalling the drivers and rebooting, then let windows reinstall, but I`m sure you`ve done that.
My System SpecsSystem Spec
26 Dec 2012   #3

Windows 7 Home x64
 
 

Quote   Quote: Originally Posted by AddRAM View Post
Run sfc /scannow

SFC /SCANNOW Command - System File Checker

I would also suggest uninstalling the drivers and rebooting, then let windows reinstall, but I`m sure you`ve done that.
As far as I know, I didn't have to install any drivers for the mouse and wasn't able to find any on the logitech website.

As for the scan: "Windows Resource Protection did not find any integrity violations".
My System SpecsSystem Spec
.


26 Dec 2012   #4

Windows 7 Ultimate 64 bit
 
 

Not with out stating the obvious...but have you checked the batteries.
My System SpecsSystem Spec
27 Dec 2012   #5

Windows 7 Home x64
 
 

Quote   Quote: Originally Posted by bassfisher6522 View Post
Not with out stating the obvious...but have you checked the batteries.
Yes, I've tried tons of different batteries.
My System SpecsSystem Spec
27 Dec 2012   #6

Windows 7 Home x64
 
 

Bump!
My System SpecsSystem Spec
27 Dec 2012   #7

Windows 7 Ultimate x86
 
 

Go into device manager and locate the mouse, right click and into properties, go to uninstall device or similar, unlpug and plug mouse back in
My System SpecsSystem Spec
27 Dec 2012   #8

Windows 7 Home x64
 
 

Quote   Quote: Originally Posted by pedroc1999 View Post
Go into device manager and locate the mouse, right click and into properties, go to uninstall device or similar, unlpug and plug mouse back in
Just tried that and it didn't work.
My System SpecsSystem Spec
27 Dec 2012   #9

Windows 7 professional X64
 
 

Quote   Quote: Originally Posted by Feriscool View Post
Quote   Quote: Originally Posted by pedroc1999 View Post
Go into device manager and locate the mouse, right click and into properties, go to uninstall device or similar, unlpug and plug mouse back in
Just tried that and it didn't work.
have you tried using it as close as possible to the USB receiver?
My System SpecsSystem Spec
27 Dec 2012   #10

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Are you using a powered USB hub? I had similar issue with this and it was a bad USB transformer.
My System SpecsSystem Spec
Reply

 Major Mouse Lag/Stuttering




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:58 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33