Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: File Permissions Problem - Unable to Overwrite, Delete, Rename


07 Jan 2013   #1

Windows 7 Professional x64
 
 
File Permissions Problem - Unable to Overwrite, Delete, Rename

I've encountered an issue where I am unable to delete, rename, or overwrite existing files on my computer, at least with certain extensions (.dll, .exe). This happens, for example, when I try to install an upgrade of a program -- the installer cannot finish the upgrade because it cannot replace the existing files. I also cannot delete the existing/old files manually, because I get a permissions error. Screenshots of two sample errors are attached -- these are from tonight when I tried to upgrade my MalwareBytes Anti-Malware. I use Avast Antivirus and it does not show any viruses. MalwareBytes also reports no malware. I am using the only account on my computer, the administrator account. I also ran a registry cleaner (CCleaner) and HiJackThis, but nothing seems amiss. The problem began a few weeks ago.

Oddly, if I hit "Retry" enough times in the installer -- maybe 10 or 15 times in a row -- it eventually overwrites the file. So, I AM able to install updates, but I have to continually press "Retry" over and over for each file.

Here's what I've tried so far: (1) Disabling UAC; (2) Running an installer as administrator; (3) Right-clicking individual files in Windows Explorer, selecting "Properties" -> Security (When I do this, all permissions appear proper -- System, Administrators, and Users all have full access).


Thanks for anyone's help!



Attached Thumbnails
File Permissions Problem - Unable to Overwrite, Delete, Rename-file_error.jpg   File Permissions Problem - Unable to Overwrite, Delete, Rename-file_error2.jpg  
My System SpecsSystem Spec
.

07 Jan 2013   #2

W7 Pro SP1 64bit
 
 

have you tried
SFC /SCANNOW : Run in Command Prompt at Boot
repeat it several times
My System SpecsSystem Spec
Reply

 File Permissions Problem - Unable to Overwrite, Delete, Rename




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:02 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33