Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: laptop hangs intermittently when I close the lid

07 Mar 2013   #21

Windows 7 Home Premium 32bit
 
 

Yes a clean reinstall is the best policy over a factory installation which includes lots of unnecessary (and so troublesome) programs. An auto driver updater also not reliable always.

It is likely that the clean reinstall will solve your issue. Do it as suggested.

My System SpecsSystem Spec
.

25 Mar 2013   #22

win 7 home premium 64 bit
 
 

Hi all,

I've been unplugging my mouse before closing the lid for the last few weeks and it hasn't locked up. I don't know if this is a red herring, but it's kept me from dealing with the issue correctly for now. If the XPired-era driver program isn't good enough, is there one for the Windows 7 era? Device manager says the HID compliant mouse driver is up to date...

I'm enticed by the idea of a clean reinstall but worry about the hours of work it would take to set up my computer again. There has to be a middle-ground solution between the standard XP-era "reformat and reinstall";-) and my current do-nothing approach.

Thanks for your help, and sorry for not taking the best approach. At some point in a computer's lifecycle, you just give up and buy another

Val
My System SpecsSystem Spec
25 Mar 2013   #23
Microsoft MVP

 

There is no driver update program from Windows 7 because it is not needed. It is a driver-complete OS in the installer and via optional Windows Updates. If any other drivers are missing after reinstall and all rounds of Updates are done you should import them from the Support Downloads webpage for the PC or device model.

In your case, try another mouse - even a wired one if necessary - to see if the issue stops. Then you'll know for sure what causes it and you should replace the mouse or its driver.

Look in Control Panel>Mouse for all of its settings and try some different ones as well.
My System SpecsSystem Spec
.


07 May 2013   #24

win 7 home premium 64 bit
 
 

Thanks gregrocker,

My SSD showed up today, so I'll be doing a clean install in the coming days. hopefully the headache of installing all my current problems will be worth it. I'm looking forward to the double boost of SSD speeds and a clean install!

I'll do my best to follow the links you posted to the letter and hopefully it'll be smooth, quick sailing.

Val
My System SpecsSystem Spec
01 Mar 2014   #25

win 7 home premium 64 bit
 
 
similar problem on new SSD/install

Hi All,

It appears I never marked this thread as solved, for which I appologize. I have had my SSD and new clean install running flawlessly for he past ~8 months, but I now suffer from occasional lockups when suspending/sleeping/hibernating. In addition I have the following symptoms:


I'm not sure this is malware related, as none of the scanners show anything. But I don't really want to do another clean install, as bloatware isn't a problem this time around.

Any recommendations on next steps?

Thank you
My System SpecsSystem Spec
01 Mar 2014   #26
Microsoft MVP

 

Start working through the Troubleshooting steps in my signature pic below. Report back as you go.
My System SpecsSystem Spec
02 Mar 2014   #27

win 7 home premium 64 bit
 
 

Okay, I will be honest as to what all I've done of the 18 steps. You can point me back to some of the ones I skipped or left partially done. You can even say do everything, but I wanted to get something up here somewhat sooner than the days it would take to run all of them.

1. HD check: not done. It's a 9 month old SSD and benchmarking it seems wasteful of time. Can go back and download CrystalMark and run if needed
2. ran memtest86+ for 10 hours, no errors, but only on both RAM sticks, not each individually
3. it's a laptop, nothing done. Could remove and reinstall RAM and SSDs, but I feel like that's as likely to introduce problems as fix them
4. tried to install coretemp, but got the "Windows cannot access specified ..file" error. Will re-run in safe mode when I do it for MBAM. I then tried to run it again, and it said coretemp is not a valid Win32 application. This is a symptom I am trying to cure. During memtesting, the core temp was 49-50C, for what it’s worth.
5. updated mbam and ran in regular windows. Quickscan found: :\Users\[user]\Downloads\coretemp_d7632790.exe (PUP.Optional.InstallIQ) -> Quarantined and deleted successfully. (something in the coretemp file I just downloaded) I also ran in safemode, updated again, and found nothing with a full scan.
6. I uninstalled avast AV, and ran MSE, even though I heard that it’s no longer very good. Updated but didn’t find anything
7. Done, nothing added so far.
8. No real problems. Winamp is not up to date…
9. I could do a system restore to 4 weeks ago or so before I noticed the issues, but then all the fixes I’ve done so far would be rolled back, no?
10. Was already automatic
11. I searched for new display drivers, but nothing newer than 2012 is available. I already updated from intel HD 8.15.10.2057 (6/30/2010) to 8.15.10.2622 (1/10/2012)
12. Downloaded, but had ‘unspecified error’ when trying to install
13. Sfc /scannow found nothing, ran 2 times
14. Did clean install when I got my SSD 8 months ago
15. Event viewer for administrative events shows ~2500 events. It seems the frequency has climbed significantly since 12/1/2013. It was a hand full each day, until then and 10-20 thereafter. Would this indicate a time to restore to?
16. This Advanced Tools showed two errors related to the suspend issue: WuDfrd.sys caused delays in suspend. The Device listed was multicard and MB855 (which is my Motorola photon phone). I still use both of these, and update driver said the multicard drivers were current. I couldn’t find MB855 in device manager.
17. I want to hold off on doing this if possible
18. I followed these instructions when I installed Windows 7 on my SSD in May 2013
My System SpecsSystem Spec
02 Mar 2014   #28
Microsoft MVP

 

I would try the earliest System Restore point after taking note of what you'll need to reinstall. There's no reason to keep subsequent fixes which have not helped, and some may have made it worse.

MSE is still the most recommended OS here and has been since Windows 7 was in beta.

It specifically says how to handle Event Viewer repeat errors in the tutorial. I winnow out all of the repeat errors using that method. Are there clues to the hang in the Diagonostics>Performance log when it sleeps?

Check for firmware updates for the SSD, and a tool for diagnostics.
My System SpecsSystem Spec
Reply

 laptop hangs intermittently when I close the lid




Thread Tools



Similar help and support threads for2: laptop hangs intermittently when I close the lid
Thread Forum
Solved Laptop freezes intermittently. General Discussion
BSOD on laptop lid close BSOD Help and Support
Game keeps crashing, the process hangs when I close it in task manager Gaming
Crashes when I close my laptop lid BSOD Help and Support
BSOD When I close laptop lid BSOD Help and Support
What happens when I close my laptop? General Discussion
Media Player intermittently hangs BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:16 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33