Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Fonts - why do some work, others dont - anybody know?

15 Feb 2013   #1
AndyF

Windows 7 Ultimate 32 bit
 
 
Fonts - why do some work, others dont - anybody know?

Hi...

I have a bunch of fonts that have been with me since the advent of Windows (it seems). Recently I upgraded the machines on my network to Windows 7 and oddly, when I loaded the fonts back on board, some worked, some did not, without any real rhyme or reason.

Now, I find that opening some documents (in MS Word, and Publisher) present that substitute font dialog thats well, a bit of a pain in the backside.

Anybody know anything about this? Why do some come across just fine, others dont? I am happy to send samples if it helps - but I just dont know if this can be fixed or not, and would love to hear some kind of expertise though I know fonts are kind of "no worries, until they dont" type things.

Thanks!


My System SpecsSystem Spec
.
15 Feb 2013   #2
lehnerus2000

W7 Ultimate SP1, LM18 MATE, W10IP VM, W10 Home, #All 64 bit
 
 
Installed or Copied?

Did you install the fonts or simply copy them to the Fonts folder?
In W7 you have to manually install fonts.
My System SpecsSystem Spec
15 Feb 2013   #3
PooMan UK

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by lehnerus2000 View Post
Did you install the fonts or simply copy them to the Fonts folder?
In W7 you have to manually install fonts.
Soz pal, but you can install fonts in win7 by either selecting multiple fonts then "right mouse button" "install" or you can just select multiple fonts then copy and paste them into the "windows" "fonts" directory with no problems, I don't quite understand when you say you have to manually do it in XP you had to copy them into the "fonts directory" there was no install option
My System SpecsSystem Spec
.

15 Feb 2013   #4
lehnerus2000

W7 Ultimate SP1, LM18 MATE, W10IP VM, W10 Home, #All 64 bit
 
 
Umm ...

Quote   Quote: Originally Posted by PooMan UK View Post
Quote   Quote: Originally Posted by lehnerus2000 View Post
Did you install the fonts or simply copy them to the Fonts folder?
In W7 you have to manually install fonts.
Soz pal, but you can install fonts in win7 by either selecting multiple fonts then "right mouse button" "install" or you can just select multiple fonts then copy and paste them into the "windows" "fonts" directory with no problems, I don't quite understand when you say you have to manually do it in XP you had to copy them into the "fonts directory" there was no install option
Sorry I should have been more specific.
I was trying to find out what the OP had done with his font files.

What I mean by "manually" is that in XP, you just had to copy the font into the "Fonts" folder and they would install automatically (no additional actions required).

In W7, you "manually" have to choose the install option or the fonts won't be available.
On my PC, any font that I copy into the Fonts folder, is not available until I install it. (see Additional below and Post #6)

Worse still, once they are in the "Fonts" folder, they aren't considered to be normal files by many (if not all) programs.
  • Open Word
  • Navigate to the "Fonts" folder.
  • Set the file selector to "All Files (*.*)"
  • The folder is empty!
Fonts - why do some work, others dont - anybody know?-fonts-folder.png
A "wonderful improvement" in W7.

You can install multiple fonts simultaneously, as you describe (right click on the selection and choose "Install").

"So what I told you was true, from a certain point of view."

Additional
My previous install must have had a glitch.
My current install behaves as you suggest
Thanks for the information about how your install works, PooMan UK.


My System SpecsSystem Spec
15 Feb 2013   #5
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 10 Pro
 
 

I have had some fonts not show up in programs and I have to go in to the font properties and unblock it and install it again and then it showed up.

Jerry
Fonts - why do some work, others dont - anybody know?-kabel.otf-properties.png


My System SpecsSystem Spec
16 Feb 2013   #6
lehnerus2000

W7 Ultimate SP1, LM18 MATE, W10IP VM, W10 Home, #All 64 bit
 
 
Interesting

Quote   Quote: Originally Posted by Bongo View Post
I have had some fonts not show up in programs and I have to go in to the font properties and unblock it and install it again and then it showed up.
Interesting.

My previous install must have had a glitch (or two).

My previous install had problems with search in the Libraries (folder search worked correctly).
Since I reinstalled my W7 OS (in September) that problem hasn't reappeared (despite using the same settings).

Since I had font install problems previously, I always just select fonts (wherever they are) and use the install option.
What would happen previously, is that I could copy the file to the Font folder, but it would remain greyed out and it wouldn't appear in any programs, unless I installed it.

I just tried copying a font from my backup folder and it automatically installed.

Maybe they were being blocked.
I'm sure I tried it with fonts I copied from my W7 betas to a folder on my PC (not from the Internet).

These weird incidents always intrigue me (like how Firefox won't run for some people).
My System SpecsSystem Spec
16 Feb 2013   #7
AndyF

Windows 7 Ultimate 32 bit
 
 

Hi guys...

Thanks to you all for replies, but I think this is now a bit more confusing... I did install the fonts - that is, these old fonts (circa 80's in some cases) came on floppy disk (which I still have) and I ran the installs on those disks presuming it copied all the fonts to the fonts folder.

However, when you say "right click and select install" well, if I go to Fonts in control panel, NONE of the fonts listed show any "install" selection, but I can see that many fonts on those disks just are not there. For example, I have a disk of Agfa fonts (the camera, etc. people) and yet I notice only two of the fonts on their disk of about 30 actually appear in Fonts in the control panel. I also have a four disk set of fonts from the old Parsons Technology - all these fonts start with "PT" and there are about 100 of them - but I only see ONE in Fonts in the Control Panel?!?!

When I look at the fonts on the floppy disks, most have a filetail of "._tf" and somehow become ".ttf" (True Type Font) AFTER they are installed.

Do you think its worth trying to just copy them and THEN see if "Install" is available through the Fonts selection in Control Panel?

...and sorry to ask such an obvious question, but where is the Fonts folder - hanging off of "Windows"?

Thanks so much for the help.
My System SpecsSystem Spec
16 Feb 2013   #8
AndyF

Windows 7 Ultimate 32 bit
 
 

Hello again guys...

Well, I found the fonts folder itself and went through all my floppy disk installs for fonts. First, it seems as though when you copy a valid font to the fonts folder, it (Win7) installs the font itself. So its really just a matter of copying them over.

I found that in some cases, even if the font file had a weird name like "A36543._tf" it would install with a valid name in some cases. In other cases I got a dialog saying "This is not a valid font" so I guess in some cases, older fonts just are not going to cut it.

I'd say I got about 40-50% of the Fonts installed, and the others just wont install - not sure why but clearly things have changed in the many years since I got a lot of these so who knows what exactly the problem is, and I have resigned myself to the assumption that its going to be unlikely I can get any updated copies.

I guess I will just have to replace fonts in documents as the need arises, though I am going to research this a bit more to see if maybe there is some program or app that might update these, as in some cases, I have lost fonts which I made some heavy use of in old documents.

Thanks for all your help and if I learn anything more, I will post it here.
My System SpecsSystem Spec
16 Feb 2013   #9
lehnerus2000

W7 Ultimate SP1, LM18 MATE, W10IP VM, W10 Home, #All 64 bit
 
 
I'm not sure what ...

Quote   Quote: Originally Posted by AndyF View Post
Thanks to you all for replies, but I think this is now a bit more confusing... I did install the fonts - that is, these old fonts (circa 80's in some cases) came on floppy disk (which I still have) and I ran the installs on those disks presuming it copied all the fonts to the fonts folder.

However, when you say "right click and select install" well, if I go to Fonts in control panel, NONE of the fonts listed show any "install" selection, but I can see that many fonts on those disks just are not there. For example, I have a disk of Agfa fonts (the camera, etc. people) and yet I notice only two of the fonts on their disk of about 30 actually appear in Fonts in the control panel. I also have a four disk set of fonts from the old Parsons Technology - all these fonts start with "PT" and there are about 100 of them - but I only see ONE in Fonts in the Control Panel?!?!
Do you get the "Install" option if you right click on the files on the floppy?

Quote   Quote: Originally Posted by AndyF View Post
When I look at the fonts on the floppy disks, most have a filetail of "._tf" and somehow become ".ttf" (True Type Font) AFTER they are installed.
I'm not sure what a "._tf" file is.

I couldn't find a result on File-Extensions.org - File extension library

Quote   Quote: Originally Posted by AndyF View Post
...and sorry to ask such an obvious question, but where is the Fonts folder - hanging off of "Windows"?
Location
C:\Windows\Fonts
Fonts - why do some work, others dont - anybody know?-fonts-folder-location.png
Quote   Quote: Originally Posted by AndyF View Post
I'd say I got about 40-50% of the Fonts installed, and the others just wont install - not sure why but clearly things have changed in the many years since I got a lot of these so who knows what exactly the problem is, and I have resigned myself to the assumption that its going to be unlikely I can get any updated copies.

I guess I will just have to replace fonts in documents as the need arises, though I am going to research this a bit more to see if maybe there is some program or app that might update these, as in some cases, I have lost fonts which I made some heavy use of in old documents.
There is a site that will try to match pictures of a font to a Font face.
http://www.myfonts.com/WhatTheFont/


My System SpecsSystem Spec
18 Feb 2013   #10
AndyF

Windows 7 Ultimate 32 bit
 
 

Hi lehnerus2000,

Just to follow up on a few of your questions - Did I get an install option if I right-clicked the file on the floppy? No. But as I mentioned, if I copied the file from the floppy (drag and drop), when I dropped it into the Fonts folder, it installed itself. A little dialog comes up and says installing...

I found out that all a "._tf" file is the pre-installed "*.ttf" file, eg, a True Type Font File. Cheesey though it is these days, when I got a few of these font disks (probably late 80's) the Install program simply copied the file and renamed it. You could tell how old that was because it copied the files NOT to the now-well-known Font folder - but the \Windows\System! So it must have been Win 3.1, maybe Win 95.

Yeah, sorry about that - I figured out the Font Folder by going up to MSDN (duh...) and reading about it. That was when I did all the manual copying with some working, some not.

Thanks for the link to the Font Face site - I will check it out.

Thanks again!
My System SpecsSystem Spec
Reply

 Fonts - why do some work, others dont - anybody know?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Win 7 Ult x64 Start doesnt work Icons dont work
Attempted a restore in Safe Mode. System came back up with all icons as normal. Issue start button doesn't work, icons open file but there is not text or data...there is what appears to be wire frames where the information should be. All files still on drive but cannot access. Safe mode does...
General Discussion
old gfx cards work ... new ones dont...
hi all my problem is as follows i wus playing "Rift" with a geforce gts 250... played it for couple of weeks when suddenly while i wus playing my screen goes BLACK (i didnt do anything in particular) the computer also kept on beeping.... so i shut it down with the power button... ...
Graphic Cards
USb dont work
No usb devices work what should i do
Drivers
Ctrl +alt + del dont work
If i click ctrl + alt + del nothing happens. I tried few threads on forum, buit nothing worked. I want to have window where its log off, task manager, change password and some other(default) stuff were, when I press ctrl alt del. Ok I found it. This is what I want to have when I press ctrl...
General Discussion
f9-f12 dont work
brand new computer, brand new keyboard, brand new clean install of windows 7 (it did it before this and after this). here's the issue: f1-f8 work fine for everything in every program, f9-f12 dont do anything anywhere as far as i can tell. f9 has the play/pause function, f10 stop, f11 rewind, f12...
Hardware & Devices
Theme dont work right ?
Hi, I just fixed a new theme but noticed that the only thing that changes is the background image and nothing else :/ Look at the buttom, shouldent it change colour from gray ? :/ Same with all windows same colour http://img200.imageshack.us/img200/4641/53810872.png ...
Themes and Styles


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App