Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Autoplay not working

12 Apr 2013   #1
Retiredbill

Win7, home premium, 64 bit
 
 
Autoplay not working

Autoplay on my desktop has stopped working. I have to go to Windows Explorere and open the DVD drive to access the proper exe file. It does not work for software or for music or for my rescue disk or the original Win7 OS software. I had the autoplay set up for "ask me every time" and I changed it to "play using Windows Media Player" for CDs and that still didn't work. Any suggestions?


My System SpecsSystem Spec
.
12 Apr 2013   #2
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Hi RetiredBill

Click start type REGEDIT inside the Search programs and files box press <ENTER> . On the UAC window click on Yes . Once the registry opens up navigate to

Code:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Delete NoDriveTypeAutoRun if present .
My System SpecsSystem Spec
12 Apr 2013   #3
Retiredbill

Win7, home premium, 64 bit
 
 

I went to where you suggestedbut there is no "explorer" as a sub folder under "policies", only an entry labeled REG_SZ. What should I do?
My System SpecsSystem Spec
.

12 Apr 2013   #4
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Right click on Policies folder choose New > Key . Name it Explorer

:ADDED:

Check this registry hive as well

Code:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
Delete NoDriveTypeAutoRun if present as well
My System SpecsSystem Spec
12 Apr 2013   #5
Retiredbill

Win7, home premium, 64 bit
 
 

I went to the local machine and "explorer" did exist under "policies". There are 4 keys but none of them ar "nodrivetypeautorun". I also added the "explorer" under "policies" in the current user listing but it still has no key or entry. What's next to do?
My System SpecsSystem Spec
12 Apr 2013   #6
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Did you add the Explorer folder inside the HKEY_LOCAL_MACHINE ?

:ADDED:

See if this link below is of any help

AutoPlay - Enable or Disable
My System SpecsSystem Spec
12 Apr 2013   #7
gregrocker

 

It is risky to have consumers edit their registry when these controls are avaiable in the Control Panel under Default Programs>AutoPlay settings.
My System SpecsSystem Spec
12 Apr 2013   #8
Retiredbill

Win7, home premium, 64 bit
 
 

That is the problem. As I mentioned before, the autoplay settings are already set in control panel and it still doesn't work. This is also a change in that it hs always worked but all of a sudden decided to stop working.
My System SpecsSystem Spec
12 Apr 2013   #9
VistaKing

Windows 7 Ultimate 32-Bit & Windows 7 Ultimate 64-Bit
 
 

Retiredbill

Have you looked at the link above
My System SpecsSystem Spec
12 Apr 2013   #10
gregrocker

 

Quote   Quote: Originally Posted by Retiredbill View Post
That is the problem. As I mentioned before, the autoplay settings are already set in control panel and it still doesn't work. This is also a change in that it hs always worked but all of a sudden decided to stop working.
In that case did you try to System Restore to before this began?
My System SpecsSystem Spec
Reply

 Autoplay not working




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Autoplay not working
The autoplay feature stopped working. Whenever I plug in a removable disk autoplay won't launch. This is strange because it is already enabled in Control Panel. Any idea how can I fix this? :(
General Discussion
autoplay not working x64 bit
Recently autoplay is not working.Whenever I insert pen drive,cd,dvd ,dongle no autoplay.It worked earlier.Installed no new software.Tried everything registry,autoplay from control panel,gpedit noe works.Plz help It's very annoying. I have avast free antivirus 2014 and malwarebytes free.
Hardware & Devices
Autoplay not working
When I put an audio disk in my disk drive the autoplay does not open the disk. I have open autoplay and selected Itune to open the disk, selected autoplay check box and saved. Then I rebooted the system, inserted a disk and only the Roxio burn icon appeared. I tried to deselect the autoplay check...
General Discussion
Autoplay not working when using CD drive
Hello, I have a problem with the autoplay, USB and card reader are fine however when using either music CD, or DVD or software CD the autoplay doesn't kick in, when I browse the disk and select autoplay manualy it will start, I have set up everything in my autoplay setting in the control panel...
Hardware & Devices
AutoPlay stopped working, help.
OS is 64-bit. AutoPlay worked fine for a long time. Then I must have installed a piece of software that now prohibits it from working. Tried to force it to work with Windows AutoPlay from the Control Panel. No luck. Tried to trace down the source of the problem. No luck. I'm out of ideas. Any one...
Customization
Autoplay is 'mixed up' and not working.
Running Win 7 Home Prem 64 bit and autoplay will not run a software instal CD/DVD. I have reset all autoplay defaults to "Take No Action" except Software and Games which is set to "Instal or run prog". I have restarted Win to ensure these stick. When I try to install a prog from the CD the...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App