Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: After W7 Clean Install Turbo Boost missing


18 May 2013   #1

Windows 7 Home Premium 32bit
 
 
After W7 Clean Install Turbo Boost missing

Hello,


I recently bought a new laptop LENOVO Z500 that came with a Windows 8 64-bit OS. I clean installed Windows 7 Pro 32-bit coz our company program needs this partiular OS. Now i've successfully installed all drivers that had an exclaimation mark from the device driver window. But the problem is that I cant find the turbo boost option from the services.msc menu. does that mean that turbo boost won't kick in anymore? how can i fix this?

I checked from the download site of lenovo where i got all the drivers but there wasnt any TURBO BOOST DRIVER download present.

Please help out. I'm sensing from a couple of autocad work that I did theres some kind of lag going on. so it got me thinking that the TURBO BOOST aint working anymore.


here's the unit specs:

Operating System
Microsoft Windows 7 Professional 32-bit


CPU
Intel Core i5 3320M @ 2.60GHz 62 C
Ivy Bridge 22nm Technology


RAM
4.00GB Single-Channel DDR3 @ 798MHz (11-11-11-28)


Motherboard
LENOVO INVALID (U3E1) 59 C


Graphics
Generic PnP Monitor (1366x768@60Hz)
Intel HD Graphics 4000 (Lenovo)
2048MB GeForce GT 635M (Lenovo) 51 C


Hard Drives
932GB Seagate ST1000LM024 HN-M101MBB (SATA) 38 C


Optical Drives
HL-DT-ST DVDRAM GU70N
WPCHUV OPQVCTY SCSI CdRom Device
DTSOFT Virtual CdRom Device


Audio
Realtek High Definition Audio



Attached Images
 
Attached Files
File Type: pdf PrintPreview.pdf (53.4 KB, 0 views)
My System SpecsSystem Spec
.

18 May 2013   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi Zyrandiel, Did you install the chipset driver from Lenovo ? this will include the turbo boost
My System SpecsSystem Spec
19 May 2013   #3

Windows 8.1 Pro (x64)
 
 

You don't need a driver for TurboBoost, that is part of the CPU. It functions without Windows or any other system.
My System SpecsSystem Spec
.


19 May 2013   #4
Microsoft MVP

 

Check in BIOS Setup to see if Turbo Boost needs to be enabled. If not what appears different from the way this feature worked before, just the lag?

Have you run all rounds of Important and Optional Windows Updates, after enabling Automatically get recommended drivers and updates for your hardware (Step 3)? This is how drivers are handled in Windows 7 for the most part.

If it isn't provided, in addition to the chipset as suggested by Kathryn I'd also install from the Lenovo Support Downloads webpage the Intel Management Engine Interface for Windows 7 (32-bit, 64-bit) - Notebook. http://support.lenovo.com/en_US/downloads/default.page?
My System SpecsSystem Spec
Reply

 After W7 Clean Install Turbo Boost missing




Thread Tools



Similar help and support threads for2: After W7 Clean Install Turbo Boost missing
Thread Forum
Help with Turbo Boost Hardware & Devices
Solved Turbo Boost -- what gives? Hardware & Devices
I need to help about turbo boost technology Hardware & Devices
Turbo Boost Monitor Software
Intel turbo boost Hardware & Devices
i7 turbo boost Hardware & Devices
Turbo Boost Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:58 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33