Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Asus laptop totally not receiving any power/ not booting.

30 May 2013   #1
Raynian

Microsoft Windows 7 Professional 64-bit
 
 
Asus laptop totally not receiving any power/ not booting.

I've a 3 years old Asus laptop. Recently tried to power it on, but I realised that it isn't even receiving any electricity from the charger.

The orange LED which will light up when it is charging doesn't light up..

Screen is a full black screen when I power it on.. Nothing happens. Tried using Battery power, nothing happens too.

Could it be short circuit ? =/

Any opinions are welcome ~

EDIT :

To add on, before my laptop gave up on me, there's this message : " Reboot and Select the Proper Device or Media. " .


My System SpecsSystem Spec
.
30 May 2013   #2
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

You have to test the charger with a multi meter. The charger should tell you how much it`s supposed to put out on the label. Usually 19.9 volts.
My System SpecsSystem Spec
30 May 2013   #3
Raynian

Microsoft Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by AddRAM View Post
You have to test the charger with a multi meter. The charger should tell you how much it`s supposed to put out on the label. Usually 19.9 volts.
Will have to get one and try.

But the green LED of my charger is lit up, so it should be working ?
My System SpecsSystem Spec
.

31 May 2013   #4
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

That just means the charger is getting power, but it still might not be converting the ac current to dc likes it`s supposed to.

I had one do the same thing.
My System SpecsSystem Spec
31 May 2013   #5
Raynian

Microsoft Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by AddRAM View Post
That just means the charger is getting power, but it still might not be converting the ac current to dc likes it`s supposed to.

I had one do the same thing.
Ahh I see.. point noted.

I am only concerned if the issue lies with the laptop.. Because booting using Battery doesn't work too.
My System SpecsSystem Spec
Reply

 Asus laptop totally not receiving any power/ not booting.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Asus not booting properly, boot options don't work consistently
I'm having trouble with my Asus desktop not booting properly. I get this message: "Reboot and Select proper boot device or Insert Boot Media in Selected Boot device and press a key" I have tried setting the boot options variously switching between manually setting between the boot options...
General Discussion
My ASUS booting screen does not show on startup
This morning, when I was turning on my computer. (My computer is a Windows 7 64-bit, and the model is an ASUS CM5571) the ASUS logo did not appear in the beginning, however the rest of my computer turned on like normally. Whenever I usually turn on my computer, the first screen I see is this:...
General Discussion
Asus 74 booting problem please help
I Have a ASUS GS74S Series that will not boot up. I have run and tryed everything under the sun. the problem signatures i am getting are problem sig 1-6.1.7600.16385 problem sig 2-6.1.7600.16385 problem sig 3- unknown problem sig 4- 21200154 problem sig 5- AutoFailover problem sig 6-15...
General Discussion
Asus Laptop can't find startup entries for Asus Programs
Asus has some way of starting their programs that I can't find. In particular, I want to disable their Wireless Console 3 (wcourier.exe). There are other programs but I can't remember what they are right now. I can only tell you that is does not show up in msconfig or HJT. Does anybody know...
Performance & Maintenance
New Laptop Having Issues Receiving Wireless IP Address from Router
So my friend just came over to my house today to use his fancy totally brand new MSI GE60 that he got from Newegg. This was the first time he was using his brand new laptop with a wireless network, and I need to specify that nobody else who has ever visited my house before has had problems with my...
Network & Sharing
Windows 7 professional x64 stucks while booting on ASUS A52J laptop
Hello. I have new laptop, ASUS A52J, i3 processor, 4 GB of memory, 640 GB hdd and so on. It runs legal Windows 7 professional, x64 system and it usual memory usage after booting is around 40% as I have many applications loaded on boot (Skype, MSN, Hamachi, Avast, MSE, and few other...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App