Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Some programs will not open. Just say "X" has stopped working

03 Jun 2013   #1
calhall4892

Windows 7 home x64
 
 
Some programs will not open. Just say "X" has stopped working

Hi

Im not sure if this is in the correct area so apologies if it isn't. I've been having this problem for about 2 weeks now where a number of programs fail to open and just say "X" has stopped working. I have tried selecting "check online for a solution" but nothing happens.

I have searched online for any solutions and have tried to run sfc /scannow to check the system files, however this freezes at 87% and after a while says "could not perform requested operation. I will attach the log.txt file from the scan.

Any help would be greatly appreciated and any further questions I will answer


My System SpecsSystem Spec
.
03 Jun 2013   #2
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Hi and Welcome to the Forum
This problem may be caused by a faulty update so can you try a system restore to a date before it started to happen.
if that's no good it cauld be that you have a virus. Run Malwarebytes if the System restore doesn't work.
My System SpecsSystem Spec
03 Jun 2013   #3
problemshredder

Windows 7 Ultimate x86
 
 

what are the several programs that cause this ? you can list some of them here for reference as it may not be the os but just individual programs issue.
My System SpecsSystem Spec
.

03 Jun 2013   #4
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I would think that it would be too much of a coincedence for a number of programs to act in the same way at the same time! I think it must be general problem not related to an individual program! We will see when the OP comes back.
My System SpecsSystem Spec
04 Jun 2013   #5
calhall4892

Windows 7 home x64
 
 

Hi

I tried to system restore but there are no restore points. I downloaded malwarebytes and started to run it but it freezes on d3dcompiler_43.dll
My System SpecsSystem Spec
04 Jun 2013   #6
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Have you got System Restore turned off then? Your system Specs don't show what anti virus you're running. Whichver one disable it and then try to run Malwarebytes!
My System SpecsSystem Spec
05 Jun 2013   #7
calhall4892

Windows 7 home x64
 
 

would like to say thanks to everyone who helped. Found out eventually that a few of the shortcuts had become corrupted and that if I went in through the program files to the original .exe file it would work
My System SpecsSystem Spec
05 Jun 2013   #8
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by calhall4892 View Post
would like to say thanks to everyone who helped. Found out eventually that a few of the shortcuts had become corrupted and that if I went in through the program files to the original .exe file it would work
Good that you have ssolved it but do you know how the shortcuts got corrupted? Also I would look into why there are no Restore Points on your system. You might need them in the future! Also run Mlwarebytes. If it stalls again you really should solve that problem. You might have a problem and if you have you can bet your life it will come back and bite you. What A/V are you running and is it uo to date?
My System SpecsSystem Spec
05 Jun 2013   #9
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Please read mitchell65 post #8 again and answer the questions.
That is some good advice.
Problems don't fix them self.
My System SpecsSystem Spec
Reply

 Some programs will not open. Just say "X" has stopped working




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Almost all programs "has stopped working"
So I started my computer and it said "IAstoricon.exe" has stopped working, along with some other programs i didnt have the time to write down, after this I attempted to open programs and 80% of them are unopenable and immediately say "(program name) has stopped working", i have tried disabling...
General Discussion
Lots of programs "have stopped working". Also glitchy screen.
An issue came up on my comp recently, and it's the "x program has stopped working, windows is trying to find a solution", this happens randomly when I'm playing games like League of Legends or Final Fantasy 14, it even happens to Skype, and most importantly, sometimes it happens to Windows Explorer...
General Discussion
Programs say "... has stopped working" when playing games.
Hello, Lately I've been suffering from crashes. When playing games like PayDay 2 and League of Legends. The game suddenly crashes and a bunch of running programs show "... Has stopped working". It doesn't crash into a BSOD but the programs won't start again. Except for 1 time I actually got a...
BSOD Help and Support
Frequent "application has stopped working" error messages -Win7 x86
For about the past 3 month I have started to see fairly frequent app crashes with the "application has stopped working error". It appears this started the week of 4/8 (from what I can tell via Reliability Monitor.) Here are some of the applications that have been affected: Zune.exe wlmail.exe...
BSOD Help and Support
Unsure how to best describe issue... Open programs try to "re-open"
For instance, if playing solitaire, the icon for the open program down on the task bar will start "sliding in" over top of itself again, as if it is just being reopened. I am sorry I really don't know how else to explain it. But when it happens it goes very quick sometimes with rapid successions of...
General Discussion
Various programs "have stopped working" + other probs
Hi all. I'm pretty much at my wits end with this problem now, and it seems, bizarrely, to have followed me from one machine to another. Here's a rundown: My old machine(emachines e3042 - 2GB ram - Celeron D 3.2ghz - ATI Radeon X300) was running just fine with XP up until a few months ago. Then i...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App