Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: How long to start populating Prefetch folder?

21 Jun 2013   #1
OvenMaster

Win7 Pro 32bit; Zorin OS 9 Core (in VM)
 
 
How long to start populating Prefetch folder?

Because I got a new motherboard, I had to do a clean reinstall of Win 7 Pro 32-bit SP1 on June 9. Here it is June 21 and my Prefetch folder has zero program entries. In addition, possibly related, from the time I boot my PC until all the hard drive thrashing is finished is 2 min, 15 sec. Soluto said that a full 58-65 seconds of that was Avira Free loading and scanning at boot. It also takes a long time to launch any other programs, no matter what they are. Virus and malware scans are clean.

I've done a site search for this. I checked the Registry for that key value that tells Windows to prefetch everything, and I do not use CCleaner to clean out old prefetch entries. I have checked the Prefetch folder for content at random times and there's never any new entries there, even days after booting and running (I run Folding@Home 24/7).

What gives? Any ideas? I'd appreciate some insight.




Attached Thumbnails
How long to start populating Prefetch folder?-prefetch.jpg  
My System SpecsSystem Spec
.
21 Jun 2013   #2
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I have read many post on this form where people are having problems of all kinds using Avira.

I recommend removing Avira using their on line method and installing this for a test.

Microsoft Security Essentials - Microsoft Windows

If you are using Ready Boost I recommend not using it and install more ram. Your motherboard is fully capable of up to 32 gigs with 4 ram slots. All ram should be matching ram.
My System SpecsSystem Spec
21 Jun 2013   #3
OvenMaster

Win7 Pro 32bit; Zorin OS 9 Core (in VM)
 
 

I've been considering moving back to Avast because of good performance reviews.
AFAIK, ReadyBoost is used for external drives. I have none.
How will installing more RAM help? I'm maxed out using Win7 32-bit.
I've even wondered if I should revert to IDE mode and MS drivers for my hard drives instead of AMD AHCI drivers.
I"m trying to figure out what I did wrong at some point, because I never had this trouble with my old ASRock board...
My System SpecsSystem Spec
.

21 Jun 2013   #4
MilesAhead

Windows 7 32 bit
 
 

Try setting BOTH EnablePrefetcher and EnableSuperfetch registry settings to 3. That's how MS sets them as default. I find my prefetch populates quite quickly. I often delete the program prefetch just for grins. The boot prefetch(which is in the readyboot subfolder) I don't bother to clear unless I made changes to the startup programs. You get one slow boot if you delete ReadyBoot contents. Then it's cached.
My System SpecsSystem Spec
21 Jun 2013   #5
OvenMaster

Win7 Pro 32bit; Zorin OS 9 Core (in VM)
 
 

I'll try that later.

I've also done a bit more online research and I've discovered that there is no layout.ini file in my prefetch folder... or anywhere else on my computer, for that matter.
My System SpecsSystem Spec
21 Jun 2013   #6
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Well I didn't notice that in your system specs (32) bit. Sorry about that. That just means it would be a good time to go to Windows 64 bit.
My System SpecsSystem Spec
21 Jun 2013   #7
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Same problem with Troubleshoot Application Conflicts by Performing a Clean Startup ? Revert to normal boot after testing!
My System SpecsSystem Spec
21 Jun 2013   #8
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Quote   Quote: Originally Posted by OvenMaster View Post
I'll try that later.

I've also done a bit more online research and I've discovered that there is no layout.ini file in my prefetch folder... or anywhere else on my computer, for that matter.
Try this to rebuild the layout.ini prefetch file.

Quote:
a) Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow
b) Type the following command, and then press ENTER:
c) Rundll32.exe advapi32.dll,ProcessIdleTasks
Note: This will rebuild the layout.ini file, even if it has been deleted from %windir%\Prefetch.
Source: layout.ini is missing in my Prefetch folder. - Microsoft Community
My System SpecsSystem Spec
21 Jun 2013   #9
OvenMaster

Win7 Pro 32bit; Zorin OS 9 Core (in VM)
 
 

Quote   Quote: Originally Posted by DavidW7ncus View Post
Quote   Quote: Originally Posted by OvenMaster View Post
I'll try that later.

I've also done a bit more online research and I've discovered that there is no layout.ini file in my prefetch folder... or anywhere else on my computer, for that matter.
Try this to rebuild the layout.ini prefetch file.

Quote:
a) Click Start, click All Programs, click Accessories, right-click Command Prompt, and then click Run as administrator. If you are prompted for an administrator password or for a confirmation, type the password, or click Allow
b) Type the following command, and then press ENTER:
c) Rundll32.exe advapi32.dll,ProcessIdleTasks
Note: This will rebuild the layout.ini file, even if it has been deleted from %windir%\Prefetch.
Source: layout.ini is missing in my Prefetch folder. - Microsoft Community
I had run the ProcessIdleTasks thing automatically every four days via Task Scheduler and it never rebuilt layout.ini.

But I did manage to fix it.

Turns out that MilesAhead had the clue. I checked my Registry as he suggested, and all entries had a value of "3".

Then I opened up Services. Superfetch was marked as "Manual" and "Stopped". I started the Superfetch service, changed startup to Automatic. Ran a few programs and immediately found them in Prefetch. I rebooted, ran ProcessIdleTasks, and voila: a normal Prefetch folder with a fresh layout.ini!

I think I can mark this one solved, gents. Thanks for the help!


Attached Thumbnails
How long to start populating Prefetch folder?-prefetch2.jpg  
My System SpecsSystem Spec
21 Jun 2013   #10
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

System service SUPERFETCH startup=automatic. That's default setting
My System SpecsSystem Spec
Reply

 How long to start populating Prefetch folder?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
A Batch file to bypass adminstrator popup [Prefetch folder] ~
Hello again guys! As I mentioned in the thread title, I want to make a .bat file that can delete each file and folder inside C:\Windows\Prefetch ~ I actually made one but it can't delete any thing in Prefetch folder until I open the folder, seeing that annoying popup below and click continue,...
General Discussion
prefetch folder
hi.i have WIN 7 64bit. i just get the attention from tune up program that some files in the prefetch folder is deleted by me or a program. idon't know if it is dangerous? if yes please tell me what should i do for repairing.THX!!
Performance & Maintenance
Prefetch folder is deleted.system running extremely slow
i am running windows 7 ultimate 64bit edition.i have tuneup utilities 2012 installed.couple of days back it notified me that some other program deleted my prefetch folder and i may experience slow log on and boot process.from that day my computer is running extremely slow and booting and logging...
Performance & Maintenance
may i purge the Prefetch folder?
hi sometime under w7 i had to purge/delete all the file inside the Prefetch folder reboot ,use the pc and after the second reboot , the pc is faster i was used to do one every 5 months could i do in w7?
General Discussion
I was deleted the Prefetch folder
I was deleted the folder C:\Windows\Prefetch.And my computer start 4 minutes since 2 weeks.What can I do? msconfig/startup only antivirus program Sorry I'm Turkish.My english is bad.
Performance & Maintenance
Start menu icons populating slowly, help?
When I click the start button and the menu opens, I notice that many of the icons take extra time to load. What can be done about this? :geek: FYI, this does not happen all the time, but it is kind of annoying Tried this:...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App