Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: why is my C:\Windows\Prefetch empty?

28 Jun 2013   #1
drugo

windows 7 ultimate 64bit
 
 
why is my C:\Windows\Prefetch empty?

Hi

i run w7 ultimate 64bit

and my C:\Windows\Prefetch is empty

i used total commander to see hidden folder and file , empty

I enable Show hidden files, folders and drives and system file is empty again

i reboot several time and it's still empty

i -> run ->Rundll32.exe advapi32.dll,ProcessIdleTasks

and it's still empty

can i fix it?

thanks


My System SpecsSystem Spec
.
28 Jun 2013   #2
bobafetthotmail

Win 7 Pro 64-bit 7601
 
 

Windows 7 disables prefetch if it detects a fast-enough drive at installation. SSDs for example.

this tutorial to enable it again. May or may not provide improvements if you are on a SSD.
My System SpecsSystem Spec
28 Jun 2013   #3
drugo

windows 7 ultimate 64bit
 
 

Quote   Quote: Originally Posted by bobafetthotmail View Post
Windows 7 disables prefetch if it detects a fast-enough drive at installation. SSDs for example.

this tutorial to enable it again. May or may not provide improvements if you are on a SSD.
EnablePrefetcher is 3
and EnableSuperfetch is 3 too

what's wrong?
My System SpecsSystem Spec
.

28 Jun 2013   #4
bobafetthotmail

Win 7 Pro 64-bit 7601
 
 

write "services" in the start menu searchbox, select the "services" entry with the gear icon.
Find a service called Superfetch in the list. Rightlick, select Properties, and then select startup type "automatic" from the drop down menu in the middle of the properties panel. Select "start". Now it should start drop a ini file in his folder, and eventually add more odd-named files with time.
Boot time may will take a bit longer for the next 4-6 times due to it scanning what is going on and optimizing.
My System SpecsSystem Spec
28 Jun 2013   #5
drugo

windows 7 ultimate 64bit
 
 

Quote   Quote: Originally Posted by bobafetthotmail View Post
write "services" in the start menu searchbox, select the "services" entry with the gear icon.
Find a service called Superfetch in the list. Rightlick, select Properties, and then select startup type "automatic" from the drop down menu in the middle of the properties panel. Select "start". Now it should start drop a ini file in his folder, and eventually add more odd-named files with time.
Boot time may will take a bit longer for the next 4-6 times due to it scanning what is going on and optimizing.
hi
i'm italian too , i don't know the name in italian of the service

by the way , i restore an image but i got only these files

Code:
ReadyBoot\
AgAppLaunch.db
AgGlFaultHistory.db
AgGlFgAppHistory.db
AgGlGlobalHistory.db
AgGlUAD_P_S-1-5-21-636928848-2182180944-2936143175-1000.db
AgGlUAD_S-1-5-21-636928848-2182180944-2936143175-1000.db
AgRobust.db
Layout.ini
PfSvPerfStats.bin
and inside the redyboot
i have only Trace1.fx

and i run lots of programs
thanks
My System SpecsSystem Spec
28 Jun 2013   #6
bobafetthotmail

Win 7 Pro 64-bit 7601
 
 

Yeah, it's annoying that they changed all the names, every time I need to troubleshoot I need to find what the heck they translated a particular thing into.

it's Ottimizzazione avvio in italian.
My System SpecsSystem Spec
28 Jun 2013   #7
drugo

windows 7 ultimate 64bit
 
 

Quote   Quote: Originally Posted by bobafetthotmail View Post
Yeah, it's annoying that they changed all the names, every time I need to troubleshoot I need to find what the heck they translated a particular thing into.

it's Ottimizzazione avvio in italian.
hi
thanks
it's set to manual
should i change it?

thanks again!
My System SpecsSystem Spec
28 Jun 2013   #8
bobafetthotmail

Win 7 Pro 64-bit 7601
 
 

as I said in the post above, it should be set as "automatic" and should say "started" all the times when you look in the lists of services, or it is not working.
My System SpecsSystem Spec
28 Jun 2013   #9
drugo

windows 7 ultimate 64bit
 
 

Quote   Quote: Originally Posted by bobafetthotmail View Post
as I said in the post above, it should be set as "automatic" and should say "started" all the times when you look in the lists of services, or it is not working.
thanks!

you solved my issue!!!!

thanks
My System SpecsSystem Spec
Reply

 why is my C:\Windows\Prefetch empty?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
prefetch folder
hi.i have WIN 7 64bit. i just get the attention from tune up program that some files in the prefetch folder is deleted by me or a program. idon't know if it is dangerous? if yes please tell me what should i do for repairing.THX!!
Performance & Maintenance
Windows 7 Startup Folder Empty (visible, but empty)
My computer was hit a malware. I was able to clean/quarantine the malware, but my startup folder is empty. From the Windows logo start, I am able to see the folders in "All Programs". But all the folders are empty. These startup folders are also empty when I navigate to their locations in Window...
General Discussion
Prefetch and SSDs
My understanding from reading the MSDN blog was that prefetch and defrag were to be disabled for SSDs with "good performance." I have a second generation Intel X25-M 80GB as my boot drive which I believe qualifies as a "good performing" SSD. I do see that defrag is disabled for my SSD (C:...
Performance & Maintenance
question about prefetch
hi i have a question about prefetch well xp , after booting and after 1 or 2 minutes ,create the file NTOSBOOT-*.pf and after with this file and others optimaze the boot and the programs that start up about w7 , i did notice that after some time of idle , w7 start to work and edit these...
Performance & Maintenance
Prefetch? On, Or Off?
Prefetch? On, Or Off? Dumb Question.. Is It Best To Have Prefetch Service On? Or Off? Does It Make Any Difference In Speed? Thanks
Performance & Maintenance
Prefetch data deleted.
I am currently running the 7022 32bit build. For some unexplainable reason my prefetch data gets deleted everytime I restart. Resulting in me losing all changes I make to my system. Anyone out there with suggestions? Regards.
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:17.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App