Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Startup repair after SSD upgrade on dual boot system, need help!

04 Jul 2013   #1
toner

Windows 7 Professional 64
 
 
Startup repair after SSD upgrade on dual boot system, need help!

Hello all, Having a little issue here, though I have a slight workaround to get my system running it's still very annoying and confusing.

I have a dual boot system. I had 2 Samsung 840 120GB SSDs and a separate Win 7 x64 installation on each (one tweak for Pro Tools DAW). I got a brand new Intel 520 180GB cheap and did the drive clone with EaseUS Todo backup which worked GREAT (typing from that Intel SSD install now).



Here is my problem:

When I turn on my computer and the dual boot screen comes up, it asks which windows I want to load and the timer is @ 30 seconds, and whatever option I pick it says to run startup repair and I can't go any further.

When I load my startup repair disc and pick either of the Windows 7 installations, it says it could not detect any problems and to restart.

When I restart, the default selection timer is back at the 3 seconds I originally had before I upgraded the SSD and either Windows Installation loads.

I've been thinking and thinking and maybe this has something to do with it:
When I originally installed my SSDs, I had the cables swapped and wanted SATA0 as Win 7 home use and SATA1 as Win 7 DAW use (OCD thing with the numbering and cabling). Well I accidentally plugged them in wrong. So when I switched to the intel drive I switched my cabling the way I wanted it.

But the more I think about it, the startup repair disc says no errors and when I restart from the startup repair options it works, until I shut down of course, then I need to use the startup disc/restart method again.

Anyways, any Ideas?

Thanks!


My System SpecsSystem Spec
.
04 Jul 2013   #2
lehnerus2000

W7 Ultimate SP1, LM18 MATE, W10IP VM, W10 Home, #All 64 bit
 
 
EasyBCD

Cloning may have given the same UUID to both W7 drives.
If that happened your PC is probably getting "confused" about which install to start.

I accidentally did this with a Ubuntu partition (on my old setup).
I had Ubuntu partitions on my old and new HDDs.
The Ubuntu partition that responded first was the one that started, not necessarily the one I wanted (i.e. it was totally random which HDD was actually running Ubuntu).

You are supposed to be able to change the UUID, but I have no idea how you do that in W7.

Do you have a access to EasyBCD?
You may be able to fix your issue using it.

There seems to be a free version:
EasyBCD - NeoSmart Technologies

You may want to wait until one of the "boot experts" looks at this thread.
My System SpecsSystem Spec
04 Jul 2013   #3
toner

Windows 7 Professional 64
 
 

Thanks for the reply, I will download it and wait for further instruction since I don't want to mess anything up!
My System SpecsSystem Spec
.

04 Jul 2013   #4
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Can you post a screen shot of Disk Management?
Disk Management - Post a Screen Capture Image

A clone "copies" an entire Disk (HD or SSD), including all partitions.
Or, did your clone copy 2 SSD's to a single SSD???

It's not clear to me how/what you cloned from a dual boot using two SSD's to a new SSD, and retained dual booting...
Do you have the new cloned SSD, and the original two SSD's with the OS's still intact?
So, you now have 3 SSD's connected that have an OS installed...???
I think the DM screen print will help answer this...

Imaging may work better for you, as it "copies" per partition.
Wait for the experts for best advice...
My System SpecsSystem Spec
04 Jul 2013   #5
ICIT2LOL

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10
 
 

I had a similar problem when 8 was in beta and I ended up wiping and doing away with the dual 7 & 8 boot.

Now I don't know if it is possible but could the SSD that toner wants be wiped clean and then use Macrium Reflect to drag and drop the partitions (OS's) from the other two drives onto it??

Just a thought.

An after thought WHS might be the fellow who would know about this stuff
My System SpecsSystem Spec
04 Jul 2013   #6
gregrocker

 

We need to see the screenshot of Disk Mgmt first.

But in general with separate HD's it's best to install each OS with the other HD unplugged, then set preferred HD to boot first, boot the other(s) using the one-time BIOS Boot Menu key. If you don't like this arrangement then install EasyBCD to the primary to add the other OS HD's. This still keeps them independent however so that you can remove one.

You can still arrange them this way by Marking Partition Active any OS or it's System Reserved partition that lacks a System flag, then unplugging all other HD/SSD's to run Startup Repair - Run up to 3 Separate Times until it boots itself and wears the System Active flags. Then plug others back in, boot preferred via the BIOS.
My System SpecsSystem Spec
05 Jul 2013   #7
toner

Windows 7 Professional 64
 
 





Disk Management window screenshot attached as requested. Photobucket makes it barely legible, sorry.
My System SpecsSystem Spec
05 Jul 2013   #8
gregrocker

 

Next time use the tutorial David provided for how we want to see screenshots. It would also help since you posted two if each one showed the config with each OS booted. For example I need to know now if Disk0 boots as C as it should provided you correctly told the cloning image to select Auto drive letter.

Nevertheless, mark Disk0 Win7 Active: Partition - Mark as Active (Method Two)

Power down to unplug all HD's. Swap the Disk0 cable to the System drive (now Disk3) which is booting both OS HD's so it will be first in order as it should be. Make sure it remains set to boot first in BIOS setup. See if it boots on its own correctly. If necessary install EasyBCD to delete the other OS boot option.

Then power down to swap in the new OS HD which you marked Active, boot the Win7 installer to Startup Repair - Run up to 3 Separate Times until Win7 starts and the partition is marked System Active.

Now plug back in the other OS HD to DIsk1 and boot it when needed using the BIOS Boot Menu shortcut key. If you don't like this arrangement install EasyBCD to the primary OS HD to add the other one, which will keep them independent anyway.

Now plug back in the other HD's one at a time to see if one interferes with either OS booting. If so move its data off and run Diskpart Clean Command to clear the boot sector of possibly interfering code. Then repartition in Disk Mgmt as Logical which is best for data drives so they cannot interfere at all with OS drives.
My System SpecsSystem Spec
07 Jul 2013   #9
toner

Windows 7 Professional 64
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Next time use the tutorial David provided for how we want to see screenshots. It would also help since you posted two if each one showed the config with each OS booted. For example I need to know now if Disk0 boots as C as it should provided you correctly told the cloning image to select Auto drive letter.

Nevertheless, mark Disk0 Win7 Active: Partition - Mark as Active (Method Two)

Power down to unplug all HD's. Swap the Disk0 cable to the System drive (now Disk3) which is booting both OS HD's so it will be first in order as it should be. Make sure it remains set to boot first in BIOS setup. See if it boots on its own correctly. If necessary install EasyBCD to delete the other OS boot option.

Then power down to swap in the new OS HD which you marked Active, boot the Win7 installer to Startup Repair - Run up to 3 Separate Times until Win7 starts and the partition is marked System Active.

Now plug back in the other OS HD to DIsk1 and boot it when needed using the BIOS Boot Menu shortcut key. If you don't like this arrangement install EasyBCD to the primary OS HD to add the other one, which will keep them independent anyway.

Now plug back in the other HD's one at a time to see if one interferes with either OS booting. If so move its data off and run Diskpart Clean Command to clear the boot sector of possibly interfering code. Then repartition in Disk Mgmt as Logical which is best for data drives so they cannot interfere at all with OS drives.
Ok, so I did all the steps EXCEPT the last one "Diskpart Clean Command" and with just the Intel SSD plugged in it would boot. When I plugged in the Samsung SSD neither would boot. So I deleted the entry for the Samsung SSD with EasyBCD, restarted, adjusted my BIOS to make sure boot order was INTEL SSD first (since it wasnt), re-added it with EasyBCD and now everything works.

AND, in all this mess with unplugging I still swapped the cables so my DAW install is still DISK0, BUT I dont have to use the repair disk to boot anymore since cloning to the larger INTEL SSD so you know what I'm good, it works!

Thanks!
My System SpecsSystem Spec
07 Jul 2013   #10
gregrocker

 

If you'd post back another screenshot of Disk Mgmt we can look it over for you for any potential problems.

Glad it's worked for you so far!
My System SpecsSystem Spec
Reply

 Startup repair after SSD upgrade on dual boot system, need help!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
upgrade win7 on dual boot system with windows xp
Hi. Right now i have dual boot system with windows 7 and xp - HP laptop. Windows 7 was installed first. XP was installed later. There are 4 primary partitions. 1. system reserved 100MB 2. win7 32 bit partition 3. xp partition 4. additional partition for data And now i need to upgrade win7...
Installation & Setup
BSOD, Startup Repair, System Repair and other errors on nearlly new PC
I took delivery of a new (and expensive!) PC in January but last week it started giving me constant and varied errors. The isssues range from Blue screen, black screen, failing to load windows, startup repair needed often, system restore needed often, and when it does load windows there are...
BSOD Help and Support
Startup repair loop - Can't repair with system restore/repair/commands
Hello, I've been unable to access my custom build computer since around 5:00 yesterday. I chose to restart my computer at around that time just because it was slowing up a little and I usually do that to help, I had not installed any updates or new programs since 2 days ago when there had been a...
BSOD Help and Support
Win 7 no boot to windows or safe mode Startup cannot repair or System
Win 7 no boot to windows or safe mode Startup cannot repair or System Restore PC was showing black screen 2 options Start windows normally or Launch Start up repair 1 beepthen launches startup repair.checkingsystem, then cannot repair and send info about this problem.Also Drive has canged from c...
BSOD Help and Support
Can't System Restore, Boot or startup repair after removing viruses
I used AVG Rescue CD to remove some pesky viruses off of a friends lenovo Win 7 32bit (upgraded from vista) machine. I stupidly chose to erase the infected files and something must have been a critical startup file for win7. It wont boot goes into startup repair and then, after a long time says...
Backup and Restore
How to Upgrade Vista to W7 on a Dual Boot System
Hello guys, Currently, when I boot, my mobo checks for my Adaptec4805SAS MBR, which is handled by Vista Boot Manager, which consists on two options: Boot Windows Vista (One logic drive inside a RAID array) Boot Windows XP (another logic drive inside ANOTHER RAID array) I've run the...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App