Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Reboot and select proper Boot Device?? Help!

29 Jul 2013   #11
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 

Reboot and select proper Boot Device?? Help!-bs.png




My System SpecsSystem Spec
.
30 Jul 2013   #12
gregrocker

 

Win7 is being booted by the System Reserved partition on the other HD which is way wrong and could be causing the problem. This is why all other HD's should always be unplugged during install, and why the Win7 HD should be plugged into the first SATA port to be Disk0, since otherwise any preceding Active partition will steal its boot during reinstall or Startup Repair.

To correct this Mark Partition C Active, power down to unplug Disk0 and swap its cable to the Win7 HD so it becomes Disk0. Unplug Disk2.

Now boot into Win7 installer or System Repair Disk to run Startup Repair - Run up to 3 Separate Times until Win7 starts and holds the System flag.

You can now power down to plug back in the old Disk0 into DIsk1 port. Since it has no content I'd wipe it with Diskpart Clean Command to remove old boot code so it can't interfere, then repartition in Disk Mgmt as desired.

After making sure the problem is resolved, plug back in Disk2 again.
My System SpecsSystem Spec
30 Jul 2013   #13
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Win7 is being booted by the System Reserved partition on the other HD which is way wrong and could be causing the problem. This is why all other HD's should always be unplugged during install, and why the Win7 HD should be plugged into the first SATA port to be Disk0, since otherwise any preceding Active partition will steal its boot during reinstall or Startup Repair.

To correct this Mark Partition C Active, power down to unplug Disk0 and swap its cable to the Win7 HD so it becomes Disk0. Unplug Disk2.

Now boot into Win7 installer or System Repair Disk to run Startup Repair - Run up to 3 Separate Times until Win7 starts and holds the System flag.

You can now power down to plug back in the old Disk0 into DIsk1 port. Since it has no content I'd wipe it with Diskpart Clean Command to remove old boot code so it can't interfere, then repartition in Disk Mgmt as desired.

After making sure the problem is resolved, plug back in Disk2 again.
Thankyouthankyouthankyou! I'll try that now.
My System SpecsSystem Spec
.

30 Jul 2013   #14
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 

Okay so I've disconnected the slave drive to do the deed.
and now that I'm trying to load up the windows disc it's coming up with a "BOOTMGR is missing"
...
...
Such a hassle. any ideas?
My System SpecsSystem Spec
30 Jul 2013   #15
gregrocker

 

That means its not booting the disk but trying to start the HD.

How to Boot A Computer from CD or DVD - YouTube

Are you getting prompt to Press any key to boot disk? If not then burn another Disk at 4x speed using ImgBurn, or write to flash stick using UltraISO Software To Create Bootable USB Flash Drive.

If that fails download another ISO for your licensed version from Clean Reinstall - Factory OEM Windows 7
My System SpecsSystem Spec
30 Jul 2013   #16
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
That means its not booting the disk but trying to start the HD.

How to Boot A Computer from CD or DVD - YouTube

Are you getting prompt to Press any key to boot disk? If not then burn another Disk at 4x speed using ImgBurn, or write to flash stick using UltraISO Software To Create Bootable USB Flash Drive.

If that fails download another ISO for your licensed version from Clean Reinstall - Factory OEM Windows 7
Yeah but that's the thing.
I've set the boot priority to my CD Drive first AND used F8 to manually select the CDD.
No luck.
I've been searching for ways to fix this and I've come across this 'mirror' method?
I tried this and received a message saying "No extents were found for the plex"??
I think as soon as I figure out how I can mirror the 'system reserved' partition on my slave drive to my actual OS drive then my problem will be solved,
seeing as the 'system reserved' file is the thing responsible for booting my OS etc.
My System SpecsSystem Spec
30 Jul 2013   #17
gregrocker

 

You need to be able to boot a disk, the most fundamental thing we do around here. Then you can do the steps I gave you to correct this problem which we've helped correct thousands of times before and do not involve mirroring anything.

Win7 is on a DVD, not a CD. So you;d need a DVD drive or to write the installer ISO to flash stick. If necessary start with a fresh ISO and use the tool in Steps 1 and 2 of Clean Reinstall - Factory OEM Windows 7.
My System SpecsSystem Spec
30 Jul 2013   #18
stuckstuck

Microsoft Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
You need to be able to boot a disk, the most fundamental thing we do around here. Then you can do the steps I gave you to correct this problem which we've helped correct thousands of times before and do not involve mirroring anything.

Win7 is on a DVD, not a CD. So you;d need a DVD drive or to write the installer ISO to flash stick. If necessary start with a fresh ISO and use the tool in Steps 1 and 2 of Clean Reinstall - Factory OEM Windows 7.
Apologies for using the wrong term in my last post.
I have a DVD windows installation disk yes.
& would also like to note that it didn't work as I said previously.
I'm actually quite suprised something as little as 100mb,
is preventing me from accessing my entire library of files and whatevers, it's amazing.
My System SpecsSystem Spec
30 Jul 2013   #19
Britton30
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

The little 100MB partition is what does the heavy lifting, it handles booting w7, but has to be on the same drive as the OS.
Running the Startup Repair as Greg outlined will get it back where it belongs.
My System SpecsSystem Spec
30 Jul 2013   #20
gregrocker

 

What do you mean exactly when you say the DVD didn't work? I gave you a link to download a new installer and tool to burn to DVD or write to bootable flash stick if you need it to get the disk to boot or work correctly.

Did you mark C Active, unplug all other HD's, swap the disk cable to WIn7, then boot into the DVD to run Startup Repair - Run up to 3 Separate Times ? This is how this is repaired.

I gave you very specfic steps in my first post that are known to work. If you can't perform them then we need to know at exactly what step do they fail? Saying "it didn't work" doesn't help.
My System SpecsSystem Spec
Reply

 Reboot and select proper Boot Device?? Help!




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Reboot & Select proper Boot device
Hi I am new and created my account for this but will be sticking around. So recently I was playing a game but then feel asleep while playing, when I woke up and turned on my pc this came up. I have been reading and watching videos for about 5 hours and going through BIOS trying to fix it but...
General Discussion
Reboot and select proper boot device
Hi guys, I have searched the forum and tried some of the solutions but it does not solve my problem. I had disconnected my had and reconnected it but to no avail. I can't even enter the bios setup screen, I can only enter the asrock setup utility screen. Does this mean my hdd is spoilt? Thanks for...
Hardware & Devices
reboot and select proper boot device.
Hi, i wasn't sure what section to put this problem in so decided on general. I have a asus x53e notebook that was on balanced on two corners to press in the charging cable ( not the problem ). It was knocked over and now when starting up i get the message on a black screen Reboot and select proper...
General Discussion
reboot and select proper boot device or insert boot media in select bo
Ok, I have googled this error and see this is common. Hopefully, I have missed something simple. I replaced my hard drive and installed the complete version of Windows 7 Home Premium. All worked great, till the next day when I turned the PC back on. I get the error message: reboot and select...
General Discussion
How do I fix the reboot and select proper boot device.
OwHi everybody i dont know is i should to post this issues here but i need help w/ booting my system build i connected my optical drive and my hdd and when power up everything look OK until goes to the monitor I see this black screen with that message I trying several things but not success how...
General Discussion
Reboot or select proper boot device
I have found plenty of threads with the same problem claiming to be solved but none have manage to fix my problem im afraid, plus i am not technical enough to follow a lot of the instructions so dare not try them. So here is my problem, i was on the internet and it seemed windows crashed everything...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App