Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: usbport.sys not working properly(?)

04 Aug 2013   #1
brajenful

Windows 7 Ultimate x64
 
 
usbport.sys not working properly(?)

Hi!
Recently I experienced that my cursor randomly stops for about half a second, and in some cases, the scroll wheel completely stops working (I have to restart the computer). Also, I ran the xperf command, and I found out that sometimes usbport.sys causes some pretty high DPC latency spikes. When I disconnect the mouse (by the way, it's a Trust MI-7770C Wireless Laser Mouse), and I use the touch pad, there is no problem with the cursor and/or the scrolling, so I think there is someting wrong with usbport.sys.


My System SpecsSystem Spec
.
04 Aug 2013   #2
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

Upload your MSINFO32.nfo file. It will let us check some necessary information.
  1. Click on the start button
  2. Type "msinfo32" (without quotes) in the search bar of the start menu, click the resulting link. It will open the System Information window.
  3. File>Save. In the "File Name" filed, put "MSINFO32" (without Quote), give the save location to desktop, and click the "save" button.
  4. Give the time for processing, it will save a .nfo file on your desktop.
  5. Zip it, and upload it following the instruction.
My System SpecsSystem Spec
04 Aug 2013   #3
brajenful

Windows 7 Ultimate x64
 
 

Here it is.
MSINFO32.zip


My System SpecsSystem Spec
.

04 Aug 2013   #4
Arc

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit
 
 

The driver is:
whfltr2k.sys; WheelMouse USB Lower Filter Driver.

No driver update available that is later of 2009. Trust.com - Wireless Laser Mouse - Carbon edition MI-7770C

I would suggest you to get a newer one.

The USB device driver is intel, part of the chipset. Most probably it is not causing any issue at its own. But if any other USB device fails in the same way, try to install the chipset from Acer | Download

My System SpecsSystem Spec
04 Aug 2013   #5
brajenful

Windows 7 Ultimate x64
 
 

Well, I'll download the mouse and chipset driver and I'm hoping for the best. Anyways, thank you for your help.
My System SpecsSystem Spec
Reply

 usbport.sys not working properly(?)




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Keyboard not working properly
Hi, my keyboard is not responding when I boot my laptop. After I switch on and off windows virtual keyboard once my keyboard starts working properly. Also the left shift key is not working properly. Please give a solution for my problem.
Hardware & Devices
Keyboard not working properly
Hello, Few days ago I started to notice that some of the letters on my laptop keyboard randomly stop working. Sometimes they work and sometimes they won't work at all. These are the keys that stop responding: A,X,C,F,N. Basically I boot my OS and then whenever I try to press on one of those...
Hardware & Devices
keyboard not working properly
this awful im using my screen keyboard to type this. this morning my keyboard was working just fine and now it says something like its not working properly. no error code, so i dont know. i can type my password to log on to my computer and then nothing. :cry ive tried uninstalling and...
Hardware & Devices
Gadgets not working properly
Hii.. My win 7 gaddgets r displaying as black on desktop wen i install a new gadget or win7 default gadgets.. I'm uploading screenshots pls help me...
Gadgets
CD Rom not working properly
I am running windows 7 and my cd rom is not working properly. It was reinstalled which seemed to help a LITTLE, but sometimes you have to incert a cd 7 or eight times before it will read it. I can see that there is a cd inserted (when I go to my computer I can see the D drive). Just doesn't read...
Hardware & Devices
windows not working properly
Installed Windows 7 on a new build-ssd. Windows loaded and worked properly, and was able to access anything I tried to. Installed driver for graphics card. After restart, windows shows desktop background. No icons and unable to open start menu from windows key. I am able to right click...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:10.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App