Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Multimonitor - App windows on wrong display after WIN+P

22 Jan 2014   #1
LaUs3r

Windows 7 Professional x64
 
 
Multimonitor - App windows on wrong display after WIN+P

Hey guys,

my setup consists of 2 LCD-displays and 1 LCD-TV. The 2 LCD-displays are both connected via DVI to my GeForce GTX 670, the TV is connected to the onboard HDMI-port. I need HDMI because of DTS HD and TrueHD.

Default setup: display (2) is primary via DVI, (3) is secondary via DVI, 3 is the TV via HDMI (here not activated)



Extended setup:



The TV is only used for watching movies. So my default configuration contains only the 2 LCD-displays.
So, using only the 2 LCDs everything works fine and all windows are opened on the screen where I want them to open (=main screen).
But when I change via WIN+P from "projector only" to "extend", everything gets mixed up. All windows appear on the wrong display (which is not the main display). For example, if my file browser was on (2) before it suddenly is on (3). Same behavior applies if I switch back from "Extend" to "projector only". My browser which was on (2) before, ends up on (3).

I tried to open the apps, drag the window to the right display and close the apps in order that they appear on the right display next time. But the settings are gone once I get back to my 2 display-setup (= projector only).
As for the boot order, I selected the onboard graphics card as primary (somehow I don't remember why, but it had its reasons )
I don't want to use an additional tool like ultramon. There has to be a way.
Maybe there is someone out there who can help. I'd deeply appreciate it.
cheers


My System SpecsSystem Spec
.
22 Jan 2014   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi welcome to SevenForums,
I'm not a multi monitor Guru so I'll just guess at this and hopefully learn from others that are
The way I believe it supposed to be,
Main display should be on the far left and Default hopefully using the VGA port depending if you have 1 VGA 1 DVI and 1 hdmi ?
DVI should be monitor 2
Hdmi to simplify should be unplugged unless being used all it does is confuse the system but might work better if it 3 and on the far right ?
After looking at the card,
Why aren't you plugged into the cards hdmi ?
Cheers.
My System SpecsSystem Spec
22 Jan 2014   #3
Kari

Microsoft Community Contributor Award Recipient

 

Deleted my previous post, I read OP's screenshots wrong.

Sorry.
My System SpecsSystem Spec
.

Reply

 Multimonitor - App windows on wrong display after WIN+P




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
ie and chrome display in wrong language
Hello all: Please forgive my spelling as I am posting from my phone. I have an odd issue after removal of a Google Chrome redirection malware. I thought that originally my customer had thier browsers set to display in German but after the checked out the machine during pickup it turned out they...
Browsers & Mail
windows extended display mode,icon missing on wrong invisible desktop
hi, i have my system hooked up to my 5.1 stereo system sound system. every once in a while, my icons and applications would be send to my invisible monitor thats not hooked up ( only sound) when i change my display to extend these displays mode. It's annoying because it doesnt happen all the...
General Discussion
Win 7 HP/IE 9 display wrong language in Youtube
None of the other threads seem to match my case. I use Win 7HP and IE 9. All my language settings show English (U.S.), although I have German as a second language in Microsoft Word 10 and in IE 9. I have no language packs installed. When I go to Youtube I get the website in German. It is easy...
Browsers & Mail
Intellipoint Shortcuts Display Wrong Icons
Hello, I have installed Intellipoint 7.0 and the shortcuts display the wrong icons. I have tried uninstalling and re-installing Intellipoint, and deleting the IconCache.db to no avail. If you right-click and select properties the change icon button is disabled. I would normally just create new...
Drivers
Preview display wrong colors
Hello! When I open a picture with the preview option in windows the picture is displayed with a yellow layer over it. I haven't seen this problem anywhere else. The right image is of course the proper one. What should I do?
General Discussion
ATI Radeon X1550 - wrong display size
Just installed WIN7 - and now my second display won't show the correct size. When booting the computer the picture fills out the entire display, but as soon as I have to logon to windows it decreases to a sad sad size which I'm completely unable to change :cry: What to do? // Jacob
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App