Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: One excessive icon (Safely remove...) after changing the BIOS to AHCI

08 Mar 2014   #1
Franky

windows 7 32-bit
 
 
One excessive icon (Safely remove...) after changing the BIOS to AHCI

Hi all,

I installed the x64 version of Win 7. After that I changed the registery and then changed the SATA selection mode to AHCI (which was in IDE mode before) in BIOS.

But;

1- One excessive icon has been appeared in bottom right-hand corner (as is in below image). When I click on it, a small window appears that says:

Open devices and printers
Eject ST500DM002-1BC142 ATA Device (this is my HDD!)
- ...(C)
-....(D)
-....(E)


I think it belongs to the HDD. How to get rid of it?

2- Should the settings of the BIOS (SATA selection mode) always be in AHCI and don't I need to return it to IDE even if I want to re-install the (x64 or x86) OS?




Attached Images
One excessive icon (Safely remove...) after changing the BIOS to AHCI-capture.png 
My System SpecsSystem Spec
.
09 Mar 2014   #2
Franky

windows 7 32-bit
 
 

Isn't there any way!?
My System SpecsSystem Spec
09 Mar 2014   #3
BrightBlessings

Win7 Pro-64 Bit
 
 

I had same thing happen to my pc on last install, I had forgotten to install the Intel Rapid Storage Technology from the motherboard driver disc. Am only guessing as you have no system specs. Please post them.
System Info - See Your System Specs
My System SpecsSystem Spec
.

09 Mar 2014   #4
Franky

windows 7 32-bit
 
 

this is my system specs.


Attached Images
One excessive icon (Safely remove...) after changing the BIOS to AHCI-capture.png 
My System SpecsSystem Spec
09 Mar 2014   #5
alphanumeric

Windows 10 Education 64 bit
 
 

Sounds like a driver issue. Windows thinks its a removable media instead of a fixed disk drive. Installing the correct SATA and or chip-set drivers should fix it.
My System SpecsSystem Spec
10 Mar 2014   #6
Franky

windows 7 32-bit
 
 

How to installing the SATA? I installed the update chipset from Gigabyte website.
My System SpecsSystem Spec
10 Mar 2014   #7
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

You can find the SATA/AHCI driver here

Intel® Rapid Storage Technology version 12.8.0.1016

GIGABYTE - Motherboard - Socket 1155 - GA-P61A-D3 (rev. 2.0)
My System SpecsSystem Spec
10 Mar 2014   #8
Franky

windows 7 32-bit
 
 

I downloaded the "Intel® Rapid Storage Technology version 12.8.0.1016" and that icon vanished. The problem is solved now. Thank you guys.
My System SpecsSystem Spec
10 Mar 2014   #9
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

You're welcome.
My System SpecsSystem Spec
Reply

 One excessive icon (Safely remove...) after changing the BIOS to AHCI




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Safely Remove Hardware icon not functioning.
Hi everyone, I've had this problem for awhile now. When trying to eject USB devices, the safely remove hardware icon in the notification area doesn't show any connected hardware. For my 4GB USB drive, it isn't a problem, because I can eject it from windows explorer. But my external drive...
Hardware & Devices
Readyboost - Safely Remove Hardware Icon
Its a niggle and not a big one, but is there no way for readyboost enabled USB sticks to not show as this system tray icon? or will W7 always recognise them as just a USB, not a permanent fixture to my machine? cheers Ben
Performance & Maintenance
Safely remove hardware icon.
I'm sorry if I posted this on a wrong side of the forum. Apparently, I have a small issue with my USB port. When I connect my external hard disk to the usual USB ports I normally use. It would show the "Safely remove hardware" icon but however, there is one USB port I could connect it and use it...
Hardware & Devices
Changing to AHCI in BIOS
Hi this might not be the correct forum but I thought i'd try anyway. Basically i've bought a new pc and the BIOS 'American Megatrends' seems to be very difficult to try and find how to change to AHCI mode. I need to change it as im going to be installing a mac os distro. If anyone has any...
Installation & Setup
Safely remove icon in taskbar disappeared
My safely remove icon in the taskbar disappeared after moving it into the "hidden box" and there seems to be no way to reset it - which is strange because every other taskbar icon can be reset. I got a shortcut to the safely remove dialog window with RunDll32.exe shell32.dll,Control_RunDLL...
General Discussion
Safely Remove Hardware icon on taskbar
Does anyone know the registry key to set Windows Explorer Safely Remove Hardware and Eject Media on (Show icon and notifications) ? That way whenever someone plugs in a USB device the icon will show in the task bar until is ejected and not just the simple notification. I Know how to turn on/off the...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App