Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dragging windows/files can cause visual issues

08 Mar 2014   #1
aljowen

Windows 7 Home Premium 64bit
 
 
Dragging windows/files can cause visual issues

Image of issue:
https://picasaweb.google.com/lh/phot...eat=directlink

When i am dragging windows or files around my desktop it will often leave an artifact like the one shown on the screen. It is caused by the icon windows shows next to your mouse while dragging. The only way to remove the artifact is by rebooting the computer, i can change its location by dragging things around the screen and hoping it gets stuck in a more convenient location of the screen, as i have done in the screenshot.
I have tried closing explorer.exe and dwm.exe in the hope that they may refresh it but with no result.

Thanks for any help,
aljowen


My System SpecsSystem Spec
.
09 Mar 2014   #2
gregrocker

 

Dragging intact takes a huge amount of resources which may be a problem on lower resource machines. For these PC's I always edit the Visual Effects of fading, dragging intact, selection rectangle, and sliding. See Optimize Windows 7 - Windows 7 Forums. Most of these effects are not even noticeable, except when they overtax resources and produce artifacts like you are seeing.

Update your display driver.

Establish a Clean Boot and work through the other Troubleshooting Steps for Windows 7.

Are you getting Aero transparent windows? This is an important benchmark if your display is up to snuff for Win7. If not type Aero in Start Search box to run the Troubleshooter to find out why.
My System SpecsSystem Spec
09 Mar 2014   #3
aljowen

Windows 7 Home Premium 64bit
 
 

Thanks for the response.
Well the thing is I wouldn't class my computer as a lower end machine even if it is getting a little old. It's a 3d rendering and gaming rig that is running an i5 2500k and a gtx560ti.The drivers are pretty new, only a month or two old, this issue has been happening over all the drivers I have had installed, I am using the official drivers too.
I do use aero translucent. windows tells me it should be fine (which it should be with a system like mine) since it gets full marks in the Windows experience score, the cpu gets pretty close too, of course the hard drive causes a lower final score.
I'm not sure what my displays could possibly have to do with it but I have a 1080p main screen and a 1050p one to the right for controlling music, having YouTube open while I work/game etc.
My System SpecsSystem Spec
.

09 Mar 2014   #4
gregrocker

 

OK I see your specs now so visual edits and Aero should not enter into the equation. How much RAM exactly? Has it been tested overnight with RAM - Test with Memtest86+ ?

You can stress test your GPU with Furmark: FurMark: VGA Stress Test, Graphics Card and GPU Stability Test, Burn-in Test, OpenGL Benchmark and GPU Temperature | oZone3D.Net

Work through the other Troubleshooting Steps for Windows 7 including the other hardware tests. This not only goes over the install and PC most thoroughly, but in most cases will come up with important clues.
My System SpecsSystem Spec
09 Mar 2014   #5
aljowen

Windows 7 Home Premium 64bit
 
 

Why would i even want to stress test my GPU because of windows issues, its more than powerful enough to run windows. Its not crashing, its not overheating (according to evga precision x when i monitor it during games occasionally). It certainly isn't overheating while running windows. My CPU is also more than powerful enough.
This does not seem to be a hardware problem. The issue is software (systems software i assume). Whether its an issue with windows or nvidia drivers i have no idea, that is why i am asking here.

I have had a look at performance options and i couldn't find anything about removing the icon for dragging folders without removing other visual features that i would rather keep. The miniature window shown in the image is a firefox thing. But it caused the same issue as windows, i guess this could make it more likely a driver issue but i am still not ruling windows out.

I would be perfectly happy if anyone could suggest a workaround, just a way to remove the icon from the screen without rebooting. Since it only happens once every 2 months or so its not to big a deal.
My System SpecsSystem Spec
09 Mar 2014   #6
gregrocker

 

It's always best to first eliminate hardware as the problem, which you've not done until the tests in the steps are done with the addition of the GPU stress test.

Then the steps will eliminate most possibilities with Win7.

However if you're convinced the problem is with Win7 then work through those steps first. I'd also compare the install you have with the perfect install in Clean Reinstall - Factory OEM Windows 7 - Windows 7 Help Forums which is based on what's worked best in tens of thousands of installs we've helped with here.
My System SpecsSystem Spec
09 Mar 2014   #7
essenbe

Windows 7 Enterprise X64/Windows 10 Enterprise X64/Windows 10 Pro X64/Linux Mint
 
 

aljowen, I can assure you it is not a windows issue. If it were, everyone would be having the same problems. When you reboot the computer, it reloads the drivers, which is most likely your problem. It is either a driver or a hardware problem. There is no other reason for you to be seeing artifacts. I would suggest you run through the troubleshooting steps that gregrocker linked to as well as the Furmark test.
My System SpecsSystem Spec
09 Mar 2014   #8
aljowen

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by essenbe View Post
aljowen, I can assure you it is not a windows issue. If it were, everyone would be having the same problems. When you reboot the computer, it reloads the drivers, which is most likely your problem. It is either a driver or a hardware problem. There is no other reason for you to be seeing artifacts. I would suggest you run through the troubleshooting steps that gregrocker linked to as well as the Furmark test.
Thanks,
I should probably mention my GPU got replaced by a different revision with lower specs by Gigabyte shortly after i bought it because they got too many complaints about driver instability. They blamed nvidia, nvidia blamed them. You've probably figured that neither party admitted fault and nothing happened.
Drivers did get fixed about a year after purchasing the card, no more daily bsod's after that point. This is the only issue it has had since. Because it is a rare occurrence it hasn't caused me enough bother to fix it yet. Since once you get it rebooted you forget about fixing it and carry on as normal

I will have a go at some furmark testing when i get the chance though since i understand that it pushes the card harder than anything normally would. Will report back once i have done that.
My System SpecsSystem Spec
09 Mar 2014   #9
gregrocker

 

How much RAM exactly? Has it been stress tested 8 passes or overnight with RAM - Test with Memtest86+?

Have you tried swapping out Avast for MSE, per the tutorial?
My System SpecsSystem Spec
09 Mar 2014   #10
aljowen

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
How much RAM exactly? Has it been stress tested 8 passes or overnight with RAM - Test with Memtest86+?

Have you tried swapping out Avast for MSE, per the tutorial?
I have 8gb (2x4gb) 1600mhz. It has not been stress tested, i wouldn't have the time to do a full stress test of the ram to that degree since i sleep next to my pc. But if i get time i will give that a go.

I have uninstalled Avast before to repair it after an update broke it, i couldn't say if it helped or not because of the infrequency of the issue. I also have malwarebytes installed. I primarily use malwarebytes because it does a better job of spotting issues than avast does. But since malwarebytes isn't actually antivirus software i have avast there too just in case.
My System SpecsSystem Spec
Reply

 Dragging windows/files can cause visual issues




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Dragging Files from XP mode into 7`
How do you drag files out of XP mode and drop them into 7, you can drag files from 7 and put them into XP mode but not the other way around how do you do this?
Installation & Setup
Win 7: Folders, Dragging/Dropping/Copying and Taskbar Issues
I noticed this about a 4 days ago... If I went to download a file, it wouldn't let me save it - it was grayed out. Last night, I was trying to write a data DVD w/some files on it, and I couldn't drag/drop files into the window of CDBurnerXP. It also wouldn't let me add them, thru the...
General Discussion
Can I copy files by dragging?
Using Vista, I could copy files to another location by dragging the name of the file. On Windows 7, however, when I drag, it moves the file (removing it from the original location). Is it possible to copy the file to another drive by dragging without deleting it from the original location?
General Discussion
Dragging Files To Another Location
Hi, Sometimes when I am dragging a file or folder into another location, it will simply make a copy of the file rather than moving. This is especially the case if dragging to another partition. This is annoying because I have to go back and erase the original file that I wanted move. Is there a...
Performance & Maintenance
Dragging files within the same folder
My mother has just purchased a new PC with Windows 7 and as I am unfamiliar with this OS I thought someone on here may be able to help. Basically she is trying to reposition word documents within the same folder but W7 will not allow her to click and drag them to their new position. The 'sort by'...
Software
Issues of Visual Studio 6.0 Application in Windows 7 OS
Hi lI have a VB6.0 application, which is functioning in windows XP operating system, And I’m going to use the application in Windows 7 operating system. In this application I am using the following OCX controls, Keysta32.ocx Grid32.ocx Threed32.ocx Mschart.ocx The "Support Statement...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App