Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can delay time for an "Automatic (Delayed Start)" service be set?

20 Apr 2014   #1
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 
Can delay time for an "Automatic (Delayed Start)" service be set?

Is there a way to adjust the delay time for a Win 7 Service set to start as "Automatic (Delayed Start)" ?
I've got one service set to the default Automatic that causes many other startup items to take a long time to run on bootup.
If I change the service to "Automatic (Delayed Start)" that fixes this annoyance issue.
Other startup programs and services start quickly ...
But with "Automatic (Delayed Start)" the delay is a minute or more ... whatever MS delayed start means
I would like the delay to be 10-15 seconds.


My System SpecsSystem Spec
.
20 Apr 2014   #2
mitchell65

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

My System SpecsSystem Spec
20 Apr 2014   #3
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Thanks mitchell65.
I haven't found anything to help
Some say a registry tweak can change the startup delay time, but I haven't found it.

For anyone interested,
WinPatrol shows a "Trigger Start" option for Services now.
From what I found, that's new Service Startup option for Windows 8.1.
Not sure what it might do with Win 7 ...
My System SpecsSystem Spec
.

20 Apr 2014   #4
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

With WinPatrol you could always delay start - already with Vista.
My System SpecsSystem Spec
20 Apr 2014   #5
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

In WinPatrol I can adjust the delay time for Programs, but not Services.
I would like to change the startup delay time for a Service.
My System SpecsSystem Spec
20 Apr 2014   #6
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

I don't know. I can delay everything in the startups. What do you call the .dll in the picture - a program or a service.


Attached Thumbnails
Can delay time for an "Automatic (Delayed Start)" service be set?-2014-04-20_1922.png  
My System SpecsSystem Spec
20 Apr 2014   #7
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

I don't know.
I can add the program the service starts to WinPatrol delayed Start, but that does not solve "my annoyance issue".
The automatic startup for the service still causes a "slow startup".
I can set the service to delayed, and the issue is fixed.
But, realtime protection is then delayed for a minute or two - I want the delay to be 10-15 seconds for the service.

I certainly may be doing something wrong trying to configure this, below are screen prints.
I can live with a "bootup delay" if it's best "security" to have the service set to automatic and wait 30 seconds or so on bootup ...

Notice that WinPatrol offers a "Trigger Start" for a service, and Win 7 Services does not offer this option

Can delay time for an "Automatic (Delayed Start)" service be set?-ssusp03.png

Can delay time for an "Automatic (Delayed Start)" service be set?-ssusp01.png

Can delay time for an "Automatic (Delayed Start)" service be set?-ssusp02.png


My System SpecsSystem Spec
Reply

 Can delay time for an "Automatic (Delayed Start)" service be set?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
"Windows Audio Endpoint Builder" service will not start
The audio services worked fine at first. But after optimizing the system for gaming and security, the "Windows Audio Endpoint Builder" service fails to start. It gives the error: "Error 1722: The RPC server is unavailable" This is required for the "Windows Audio" service, so I have no sound now....
Sound & Audio
"The dependancy service or group failed to start"
Okay.... I have a laptop running Windows 7 64bit. It was working fine up until a week ago when it started to display "The dependency service or group failed to start" when I was trying to connect to a network. I have seen a lot of threads and tried a lot of things and nothing has worked. Also...
Network & Sharing
"Home Group Listener" service won't start, error -2147023143
I am not able to start the "Home Group Listener" service, hence I can't use Home Group feature. I get this error message: http://i.imgur.com/IU13d9n.png I checked the System Event Log, I found this entry:
General Discussion
"The dependency service or group failed to start" after sys restore
So I installed SP1 on my netbook (Windows 7, 32bit) but it made my notification icons disappear, and the options to re-enable them was greyed out (aka here) so I did a roll back to before I installed SP1 and for some reason, after reinstalling my Custopack (this one if yer curious) - which I've...
Network & Sharing
"Can not start the dependency service or group"
I need help, because I canīt run anyone application Once time that I try to run any application, the system become in slow performance and few minutes later appear the fallowing dialog box: "Can not start the dependency service or group" This occur with all kind of application that I try to...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Đ Designer Media Ltd

All times are GMT -5. The time now is 14:50.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App