Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: When Typing There Is a Delay

08 Jun 2012   #31


I know this is months down the road, and I apologize. I have since then ripped out the two 1GB Hynix 1066mhz CL7 sticks and installed two sticks of Corsair 4GB 1333mhz CAS 9 (Running at 1066mhz CAS 7). This seemed to help out the problem. It's strange! My old P4 socket 775 with 2GB of RAM running Windows 7 didn't do the keyboard lag.

My System SpecsSystem Spec
08 Jun 2012   #32

Windows 7 Home Premium 64 bit

Oh well. Afraid that didn't work. I typed, literally, half a dozen lines of type in Google+, commenting on photographs, and the delayed typing started, words took a while to finish themselves. Then I could no longer scroll reliably.
I've had to close Chrome and go back to Opera. It's too late here to try anything further now, but I shall return over the weekend

Any ideas as to why Opera should be immune to this problem?
Good night folks, John
My System SpecsSystem Spec
08 Jun 2012   #33

Microsoft Windows 7 Home Premium 64-bit 7600

thats a shame john, i figure the problems sfc found were to do with the fact you have patched your system for a third party theme, in fact i guess your theme isnt displaying all the features as it used to.
im still none the wiser to your issue,
i dont suppose you have the PCMservice.exe mentioned in the first links i gave you.
as you have a custom built pc and the fix via disabling the PCMservice.exe was for dells i doubt it, but worth a check, search for it in the start search,
My System SpecsSystem Spec

08 Jun 2012   #34


John, try a Clean Boot from the Troubleshooting Steps for Windows 7.
My System SpecsSystem Spec
09 Jun 2012   #35

Windows 7 Home Premium 64 bit

Yes, you're right Julian, my Mr. Grim HUD theme is now reduced and I have no aero. I'll worry about that later and go through the diagnostic steps suggested.
I don't have the Dell exe. file.
It's looking like a clean install might be necessary, and I'm overdue for one anyway.
Did new RAM sort out your problem Flipicaneze?

Cheers folks, John
My System SpecsSystem Spec
09 Jun 2012   #36

Microsoft Windows 7 Home Premium 64-bit 7600

i see you have 3x2gb ram, that should be ample, i dont have a lag on 2gb of ram on the laptop, that said you use imaging softwares and they may be heavy on the ram, does the lag continue without any software open,

oh! and you need to remember to repatch your system before you redo the hud theme,
My System SpecsSystem Spec
12 Jun 2012   #37

Windows 7 Home Premium 64 bit

Still no joy folks. I thought SFC/scannow had done something miraculous. As you say Julian, it knocked out my custom theme, and when I tried G+ in Chrome the typing delay was still there.
I tried all the other diagnostic steps recommended and still nothing.
I figured that the next step was a re install, but then realised I can't do that right now as one of my externals has failed and I haven't room to back up all my latest pictures.
So. I re patched the system with Universal Theme Patcher x64. Merely doing that restored my custom theme. Also, amazingly, it seemed to have fixed my problem. For about two days I had no delayed type issues in Chrome! Hooray!
However, now it's come back just as bad as before and renders Chrome unusable with G+.
Oh well. Opera is still absolutely fine, with no problems. I'll just have to use that until I can get another HDD and do a re install.
Unless anybody has any other suggestions?

Thanks for your help people, cheers, John
My System SpecsSystem Spec
12 Jun 2012   #38


Hi John -

I would Clean Reinstall and not use a theme patcher since it pretty clearly is the problem.

If you wish to continue with the theme then to get it in a working configuration that doesn't affect your performance may require another browser or asking for help from the patch author or our Customization experts.

I would use Firefox or IE9 since Google is pernicious spyware when in any installed program or while remaining signed into any of its sites. You can mitigate this some with Network Advertising Initiative.
My System SpecsSystem Spec
12 Jun 2012   #39

Microsoft Windows 7 Home Premium 64-bit 7600

you could try a different theme to see if the problem continues, it maybe a problem with the fonts in the hud theme but unlikely,
it may be the universal theme patcher

to check the theme patcher john , run it again but repatch to the defaults (reset), then see if there is a keyboard lag. i have to say i have used the hud themes and have the universal patched on both computers, and no problems,
My System SpecsSystem Spec
12 Jun 2012   #40

XP / Win7 x64 Pro

Ah, a theme patcher issue. This would be the 309234th one to date. Those things are nothing but problems. Please, do yourself a favor and completely uninstall that (might require a repair install or a clean reinstall as gregrocker suggested to get it to go completely away).
My System SpecsSystem Spec

 When Typing There Is a Delay

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
typing cursor disappears when typing and deselects typing box
hi guys, whenever i start typing the cursor disappears and i have to repeatedly keep clicking back in the typing area multiple times in order to type a few letters more b4 it happens again. can someone plz help. i tried alot of things already
General Discussion
when typing any messages the cursor is likely to jump and type text anywhere. any ideas how to stop it
General Discussion
Moving typing error when typing
hello everyone I changed my OS form vista to windows 7 home premium 32bit, since changing I'm facing problem when I'm typing. The typing arrow move by its self while typing. for example if I'm writing a sentence the arrow suddenly move to beginning of the sentence or middle etc. example :...
General Discussion
IE9 - 2sec startup delay; 0-2sec delay when opening tabs
I have tried to fix this but to no avail. This is a list of what I have tried (I probably forgot a few things): - run IE9 with no add-ons - run IE9 in 64bit mode - tried the above 2 in safe mode - deleted the registry keys corresponding to Spybot, even though it's not installed -...
Browsers & Mail
Windows 7 delay and lag in typing
Windows 7 has been giving a bit of issues with delay or lag in typing I called Dell and received help in upgrading drivers. Things seem to work better then it went back to its old ways Can anyone shed light? why is there such a lag in typing when using win 7 having issue with cursor
General Discussion
Mouse delay and OpenGL games delay. Help!
Hi there. Im running Windows 7 Professional x86 final on this machine: athlon x2 5.000+ 2x2gb ddr800 dual-channel memory ati radeon hd 4650 512mb 128bits 500g sata hd The os is updated and all the settings of the os are on default. The settings of videocard are in performance/balanced.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:23.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App