Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Server execution failed

05 Jul 2014   #1
bertie11

Windows 8.1.1
 
 
Server execution failed

I get this message sometimes when I click on a desktop folder, it comes up with the path c:\Users\Mike\Desktop\System Utilities (which is the folder I am trying to open when fault showed). It can happen when I try to open any desktop folder.

The odd thing is (to me!) is that I had this fault before I re-installed windows 7 5 days ago, and I still have it. I assumed that the new install would create a new registry so I shouldn't be getting this message, unless it is due to another reason?

I've read a load of threads but they seem to mainly relate to Windows Media which I still have on the system but I don't use it. I had a Remote Assistance with Microsoft yesterday and it came up when he was trying to open a folder. The 'hourglass' goes for 2-3 minutes before the message comes up. After that, I can open folders with no problems (until the next time).

Any ideas please?


My System SpecsSystem Spec
.
05 Jul 2014   #2
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Suggestions

Check the following registry keys:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Make sure that the paths shown are correct.

Edit: Especially for Desktop!

User Folders - Restore Default Location
My System SpecsSystem Spec
05 Jul 2014   #3
bertie11

Windows 8.1.1
 
 

Hi Callender

I've looked at both those registry keys, they both take me to C:\Users\Mike\Desktop so I'm assuming they
are both OK, if I understood you correctly you just wanted me to check the paths?

I haven't made any registry changes since I installed Windows.

Thanks.
My System SpecsSystem Spec
.

05 Jul 2014   #4
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Looks okay

Yes that looks as if it's correct.

I wonder if you could upload copies of those two registry keys?

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Shell Folders

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

Right click and choose "Export" then choose a file name and "Save As" .txt file. Attach the two text files just so that we can see if there are any obvious problems.
My System SpecsSystem Spec
05 Jul 2014   #5
bertie11

Windows 8.1.1
 
 

Of course, I haven't had the fault since...


Attached Files
File Type: reg Shell Folders.reg (4.4 KB, 7 views)
File Type: reg User Shell Folders.reg (12.2 KB, 7 views)
My System SpecsSystem Spec
05 Jul 2014   #6
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
User Shell Folders

Shell Folders.reg looks fine

User Shell Folders.reg looks wrong. Would you confirm that the method used to export was as follows?

Right click registry key> Export> Type File Name> Save As Type> Registration Files (*.reg)

Also would it be possible to post a screenshot of the registry key - it should look something like this?


[Image Removed]

EDIT: It all looks fine. My mistake!

EDIT: Are you saying that the problem might be intermittent and that sometimes it's possible to open any folder located on your desktop successfully?

Have you been using any external drives by any chance?
My System SpecsSystem Spec
06 Jul 2014   #7
bertie11

Windows 8.1.1
 
 

Yes, most of the time I can open folders on the desktop without any problems, but then sometimes I have to sit and wait, and wait, until the 'Server Execution failed' message appears. If I try several times to open the same folder, once I've cleared the Server fault window, the folder opens a window for each opening click, so I might get six windows open. Like a logjam, once the faulty log has gone...

Yes, I do use a 500gb external USB drive as I do several backups through the day. I cannot be sure though that it was on at the time of every fault message but there have been times when it was on and the fault appeared.
My System SpecsSystem Spec
06 Jul 2014   #8
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
External Drive

Well I'm guessing that if you've got shortcuts stored on your desktop (or possibly anywhere else) to anything located on your external drive then it could cause the problem at times when the drive is not in use or disconnected.

There's quite a detailed thread on the problem here:

Explorer.exe server execution failed

If you can read the entire thread from the first post through to the last it might give you a clue.

I asked about those registry keys as I had the same problem and one of the paths had somehow changed from the default path. In your case, as stated, there's nothing to worry about!
My System SpecsSystem Spec
06 Jul 2014   #9
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Another thought re: your external drive.

You say that it's plugged in but sometimes it's switched on and sometimes it's switched off.

Suggestion: When it's switched on and everything seems to be working go to My Computer and take a look at the drive letter that's assigned to your external drive and make a note of it.

Next time you see the "Server Execution Failed" message just have a quick check to see if Windows assigned a new drive letter to your external drive somehow! If this is the case - it's very likely to be the reason for the error message.
My System SpecsSystem Spec
06 Jul 2014   #10
bertie11

Windows 8.1.1
 
 

Thanks for those suggestions Callender, I haven't been able to do any more investigation but I will check out your suggestions. my system has started to run slow so I'm trying to find out why and what I've done! I know it is overheating and I'm waiting doe a laptop cooling tray and some compressed air to arrive to see if that helps!

The server fault hasn't re-appeared since.
My System SpecsSystem Spec
Reply

 Server execution failed




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
WMP Server Execution Failed
So...I got a new computer and WMP was already kinda screwy since it was splitting up my albums and messing with the tracks. No matter how many 'scan now' things I ran, my computer didn't pick up anything wrong, so I just dealt with it. Now WMP isn't working at all and every time I try to play a...
Media Center
Server execution failed
I got his error on a 3 hour old Win 7 HP X64 install on a SSD. Any thing I click in the right pane of the start menu is non responsive and about 15 seconds later this error pops up. I have ran the Windows update gamut and new drivers form the ASUS (motherboard) site. Ne'er mind, fixed...
Performance & Maintenance
Server execution failed
Hi, I frequently get the message SERVER EXECUTION FAILED and I cant play a song on WM that is located in my win Explor folder -- Sometimes this happens occasionally but right now I cant open any folder as that message just pops up. My music comes thru on WMP - I have 6 g ram and I am...
Music, Pictures & Video
Help!!!!! Server execution failed? WMP
I AM NOT VERY COMPUTER SAVVY. JUST BOUGHT MY LAP TOP A FEW WEEKS AGO FROM A PAWN SHOP. ALREADY HAD FILES ON IT. DID NOT HAVE ANY PROBLEMS WITH IT UNTIL I LET MY 10 YEAR OLD SON CONVINCE ME TO LET HIM USE IT TO PUT MUSIC ON HIS IPOD. EVER SINCE I CAN NOT PULL UP MY MEDIA PLAYER AND WHEN I TRY TO...
Music, Pictures & Video
Server Execution failed
I'm having errors with Windows media Player and Media Center. I get a message that says server execution failed and Windows media player wont open. Media Center will open but wont play audio files. my hands are tied unless I can find some way to fix this
Music, Pictures & Video
Server execution failed
About an hour ago following a screen freeze after inserting a camera SD card and then doing a restart I went to Control Panel to change a setting. Clicking on any of those selections in that list would do nothing. Then I began to get error messages that Server connection failed. Four samples of...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:49.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App