Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Blank desktop at start up in Windows 7 Ultimate

30 Jul 2014   #1
CCiwl

Windows 8
 
 
Blank desktop at start up in Windows 7 Ultimate

PS: Please delete this thread if necessary.


Hullo, I'm new here and a newbie when it comes to knowing what kind of graphics card, motherboard and very technical details, so please bear with me.

This all started while I was using jv16 PowerTools and CCleaner to clean my computer when I suspected my computer of an malware, spyware or an infection after seeing Mozilla Firefox loading really slow. After CCleaner detected 4 registry problems, I unwittingly clicked "Fix All Selected Issues" (And I suspect one of them included a "Missing Shared DLL" or something) and from there on, when I restarted my computer, I was face to face with a blank desktop, with my mouse. I can still move it, and I can do Ctrl+Alt+Del, but when I try to run my browser with "Run", no windows appear, and a certain "Browse" window loads what seems to be an eternity. Can't run any programs. I tried to add in the "explorer.exe" (but it's present in the Task Manager) and the one in which you end it and type a new one back, it didn't fix. No System Restore, I don't put much of an habit to do it. Can't right click, nothing appears. I did a Ctrl+Esc, nothing and I don't really know much about my drivers here.

I can't run the "sfc /scannow" in my normal mode because it needs to be ran as an "Administrator" and I don't know what to do because I can't run it from there, and I can't load my "C:\" because nothing appears. And I remember when I was cleaning stuff a few days ago and I came upon a "registryfix" download from a certain website in which it puts the default and normal keys back in your registry, I was just hoping if anyone can give me a link to it, I was just hoping it might get fix by it, it's my only hope now.

And I thank anyone who reads this noobish and long, cumbersome story. I really, really need some help now guys.

Once again thank you.

PSS: I'm sorry if this doesn't sound grammatically correct and a bit coherent, I'm pulling an all-nighter here and I'm reviewing for my test.

-CCiwl

EDIT:
CCleaner Registry Tool detected UNUSED Extension File:
HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.

I got the registryfix.reg, but it didn't solve the problem. Got it from pcrisk.com
Don't know if okay, but I just recklessly click on it and added the reg keys:
registryfix.reg
Be careful, though.

EDIT 2:
Anyone? No suggestions? Any hope? Well, the regfix.reg didn't work, so there must be any more?

EDIT 3:
8-12-2014

Alright, thank you, Mr. gregrocker for your suggestion, help and time that you've given to type your answer (no seriously thank you) and Sammy Roseberry for your time to answer this.
After I downloaded a 24 fewish something programs and scanned with Avira, I've got my taskbar and icons back, I can open windows now. I just want to ask what should I do to keep it permanent?

Whenever I'm in the startup, I have to do end the explorer.exe and run it again, and there goes my icon and taskbar back, any help?

(PSS: You know, I'm a bit tad confused, right now though... I don't know which program returned my computer back, but... If I may and need to... I can attach my GMER and DDS log here.)

But for now, thank you very much for your help, guys!




My System SpecsSystem Spec
.
31 Jul 2014   #2
gregrocker

 

Boot into System Recovery Options
from Win7 installation media or System Repair Disk
to run Startup Repair a few times.

It should automate System Restore and SFC but if not run them from the Options list and Command Line to SFC /SCANNOW Run in Command Prompt at Boot.

This likely had nothing to do with CCleaner which has no documented cases here of causing these problems.

More likely you still have serious infection which took over. If this is indicated by these repairs not working, start at the top of Troubleshooting Windows 7 Failure to Start to disinfect and then repair System files which may not repair until fully disinfected. Post back infection once you confirm it so we can see if a special tool is needed.
My System SpecsSystem Spec
31 Jul 2014   #3
Sammy Rosebery

Windows XP Pro ;Windows 7 Ultimate ;Windows 8 Pro 32 bit
 
 

Maybe you should fix explorer.exe, or replace it?
My System SpecsSystem Spec
.

31 Jul 2014   #4
CCiwl

Windows 8
 
 

Well, I have the explorer.exe download in safe mode (yes the same computer I'm using) but I couldn't even open the download windows, nothing would appear in the first place.
My System SpecsSystem Spec
Reply

 Blank desktop at start up in Windows 7 Ultimate




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Still unable to copy CD-ROM for Windows 7 Ultimate SP1 to blank DVD+R
Let's try this again. Below is the 1st thread, plus results of 3 attempts at the suggestions. So far, nothing has worked. I included the root directory list of the CD-ROM which I am trying to copy. Please read this again and give me more detailed instructions. It is appreciated - I am trying,...
General Discussion
Windows (7 Ultimate x64) boots into a blank screen with a cursor
I was all good working on my computer when I decided to restart my computer because "rocketdock" (a dock program) didn't open a folder and gave me the "open with" dialog instead. Background:- I've installed a lot of updates recently, including SP1. The windows is customized i.e. some files...
BSOD Help and Support
All icons in start menu and desktop are showing blank
Just upgraded WIndows Vista to Windows 7 from a download. The installation appeared to be fine but all of the icons on the desktop have lost their pictures and none of the start menu icons are showing any design nor do they work. I've tried deleting the icon cache and restarting but that hasn't...
Installation & Setup
Desktop icon and start menu not loading - Win7 Ultimate
Hi everyone. I installed Win 7 Ultimate recently on top of my Vista Home 64bit, Vaio laptop. Setup archive was downloaded from microsoft website. Installation was fine, first start up was fine. But after second reboot my desktop stopped loading, its was just a blue screen with sign at the right...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App