Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: FoxPro taking forever to start up on Windows 7

15 Oct 2014   #1
bluby

Windows 7
 
 
FoxPro taking forever to start up on Windows 7

I'm assisting a company that is using fairly old software and they want to get off the old server and on to a more recent workstation.

Here is their setup:

Windows 2000 Server (domain controller) FoxPro 5.0a as a shared folder (no database, just a folder with the data)

How they launch the Inventory system:

PC users double click a lucky.exe shortcut which is mapped to the server share in a \lucky folder. The only requirement for this to run is to map a driver letter E: to the server\lucky folder. When the exe is launched the custom FoxPro inventory system loads immediately. Everyone in the office uses this same method of opening and they can all run it at the same time. The data seems to be stored in a folder called \lucky\LU_

In this current environment the inventory system works fine.

Note: If I try to browse to the LU_ folder it takes quite a bit of time to display the files. I don't know if it's because there is 1gb of data in that \LU_ folder.

However, for the fear of the hard drives failing they would like to get rid of the Windows 2000 server and have the inventory run on a newer machine. So I bought a Windows 7 Pro workstation. Copied the \lucky folder and tried to run the inventory system.

It takes more than 4 minutes just to load the Log in screen. It's clearly hanging or doing something erroneous. Then a pop up asks if we want to RUN the exe). Clicking Run then takes another 4 minutes or so just to see the log in screen appear. I've tested this on a Windows 7 workstation and Windows XP - both have same issues. Once the login screen finally loads the system works fine.

So to recap, I am trying to get the inventory system to work on a Windows 7 Pro workstation but it simply takes forever to load.

Things I've tried that made no difference:

1. right click "Run as administrator"
2. Compatibility mode

Thanks in advance!


My System SpecsSystem Spec
.
15 Oct 2014   #2
Alejandro85

Windows 7 Ultimate x64
 
 

Did you change only the server computer? Is just a new OS or a new hardware altogether? With the fast and slow system, were the all the clients the very same?

If so, it could indicate a network or hardware problem on the newer server. Antiviruses on servers are also known to cause such issues, try disabling it if you have one.
My System SpecsSystem Spec
15 Oct 2014   #3
bluby

Windows 7
 
 

Quote   Quote: Originally Posted by Alejandro85 View Post
Did you change only the server computer? Is just a new OS or a new hardware altogether? With the fast and slow system, were the all the clients the very same?

If so, it could indicate a network or hardware problem on the newer server. Antiviruses on servers are also known to cause such issues, try disabling it if you have one.
They are still using the old Windows 200 server every day. I need to phase it out and get everyone on the new Workstation (WIN7). Yes, all clients same.

I will try disabling Antivirus. And it's not a server, just WIN7 Pro.
My System SpecsSystem Spec
.

16 Oct 2014   #4
bluby

Windows 7
 
 

I have an update on this. AntiVirus prorgram uninstalled and not the culprit.

To test, I took an old XP Workstation (newly formatted) and connected to the live environment (Windows 2000 Server), joined the Workgroup, mapped the drive, launched lucky.exe and it loads fast and works great.

I then removed the mapping, change the workgroup to point to new Windows 7 Workstation, remapped the drives, launched lucky.exe and its brutally slow. I checked resource monitor on the Windows 7 Workstation and it does not spike.

This is a complete mystery. Someone had mentioned something about the files I copied from Windows 2000 Server (Live environment) to the Windows 7 Workstation (test environment) having Encrypted Files enabled since it was on Windows 2000 Server first?
My System SpecsSystem Spec
16 Oct 2014   #5
bluby

Windows 7
 
 

I put together a quick video to show you: http://screencast-o-matic.com/watch/c26Dqwejy3
My System SpecsSystem Spec
16 Oct 2014   #6
Ranger4

Windows 7 Home Premium 64 bit sp1
 
 

Is there anything at this website that might help you.

https://social.msdn.microsoft.com/Fo...-on-win-7x64?f
My System SpecsSystem Spec
17 Oct 2014   #7
bluby

Windows 7
 
 

Quote   Quote: Originally Posted by Ranger4 View Post
Is there anything at this website that might help you.

https://social.msdn.microsoft.com/Fo...-on-win-7x64?f

No, this is not related
My System SpecsSystem Spec
Reply

 FoxPro taking forever to start up on Windows 7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows taking forever to download updates
I just recently did a restoration process on my computer and it is all working fine i am now trying to install updates, there are 144 of them and when i clicked install updates, it said downloading updates and it has been stuck at 0% for over 20 minutes, how long does it actually take to download...
Windows Updates & Activation
Reinstalling Windows without taking forever like in XP
I just reinstalled Windows for my sister based on info here whereby you go to a Microsoft page to download an ISO file. Though this claims to be recent, with updates included, it isn't and far from it. There is somewhere on the same page where you can actually download and include other...
Installation & Setup
Catalyst Control Center taking forever to start
I need this loaded at startup as I have custom gamma and flat panel settings. I have minimal items checked at startup. I did a clean install of 13.9 drivers using DDU. Boot times: Boot time without CCC: Windows has started up: Boot Duration : 66265ms
Graphic Cards
Pet Pet Park taking forever to load on windows 7
really it is i need help
Gaming
Windows Update Taking Forever
Hello. I recently upgraded from XP to Win7 Pro 64 and did the typical updates after the install was complete. After the second round of updates and reboots, the updates started taking forever to complete. Forever being literally one hour for just two updates and the system is stuck on "Creating...
Windows Updates & Activation


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App