Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: plugging old SATA hard disk in AHCI system

01 Dec 2014   #1
anctop

windows 7 professional 32bit
 
 
plugging old SATA hard disk in AHCI system

My current system is running Win7 with SATA configured as AHCI.
I have an old desktop running WinXP but with SATA configured as IDE.

May I ask : Is it safe (in terms of data reliability) to plug the old WinVista HD in the current system for retrieving data files ?


My System SpecsSystem Spec
.
01 Dec 2014   #2
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Why do you mention the XP machine ?

Yes, it`s safe.
My System SpecsSystem Spec
01 Dec 2014   #3
anctop

windows 7 professional 32bit
 
 

I'm sorry, actually I mean the old WinXP HD.

I worry about the risks of data corruption when the file system created by SATA(IDE) is read by SATA(AHCI).
My System SpecsSystem Spec
.

Reply

 plugging old SATA hard disk in AHCI system




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Upgrading Hard Disk from SATA to SATA 3 Drive
The time has come for me to wipe the hard drive and re-install Windows 7 following a recent disastrous download that's effectively knocked out my Internet Explorer 11 and rendered Internet browsing difficult. My system has since become unstable and progressively slow and unfortunately, for some...
Hardware & Devices
SSD hard drive do i use Sata as IDE or AHCI in Bios
Hi Guys I have just fitted a SSD drive in my computer windows 7 64 bit system, when I installed windows onto the new SSD I just unplugged my old hard drive and fitted the SSD and just installed windows 7 and all worked ok. But after the new install was working I was told I needed to make a change...
Hardware & Devices
Changing from SATA RAID to SATA AHCI - Help needed!
I could really use some help with this. I have a HD that I'm moving from one Windows 7 machine to another. The new system is a Gateway DX4860. The old was was also a Gateway DX4820. When I put the old drive in the new computer, I get the Windows Splash screen, the stars begin to appear...
Hardware & Devices
oparating system not found when booting is Sata option AHCI
so here what's wrong with my comp , i have an m17 r2 alienwAre laptop.in the bios menu the sata option HCAI is selected but when the comp boots it says no operating system is found when booting for bios sata option RAID it runs fine. But the comp should be on HCAI in order to run features that a...
General Discussion
AHCI SATA disk E: suddenly DISAPPEARS (auto-ejects..?!)
I have been using XP for many years, now I'm building a pc for the son of a friend of mine, with Windows 7 x64. I decided to go for a Corsair P64 SSD for (C:), and a 1 TB WD Caviar Black for (E:). I connected first the SSD and installed Windows 7, then after I had installed drivers through...
Hardware & Devices
Intel Sata controler ICH10R AHCI + Jmicron AHCI error
Hi. I have the GA-EX58-Extreme Board and have just installed the pre release of Win7 7600 64 bit. Normally i have experience to get the BSOD when in staling with AHCI active in bios so i change to IDE mode. Installation went flawless and also the change to AHCI mode on Intel ICH10R controler...
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:29.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App