Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Understand UEFI and CSM BIOS setting for ASUS H97-Plus

23 Dec 2014   #11
dw85745

Win 7 Pro x32
 
 

Quote:
We deal with a dozen of these a day. Every single one gets installed without need for a UEFI committee thus far. Are you writing a guide?
No. Just trying to figure out the BIOS so I can solve the problem at this link. Both myself and a WD representative can't get a backup drive connected through the USB (NOT the boot drive as its SATA and boots fine) to be OnLine.

Second Hard Drive Not Appearing in Explorer

Quote:
There has always been a way to turn off Secure Boot so far. We could spot it if there were pictures?
Be glad to send all the pics you want. As previously stated did Excel listing because my estimate will be over 100 pics as each line in the Excel list I provided for the most part shows as a separate page for each line. Can you narrow down where I should focus for pics.

Quote:
Read your mobo manual on board's Support Downloads webpage.
I have the MOBO user guide sitting in front of me. Will check website to see if any different. MOBO is brand new - bought 12/5/2014.


My System SpecsSystem Spec
.
23 Dec 2014   #12
gregrocker

 

If you're not even trying to install Win7 then there is rarely need to change settings to get USB external recognized. Those settings mainly pertain to booting either via Legacy or UEFI. Which is yours? If in doubt post back screenshot of Disk Mgmt.

If larger than 2tb Format drive GPT and assign a drive letter. Try every USB port. Is drive detected in another PC? Does it pass Data Lifeguard diagnostics - new or not?
My System SpecsSystem Spec
24 Dec 2014   #13
dw85745

Win 7 Pro x32
 
 

Quote:
Those settings mainly pertain to booting either via Legacy or UEFI. Which is yours? If in doubt post back screenshot of Disk Mgmt.
That is one of the things I'm confused about.
From my prior reading UEFI identifies a new boot standard primarily for Windows OSes.
So Linux or BSD would be considered legacy. Regardiings Windows OSes I think UEFI starts with WIndows 8 or 8.1 (not sure on this). witjh Windows 7 and prior being considered legacy.
UEFI committee never specifies where legacy stops and UEFI begins.

Didn't realize the UEFI standard applied to Hard Disks.

Per your statement attaching DiskMgt pic minus USB problem as not connected right now.

Quote:
If larger than 2tb Format drive GPT and assign a drive letter.?
Problem drive is only 160GB and boot SATA is 250 GB

Quote:
Try every USB port.
Have NOT done that. Tried two or three and Drive is recognized -- just Offline -- so my guess is USB port OK as sees drive.

Quote:
Is drive detected in another PC?
Yes. Initially used an internal IDE to SATA connector and could not get drive recognized. Finally went to shop where I bought MOBO and they used another of the same and found one I had was bad out of the box. While there asked them check drive (they used external USB to IDE -- same one I'm using now) and could see drive and directory with their system.
Bought the external USB to IDE connector from them, hooked it to this MOBO when I got home along with the blank (zeroed) SATA

After playing with BIOS finally found a combination (unfortuantely didn't write down) which allowed me to copy the External to the new SATA using the external USB to IDE adapter. After copying both partitions (C & D) to new SATA, I then installed Window 7 on the new SATA using the same Win7 CD I had used wiith the external drive I loaded the SATA from. Next got a new activation code from M$.

After couple days of loading software needed to access the external for some files and this is where I found the external USB to IDE connector showing, but Offline. As I recall -- but NOT sure -- when the SATA was new and blank, I believe secure boot could be toggled, but Not now -- Read Only. Won't swear that it could be toggled at that time but believe so.

All of above plus discussions on thread link I posted has lead me to thinking problem lies with:
1) BIOS
2) Bad Controller Board.

Since little confused over BIOS settings -- Excel list plus glossary has helped a bunch -- thought I would tackle BIOS first.


Quote:
Does it pass Data Lifeguard diagnostics - new or not?
Have that planned for tomorrow. Planned to boot from CD with SATA boot removed and see if Lifeguard sees drive unless you recommend different configuration?


Attached Images
Understand UEFI and CSM BIOS setting for ASUS H97-Plus-diskmgt.png 
My System SpecsSystem Spec
.

24 Dec 2014   #14
dw85745

Win 7 Pro x32
 
 

FollowUP:

Finally got drive online.
See resolution at:
Second Hard Drive Not Appearing in Explorer

====================================

That leaves just my primary BIOS question as to why "Secure Boot" option is Read-Only and if there is some other BIOS setting I need to Enable/Disable in order to allow me to select it?
My System SpecsSystem Spec
24 Dec 2014   #15
gregrocker

 

Can we see a picture now of the BIOS tab?

While you're at it take a picture also of the tab with the CSM settings. Expand choices so we can see them
My System SpecsSystem Spec
24 Dec 2014   #16
dw85745

Win 7 Pro x32
 
 

Never thought of it till now, but can't use Windows Snipper of my Screen Grab program for BIOS.
Only way -- unless you know otherwise -- is take an actual picture then upload it.
If that is the only option will have to try and borrow one as I do not own a digital camera nor cell phone with a camera.
My System SpecsSystem Spec
Reply

 Understand UEFI and CSM BIOS setting for ASUS H97-Plus




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
UEFI/BIOS Query
I'm expecting delivery later in the week of my new laptop. I selected Windows 7 Professional option as installed OS but OEM are including Windows 8.1 Professional media, as well. Not sure how this works, but I'm wondering if I will have UEFI or bog-standard BIOS to contend with for firmware...
Installation & Setup
UEFI BIOS upgrade
My machine is 2 1/2 years old and due a bit of an upgrade and tidy up. Only hardware upgrade this time will be replacement of the C: drive with an SSD. I'll be doing a full OS & SW re-install rather than cloning what I've got now, so I'm checking for the latest drivers etc to use. Looking at...
Hardware & Devices
UEFI BIOS Windows 7 do I have it??
Hello everybody. I have a question I'm hoping somebody can help me with. I have a Dell XPS 8500 which will be 2 years old this August. I am looking into installing a much bigger internal hard drive but have found out that I need the newer UEFI BIOS to do that. Well I have been driving myself crazy...
General Discussion
Hard Disk Drive not found in ASUS UEFI BIOS Utility - EZ Mode
Hi there, My sister just bought a new desktop. It was working fine and all. But this morning, she forced shut down a windows update. The next thing happen once it gets past through BIOS is "Reboot and select proper boot device or insert boot media in selected boot device and press a key" So I...
Installation & Setup
UEFI or BIOS??
Is the Dell Vostro 400 (my computer) and Toshiba T135 (my laptop) legacy BIOS or UEFI? Note: I have not yet updated the BIOS because I'm too lazy to do so and because it is not required.
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:39.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App