Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IE and Itunes launch links - will not work without running as admin?

04 Jan 2015   #1
agogley

Windows 7 Ultimate 64Bit SP1
 
 
IE and Itunes launch links - will not work without running as admin?

I'm running Windows 7 Ultimate fully updated and the latest Internet Explorer.

When I go to www.movieredeem.com to download my copy of Divergent for ITunes, I'm presented with two options. One for Ultraviolet and one for ITunes. Clicking on the ITunes link is supposed to launch ITunes and log you into the ITunes Store. Whenever I run IE normally, I click on the link and IE doesn't recognize I have ITunes and instead directs me to download it.

If I turn protected mode off, then the link works correctly and ITunes opens and asks for my ITunes Store login. Alternatively, I can run IE as an admin and that also works. But simply running it normally in protected mode, will not work.

I would simply turn off protected mode, but it seems like I should be able to run it (otherwise this topic would be all over the place as a common problem, right?)

So I'm sorta scratching my head. I've reset IE and tinkered with every options I can including various add-ons. I can't figure out how to make ITunes launch in regular IE. I made sure Active X Filtering is not checked.

Any ideas on what setting I'm missing or how to get this to work?


My System SpecsSystem Spec
.
04 Jan 2015   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
Yikes I haven't a clue I would expect something like that to open in Quicktime and not ITunes :/
I did not know ITunes played stuff as a player I always thought it only played downloaded content and until it was actually on your hard drive it did nothing but waste resources
Cheers.
My System SpecsSystem Spec
04 Jan 2015   #3
agogley

Windows 7 Ultimate 64Bit SP1
 
 

The link is to open the ITunes store where you input your code to download the movie to ITunes. You can't play it until it downloads. And then, yes, it could play within ITunes. But the main purpose is to add it to your library so you can transfer it to your phone or Ipad.

The question is, why doesn't IE know I have ITunes installed and open it when I run IE normally. But when I run IE as an admin or with protected mode off, IE suddenly recognizes I have it installed.
My System SpecsSystem Spec
.

04 Jan 2015   #4
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Are all your programs installed on the same drive/ partition as windows is ?

Did it ever work normally as you state ?
You might try Gear symbol and Internet options,
Advanced section and scroll to the bottom of the list and Uncheck SSL 3.0 SSL 2.0 SSL 1.0 and save changes,
Boot your machine,
Or Uninstall ie11 windows update and roll back to ie10 and test using it to rule out a possible ie11 conflict ?
Cheers.
My System SpecsSystem Spec
04 Jan 2015   #5
agogley

Windows 7 Ultimate 64Bit SP1
 
 

Yes, same partition. And yes, there is an add-on by Apple. It is designed to detect the version of ITunes. For whatever reason the add-on does not work in protected mode.
My System SpecsSystem Spec
04 Jan 2015   #6
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

For the record what other security do you have installed protection mode may not be necessary ?
My System SpecsSystem Spec
04 Jan 2015   #7
agogley

Windows 7 Ultimate 64Bit SP1
 
 

I run through a personal router, open DNS, mse, and also spybot and mbyte. More concerned as to why it doesn't work. It seems to me that something somewhere has an incorrect setting. Otherwise, everyone and their brother would be asking about this.

I should say that this is not a problem in other browsers. Just IE.
My System SpecsSystem Spec
04 Jan 2015   #8
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Well if you haven't already tested using ie10 instead or resetting ie11 ?

The only other thing I can think of is to re-install ITunes,
Did you uncheck ssl 3.0 and restart ?
Cheers.
My System SpecsSystem Spec
04 Jan 2015   #9
agogley

Windows 7 Ultimate 64Bit SP1
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi,
Well if you haven't already tested using ie10 instead or resetting ie11 ?

The only other thing I can think of is to re-install ITunes,
Did you uncheck ssl 3.0 and restart ?
Cheers.
I tried unchecking SSL 3.0. No luck. Reinstalled ITunes. No luck. Can't find IE10...must not be looking at correct place.

Something is going on with the permissions and the add-on or web object. For whatever reason, I can run it outside of protected mode and in other browsers. But IE11 seems to not like it. At least not in protected mode. I'd just like to see if there is some option that overrides that aspect of protected mode.
My System SpecsSystem Spec
04 Jan 2015   #10
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Well not that I would recommend it but adding the site to your safe sites list might do that but the easiest thing would be to test Uninstalling the ie11 windows update and that will force windows to reload the prior version of ie what ever that was before you had ie11,
Possibly ie8-9 or 10 depending on how long you've had the computer,
If you choose to Uninstall ie11 you will need to change how you receive windows ups to Check for updates but let me choose when to download and install them,
Then Hide the ie11 update and recheck for updates manually either or both 9 and 10 will appear,
Internet Explorer 10 - Install or Uninstall in Windows 7

See a video here Uninstall three versions of ie in about three minutes,
Internet Explorer 9 - Uninstall

Windows Update Settings - Change

Windows Update - Hide or Restore Hidden Updates
My System SpecsSystem Spec
Reply

 IE and Itunes launch links - will not work without running as admin?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
iTunes Will Not Launch
Hello, I am trying to launch iTunes, and it will not launch. I have reinstalled twice using apples recommended uninstall process, Remove and reinstall iTunes and related software components for Windows Vista, Windows 7, or Windows 8 and I have also tried every step they offer. iTunes for Windows...
Software
Lost Quick Launch links after OS install
overview:I was selling off my old laptop and in the process of wiping it and re installing windows seven on it i lost the links to all my programs installed on my quick launch icons. more details: I completely removed the laptop hard drive and put it into my computer tower to rebuild the OS on...
General Discussion
Launch batch file from the context menu in admin mode
Hi, I found a registry script that creates an option on the windows explorer context menu that allows you to run a batch file. The program that I use within the batch file is producing an access denied error which I dont get if I run the batch file normally. I wondered if this was something to...
General Discussion
Admin account does not have permission to install Itunes
I have administrator rights on my Windows 7 account, and I always have problems installing programs. Usually it is with a folder called config.msi. I don't have write permission for that folder and when I install anything I get multiple error messages about it. I have been unable to install...
Software
ITunes 9.1 setup screen after each launch
upgraded to 9.1 on Win7 64bit, but each time I launch ITunes, I keep getting the setup screen. "Please wait while Windows configures ITunes." Once it goes through the process ITunes works, but each time I open ITunes, I get the same routine. I went back to an older version and I'm having...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App