Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: new hdd won't install Windows 7 bootmgr missing

08 Mar 2015   #1
Constantine76

Windows 7 64 Professional
 
 
new hdd won't install Windows 7 bootmgr missing

A few weeks ago (yes weeks) I turned on my computer and was given a small message, something to the effect of "hard drive not found" after several failed attempts to repair the problem a new msg appeared upon restart, "bootmgr missing."

I bought a new HDD with the exact same specs as the old one and attempted to install Windows 7 professional 64 bit from an installation DVD. At the second stage of the installation process, "expanding windows files" after running about an hour or more the following error code: 0x80070017 pops up and the installation fails.

If I start up the computer without the installation CD, I still receive the missing bootmgr error. Thinking this is the cause for the failed install, I've tried to repair the bootmgr. Using the installation CD and clicking on Repair Your Computer, I can get to the System Recovery Option screen and select Command prompt where I have used bootrec, bootsect, I have cleaned, formatted and activated a partition. Basically, any fix listed when you Google Bootmgr missing, I've tried. Though I am somewhat restricted in what solutions I can try because the new HDD has no pre-installed OS.

Is the missing bootmgr the reason for OS installation failure? How can I fix the bootmgr when everytime I run a fix in the command prompt, it indicates operation successful, yet the bootmgr is still missing and Windows 7 fails to install?


My System SpecsSystem Spec
.
08 Mar 2015   #2
dsperber

Windows 7 Pro x64 (1), Win7 Pro X64 (2)
 
 

Maybe you have a genuine hardware failure on the motherboard, and/or SATA controller?

Sounds like you have issues reading/writing to HD, first the old original and now the new one. Gotta be a hardware failure in the notebook itself, in my opinion.
My System SpecsSystem Spec
08 Mar 2015   #3
gregrocker

 

You'll always get Bootmgr is Missing when trying to boot a HD which hasn't completed Win7 installation yet, or in situations where the BIOS Boot Priority order has changed. So you'll need to complete the new install ignoring that error, and I'd also be sure to test the old hard drive if you haven't already with the maker's HD Diagnostic because it may still be fine but just wasn't set as Primary HD and/or First HD to boot.

To proceed with installation work through the steps to Troubleshoot Windows 7 Installation Failures - Windows 7 Help Forums
My System SpecsSystem Spec
.

13 Mar 2015   #4
Constantine76

Windows 7 64 Professional
 
 

Gregrocker- thanks for posting a reply, I checked out the link you posted and followed the suggested steps. Since the hard drive is new and basically empty I had nothing to back up, so I moved on. I could not find anything remotely similar that would allow me to "set SATA controller to AHCI" so I skipped that step. I set the Hard Drive to boot first and followed the steps you listed under "DISKPART" section. Then booted up the install disk and then installed Windows 7 to the partition I created.

When the installation reached the expanding files section, again, I got the error 0x80070017. I checked your troubleshooting guide, but still could not figure out a way around the error. I am still a novice at "tech speak" so perhaps I misunderstood the best way to get around it. Can you elaborate a bit? Thanks!
My System SpecsSystem Spec
13 Mar 2015   #5
gregrocker

 

The error often is caused by bad installation media. Where did you get the Win7 installation media, how is it burned or written to stick?

Do you have an EFI BIOS? Look in BIOS setup for settings related to CSM, Legacy BIOS, Secure Boot or any other EFI or UEFI settings.
My System SpecsSystem Spec
Reply

 new hdd won't install Windows 7 bootmgr missing




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BOOTMGR is missing after corrupt install
So yesterday after starting up a brand new computer, I was installing my OS when i had a power-cut now every time i turn my pc on it comes with following message "BOOTMGR is missing" I believe my whole harddrive is corrupt maybe, But i do not know how to go about this. I tried running another...
Installation & Setup
BOOTMGR is missing or edit windows boot options while try 2 INSTALL 7
Windows 7 Home Premium 64bit. Gateway desktop all-in-one model zx4951. Recovery media not made by owner 2 years ago when purchased. I tried to make the recovery discs but the program wont launch, it's probably corrupted. I couldn't open some other files, has some corrupted files, Trojans, and lots...
Installation & Setup
BOOTMGR is missing (RAID 0 ICH10R ASUS P6T Windows 7 Install)
I'm somewhat resurrecting the following thread. This thread is the closest thing on the net I have found to my situation. http://www.sevenforums.com/installation-setup/75991-windows-7-install-cannot-load-raid-drivers.html BOOTMGR is missing Win 7 Install Disk boots but can't install ICH10R...
Installation & Setup
BOOTMGR missing after GRUB install
Hello, My HP Mini 110 (w/o CD player) gives some error about BOOTMGR after installing Android-x86 2.2 with GRUB on the second ('data' part) partition (Please note that Ubuntu is installed too, but it does not list it. Cannot get into the Ubuntu 'GRUB' loader too.). Now, the drive letters suddenly...
Installation & Setup
Can't install win7, because 'bootmgr is missing'
Hi, so I'm experiencing some problems with my computer. Recently my motherboard broke so I had to get a new one. After getting the new one in the mail and re-assembling my computer, I thought it would be best if I reinstalled Win7. Win7 was still functioning with the new motherboard, but it had...
Installation & Setup
BOOTMGR is Missing During Windows 7 Install
Hi, I'm attempting to install a copy of Windows 7 on a Asus Eee 1000HE. I downloaded the ISO copy of Windows 7 Home Premium from the Microsoft website on another laptop which I own. I then used diskpart to clean and partition my 16gb usb drive to NTFS. I then transferred the Windows 7 ISO to...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App