Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Explorer does not follow Symbolic Links

19 Mar 2015   #1
Shoaler

Windows 7 x64
 
 
Windows Explorer does not follow Symbolic Links

I have several symbolic links (SYMLINKS) to php files. Until recently when I clicked on the symbolic link, Windows would follow the link and open the php file with an editor. Now it doesn't seem to follow the link in resolving the file extension: it asks me to "Choose the program you want to use to open this file." When I select my editor, it opens the file properly. But next time it asks me again to choose. (Yes, I have "Always use the selected program to open this kind of file" checked.) Any thoughts?


My System SpecsSystem Spec
.
19 Mar 2015   #2
JohnPC

Triple Boot - Win 7 x64 Ultimate x2 + WinXP-mce x1
 
 

Hello,
You might have installed something else recently that may have messed up your default file associations. Have you tried using the Control Panel > Default Programs?
This is a link to an interesting tutorial on the subject in this forum as well.
Regards-
My System SpecsSystem Spec
19 Mar 2015   #3
torrontes

Windows 7 Home Premium 64 bit
 
 

Same problem here. And yeah, I have installed something: the latest Windows update. I know that's the cause, because I noticed the problem on one computer. Then checked on a different one, and no problem there. I immediately applied Windows update to the second machine, and... bam! Explorer no longer resolves symbolic links. Other programs deal with links just fine, but not explorer or alternative file browsers that avail themselves of the services provided by the Windows shell. Bravo Microsoft!
My System SpecsSystem Spec
.

20 Mar 2015   #4
Pyprohly

Windows 10, Windows 8.1 Pro, Windows 7 Professional, OS X El Capitan
 
 

I experience the same problem too.

With a System Restore to a earlier date, I was not able to duplicate this issue, thus I can positively confirm that there currently stands a bug with regards to Symbolic Link behaviour in Windows Explorer, introduced after a recent Windows 7 update.

As a work-around for now: if you would like to navigate to a linked file through Explorer, and you require a programme to access that link, consider using a Hardlink.

If you absolutely require Symbolic Links to function properly under Explorer, you may choose to System Restore to an earlier date.
My System SpecsSystem Spec
27 Mar 2015   #5
Circle

Windows 7 Pro x64
 
 
"Symbolic links?" "Choose * program * open * file" -linux

I'm having issues too. Searching using the above query in this post title yields this as the only search result, and it's only a few days old, possibly further suggesting it was a recent update.

My issue is that when pointed to an executable causes the "Choose a program" dialog. They do appear to be working for other file types.

From 3/12/2015 to 3/26/2015 the only update, besides MSE Definitions, was KB2952664 installed on 3/24/2015. The update was released on 4/16/2014 but Microsoft has continued to silently re-release it every few months. Nobody seems to know what it does.

On 3/12/2015, 45 Updates were installed. The logs show KB2952664 was to be included but failed. It was successfully installed until 3/24/2015. Going through my logs show's that this update continually installs then a few days later (Once even just hours later) uninstalls itself? Here's what I'm seeing.
Quote:
  • Installed: 03/24/15 - <06 Reboots Later> - Exists as of: 03/26/15 - <07 Reboots>
  • Installed: 02/12/15 - <17 Reboots Later> - Uninstalled: 03/12/15 - <01 Reboots Later>
  • Installed: 12/10/14 - <12 Reboots Later> - Uninstalled: 12/10/14 - <35 Reboots Later>
    • Shortest Runtime:33s ○ 8 Uptimes<=25min ○ Installed 14hrs Total
  • Installed: 11/12/14 - <03 Reboots Later> - Uninstalled: 11/24/14 - <05 Reboots Later>
  • Installed: 10/16/14 - <Insuffi. Log Data> - Uninstalled: 10/23/14 - <05 Reboots Later>
  • ReInstld: 09/10/14 - <Insuffi. Log Data> - Uninstalled: 10/07/14 - <No Data>
  • ReInstld: 08/26/14 - <Insuffi. Log Data> - Was a Direct Upgrade - <No Data>
  • ReInstld: 05/20/14 - <Insuffi. Log Data> - Was a Direct Upgrade - <No Data>
So what do you guys think? It will uninstall itself again and everything will go back to normal? Was it some other update?

I can't rollback using System Restore.
My System SpecsSystem Spec
26 May 2015   #6
Shoes

Windows 7 Ultimate x64
 
 

I've just ran Windows Update and now all my Symbolic links from within Explorer are broken - each opening the "Open With" dialog box.
Rolling back with System Restore isn't an option for me. I last used Windows Update around Feb 2015 but since then there's been a lot of updates. I have no idea which one broke symlinks

@Circle, installing/uninstalling KB2952664 seems to have no effect. Perhaps that update is related to Windows 10 compatibility upgrader, GWX?

Edit:
According to this thread it was KB3039066 which broke symbolic links! I've just uninstalled it (you must restart Windows for it to take effect) and my symlinks are no longer redundant!
My System SpecsSystem Spec
29 May 2015   #7
torrontes

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by Shoes View Post
According to this thread it was KB3039066 which broke symbolic links! I've just uninstalled it (you must restart Windows for it to take effect) and my symlinks are no longer redundant!
Yesssssss!!!! It works! Thanks for the tip!

My System SpecsSystem Spec
13 Aug 2015   #8
fred543

Windows 7 Ultimate x64
 
 

Broken again with KB3079757 (replaces KB3039066).
My System SpecsSystem Spec
Reply

 Windows Explorer does not follow Symbolic Links




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Please help me set up symbolic links in Windows 7
Hi, I have thoughT about using symbolic links in my system for the data I store from my Android devices. I have read about it on internet and I understand that there are several ways to create them. Which way is the better one? The DOS method or the method using 3rd party applications? What are...
General Discussion
Internet Explorer 8 is not opening links to new tab in Windows 7 64bit
I have win 7 x64 with IE 8. Whenever i click on link, a new tab incompletely open but a pop up displayed on screen. that link may be a pdf, a downloadable file (movie, .exe ), It does happen in IE 9 also, i tried IE 9 by upgrading IE8. A pop up shows " Internet Explorer has stopped working ...
Browsers & Mail
Outlook won't let me follow web links in email/msg says restricted
Hi, Seemingly out of nowhere, Outlook displays the following message when I click on a link in email: This operation has been canceled due to restrictions in effect on this computer. Please contact your system administrator. I sometimes wish I had a 'system administrator', lol. This is...
Microsoft Office
Can't add shortcut links to favorites in windows explorer
Hi everyone, Firstly just wanna say thanks heaps to all the brainy people from this forum. Helped me time and time again and appreciate it heaps ;) Ok, so i'll quickly explain how it got to be this way to begin with and apologies for the long post. Basically, recently i was looking in disk...
General Discussion
E-mails-Internet Explorer links
Can someone possibly help with this issue-When looking at my e-mails and there is a link which l can click on which should take me straight to that link or site on Internet Explorer,many times Internet Explorer page comes up but nothing shows and the only way to get out of the site as the red X...
Browsers & Mail
Follow-up: Accessibility in Windows 7
More...
News


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App