Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Missing explorerframe.dll Fixed but no Explorer ?

05 Apr 2015   #1
JerometheGiraff

Windows 10 Pro
 
 
Missing explorerframe.dll Fixed but no Explorer ?

I ran MalwareBytes because I knew I had malware and adware on my computer, somehow it got on my system. MalwareBytes successfully removed everything; to my surprise restarting my computer and loading windows caused an explorerframe.dll is missing. To fix this, I ran sfc /scannow as an administrator, I was informed there was problems and they were fixed. Restarted the computer once again, the explorerframe.dll is missing error is gone but windows doesn't load, since I have a background loader, I can see all my drivers loading, except one thing that makes my computer usable, explorer, no start button etc.


My System SpecsSystem Spec
.
25 Apr 2015   #2
Jackbnimble924

Windows 7 Home Premium x64
 
 

Hi Jerome,
I've done the same thing on a friend's computer (MBAM, sfc for explorerframe) and am getting the Windows load without explorer.exe as well. If I try to start it manually the process closes itself after a second (before loading Task bar, etc).
Did you manage to resolve your issue?
If so, I'd really like to know how
Thanks
My System SpecsSystem Spec
26 Apr 2015   #3
JerometheGiraff

Windows 10 Pro
 
 

Hi, I did manage to resolve, I had to restore a 2 month old backup, it was the only way, that or you'd have to re-install fresh

If you had the same virus/malware that I had, Malwarebytes Anti-Malware will remove the Virus/malware, but because the Virus/malware embedded its self deep into the windows registry, there is no other solution then what I mentioned, it crippled everything else in the process. I did endless searching for answers before restoring my backup, hours upon hours hoping I didn't have to go that route, I came up empty handed.

I got attacked today, by two malware, one I removed, the other is not a major threat so I will remove soon. I have a solution in the works, but I haven't got it fully operational yet
My System SpecsSystem Spec
.

28 Apr 2015   #4
Jackbnimble924

Windows 7 Home Premium x64
 
 

Didn't have a backup to restore from but my persistence won and I found a solution.

The adware/malware had infected the explorerframe.dll and MBAM mistakenly removed a bunch of registry keys that referenced explorerframe.DLL along with the malware specific keys.
I restored the keys (only) from the MBAM quarantine then went through the log and manually removed the restored keys that referenced the malware (in my case, something called plesome), and left the others that only referenced explorerframe.DLL alone.
After a reboot, explorer.exe was running again and they were no longer getting hidden iexplore windows making random sounds!
My System SpecsSystem Spec
29 Apr 2015   #5
JerometheGiraff

Windows 10 Pro
 
 

Wait, how did you do this ? If I had of know three weeks ago; I got another virus three weeks later, Bronchitis, coughing is a real pain in the ass, especially when recovering !

My System SpecsSystem Spec
29 Apr 2015   #6
Jackbnimble924

Windows 7 Home Premium x64
 
 

In MBAM (the latest version at least) I went into the quarantine and selected all the registry keys that had been removed by the scan.
Then I've gone into regedit and checked out the keys manually, using the MBAM results log as a guide.
Only about 6 keys in my case out of the 30 or so removed, actually referenced the malware. So I deleted those keys and left the rest which I assume are regular keys that reference Explorerframe.DLL some/all of which are required to actually run explorer.exe.

Might not seem very safe, but another MBAM scan was clean and the symptoms are gone so I'm pretty happy!

Hope you feel better soon!
My System SpecsSystem Spec
29 Apr 2015   #7
JerometheGiraff

Windows 10 Pro
 
 

That was a smart way, I'm going to keep that method in mind. I hope I feel better soon tool, I had a cold,flu & Bronchitis combined over several days, real brutal.
My System SpecsSystem Spec
Reply

 Missing explorerframe.dll Fixed but no Explorer ?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
missing explorerframe.dll
I have WIN 7 ULTIMATE x64 ... My computer doent strting because it getting error ... PLEASE SOMEONE UPLOAD YOUR explorerframe.dll ... C:\windows\system32 Please as fast as possible....
General Discussion
Replacing explorerframe.dll crashes explorer.exe - 0xc000007B
I am trying to completely install the Appos theme and am having trouble replacing explorerframe.dll without explorer crashing and failing to restart. This theme in particular comes with an x86, x63, and sp1 folder that contain the explorerframe.dll files. I have followed every guide to the T...
Themes and Styles
Windows missing bootmgr fixed, but caused more problems
So I was trying to shrink my hard drive to make a second one for another OS. But I accidently clicked on Make Active, so I canceled my plans. The next day my computer didnt start with the message: Missing bootmgr ... something like that, I looked for a a solution online and tried everything. I...
General Discussion
Explorerframe.dll Folders missing, default dlls, theme manager
Ok I have 3 questions so I'm going to jam them all in one topic instead of making 3. I installed this theme and its explorerframe.dll: PlastiQ Aero 1.1 by ~Lukeedee on deviantART Now when I open a window that involves folders like this:http://imgur.com/28CNo http://i.imgur.com/28CNo.png ...
Themes and Styles
BSOD, as well as possible explorer.exe and ExplorerFrame.dll problems
A couple of months ago I ordered a computer from a nearby city. After a few weeks I started to have BSOD problems during the startup, always when windows was loading. Startup Repair was unable to fix these problems, mostly because Startup Repair would crash during the process. Not long after the...
BSOD Help and Support
Explorer crash caused by explorerframe.exe
Hi! I have browsed this website for a solution for my explorer crash but hadn't found anyhing that works! My explorer crashes after I try to browse my user/ folders like Downloads etc. and my explorer crashes 90% of the time. It's getting really annoying because I cannot put my schoolwork into my...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App