Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Windows 7 64bit, Asus A8n32sli-deluxe

07 Nov 2009   #1

Windows7
 
 
Windows 7 64bit, Asus A8n32sli-deluxe

I decided to go to Windows 7(64) and I also wanted to upgrade from 2g dual channel to 4g dual channel memory. I did a clean install with only 2g memory installed, because I had already read about the issue I was going to face. So I get Windows 7 running with 2g memory, no problems. Install the other 2g(now the total is4g), and everything is running fine.

Windows recognizes 4g, but only 2.97 is usuable. Also I've noticed there are two unknown devices on my motherboard. So I'm guessing there weren't drivers for them on the Windows 7 installation disk. My system seems fine, but I would like to use all of the ram I've installed and also I would like to be sure that the correct drivers for this motherboard are installed.
(Asus A8n32Sli-deluxe)

Visiting the Asus website for answers is not helping, pretty much there are users with the same issue I have, and there is no definate answer to solve this problem. Just other users saying "try this or try that" Seems to me that Asus would release a Windows 7(64bitdriver) for this motherboard? Is that going to happen? I'm being impatient? Or should I just be happy that my system works at all. The answer is make me a W764bitdriver for the asusAn32sli deluxe or hear me complain about Asus till I die.

Or can anyone help? Thanks

My System SpecsSystem Spec
.

07 Nov 2009   #2

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I wish that I could help, because I have the same MB, but am having the same memory issue. When I went to the memory tab of the Resource Monitor, it shows that 1GB is hardware reserved, but I have yet to discover what is reserving it. I seriously doubt that the unknown devices in your Device Manager has anything to do with this. because I have no unknown devices.
My System SpecsSystem Spec
07 Nov 2009   #3

Windows 7 Professional 64-bit
 
 
Win7, 4GB RAM, and ASUS mobo

Hi Prefontaine, I'm in much the same position. My system is based on an ASUS M2N4-SLI motherboard, has 4GB of dual-channel RAM, and I recently upgraded to Windows 7 Pro 64-bit. Having had some bad install experiences in the past, I visited every hardware vendor's site before I started and burned every available driver to DVD before formatting. It turned out to be unnecessary though - Windows 7 booted up with its own drivers for my hardware, and Windows Update brought me another ASUS driver set on its first run. So I never used anything from my Drivers disc. My Windows 7 'Computer' properties page states 4.00GB of RAM installed.

One thing I've noticed is that some ASUS setups set aside a certain amount of RAM for on-board video. On my wife's ASUS board the BIOS setting can be 'Auto' up to '256MB'. Even if yours was set to '256MB', that doesn't cover the whole 1.03GB you're not seeing, but it is a place to start.
My System SpecsSystem Spec
.


07 Nov 2009   #4

Windows 7 64 SP1
 
 

I have the Asus M2N-SLI Deluxe and with both Windows Vista 64 and Winows 7 64 I had to play around with the Windows System Configuration - Boot - Advanced Options to get Windows to recognize all of my four GB of memory. With Vista it was a bit more straight forward by checking the HAL box. But for Win 7 I had to check, reboot and then uncheck reboot and then choose Normal Startup to get it to recognize all the memory. After I did that I was able to go back to selective startup. A bit weird but now I have no more problems.









My System SpecsSystem Spec
07 Nov 2009   #5

Windows 7 X64
 
 

I have your board and this used to work all though the last time I tried it my machine wouldn't boot for some reason.

In your BOIS:

Advanced-> CPU Configuration -> Memory Setting-> Memory Configuration-> Hardware Memory Hole -> Enable

This will let you use all 4gb, the problem I used to have was the machine would not resume from standby correctly.

The two devices 1 is midi port which has not worked since vista so just disable in BIOS, Second is ACPI device you can get the driver from the asus site under ATK1 "ACPI driver for ATK 0110 virtual device for Windows (32bit and 64bit)/2003(32bit & 64bit)/VISTA(32bit & 64bit)". You don't have to install the program just show device manager were the driver is, its in the ASUS_CoolnQuiet_V21706\2.17.06\Acpi64\WINVISTA folder.

I opted to just run 3gb so resume would work since I use it all the time and the extra gb of RAM doesn't seem to make a huge difference. I'm also running RAID and SLI so you may not have the problems I did depending on your config. When you enable memory hole you will see the system use all the RAM when it first posts.
My System SpecsSystem Spec
08 Nov 2009   #6

Windows7
 
 
the most help ive gotten so far

thanks everybody. All of your replys seem very helpful. I was getting the run aroud on the asus site, not finding any real solutions. It may be awhile but once I get to it I will try to get my 4g's of Ram usable. I'll let ya'll know what worked.

thanks again, and if anyone else has any more suggestions let us know.
My System SpecsSystem Spec
08 Nov 2009   #7

Windows7
 
 

Oh, and one more question. Is it necessary to install any of the drivers that originally came on the asus motherboard CD. Or does the install of Windows 7 take care of that for me?
My System SpecsSystem Spec
08 Nov 2009   #8

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Zone23,

Hmm, I just tried the memory hole setting, and it did work as far as showing all of the memory, but each time Windows got to the login screen, it BSODed with an 0XD1 on vsmraid.sys.

This is curious, because that is a VIA driver, and the only thing that I have that is VIA is a PCI controller, which is raid, but I don't use the raid. The reason that I have it installed is for an SATA optical drive that there isn't room for otherwise.

From what I saw at a glance Googling, it appears that vsmraid.sys is a 32 bit file, rather than 64. I know that I never installed it, so I assume that Windows Update did.

Beside uninstalling the controller, which would also cost me the optical drive, is there some other solution?
My System SpecsSystem Spec
08 Nov 2009   #9

Windows7
 
 

Yes, the memory hole setting to enable works! No problems so far.
My System SpecsSystem Spec
08 Nov 2009   #10

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Quote   Quote: Originally Posted by Prefontaine View Post
Oh, and one more question. Is it necessary to install any of the drivers that originally came on the asus motherboard CD. Or does the install of Windows 7 take care of that for me?
I doubt that you will need anything from the CD, I didn't.
My System SpecsSystem Spec
Reply

 Windows 7 64bit, Asus A8n32sli-deluxe





Thread Tools



Similar help and support threads for2: Windows 7 64bit, Asus A8n32sli-deluxe
Thread Forum
Asus p5gd2 deluxe mb and windows 7 Hardware & Devices
Windows 7 audio driver for ASUS P5WDH deluxe Drivers
ASUS P6T Deluxe V2 & 920...with H50 Hardware & Devices
upgraded frpm asus P6T to asus P6T deluxe 2... General Discussion
ASUS A8N-SLI Deluxe Installation & Setup
Asus M4A79T Deluxe and windows 7 anyone? Hardware & Devices
ASUS P6T Deluxe Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:53 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33