Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Reinstall Win 7, many missing mystery drivers

10 Nov 2009   #1
robertpri

Win 7 - 64 Pro
 
 
Reinstall Win 7, many missing mystery drivers

This is related to another thread of mine, but the situatioin has changed so radically that a new thread made sense.

With the help of MS Tech Support on the phone [got right through!] he explained how to get rid of all my annoying partitiions. So, both drives were wiped out and made into single primary partitions.

I then installed Vista but had problems with a few of the drivers. A couple of them failed, but they were like 'touchpad' and such. Nothing that I saw as critical.

The minute Vista was complete, I custom installed Win 7 and it went well, execpt that it did say it could not find some drivers--of course, it did NOT say WHICH drivers! It just says, driver missing, click to browse or install.

I have no idea which one, or where it is.

So, rebooted to Win 7 and a few issues:

1: it knows the second hard drive is present and working, but it does not show in My Computer or Explorer. That is my biggest issue.

2: I have been installing second monitors on many machines for years, but this time, Win 7 can't seem to find my large moniitor. It worked before with Vista and it worked before with the first insall of Win 7.

It says missing drivers in the screen shots, but are these Vista drivers it wants? Or Win 7 drivers?




Attached Thumbnails
-7.jpg  
Attached Images
   
My System SpecsSystem Spec
10 Nov 2009   #2
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Hi

Try downloading drivers from here:

ASUSTeK Computer Inc.-Support-
My System SpecsSystem Spec
10 Nov 2009   #3
zone23

Windows 7 X64
 
 

Do you have a card reader? Those device IDs appear to point missing card reader drivers. Is your USB ports working? Looks like maybe a chipset driver.
My System SpecsSystem Spec
10 Nov 2009   #4
robertpri

Win 7 - 64 Pro
 
 

Thanks. i went to the Asus site but the error does not tell me much--missing device driver. During the install, it was the same problem: missing device driver, without telling me which device. Annoying.

All USB ports appear to be working, but I have 4 and did not try them all. Wiil do.

The error: base system device: PCI/VEN etc should tell me something, but it does not relate to anything I can find on the Asus site.

I browsed everywhere in windows.old [vista] but Win 7 did not like any of them.

Looks like another call to Asus.
My System SpecsSystem Spec
11 Nov 2009   #5
robertpri

Win 7 - 64 Pro
 
 

I have solved most problems except for two 'base system device' errors. "Missing drivers" is the Win 7 msg. Asus tech support on the phone has improved considerably over the years, but once they understood that I was installing Windows 7 instead of Vista that came with their laptop--Tech support said they could not do anything for upgrading my Asus laptop.

In a way, I don't blame them, but calls to MS Tech support have confirmed Win7 is an upgrade and is "looking for installed Vista drivers by Asus". So, catch 22.

Asus won't help, but I have cleared most driver errors. Down to only two now.
My System SpecsSystem Spec
19 Nov 2009   #6
thefabe

Windows 7 ultimate 64 bit / XP Home sp3
 
 

The base system device is aR5C833 card reader They only have Vista drivers. Can be installed in compatibility mode Compatibility Mode Driver 32 bit ASUSTeK Computer Inc.-Support- 64 bit here ASUSTeK Computer Inc.-Support- Also you list your laptop as the Asus G50 but Asus only has the G50G and G50V G50VT(best buy) and G50VT the drivers listed are for the G50G If your is one of the others go to the last link and maje the afjustment in your series.Fabe
My System SpecsSystem Spec
20 Nov 2009   #7
robertpri

Win 7 - 64 Pro
 
 

Thanks. The missing base drivers are all related to video, as I learned by checking the existing video drivers. I have downloaded the latest Nvidia drivers, but want to make backups before installing them. True, the missing drivers are Vista related [according to Asus Tech support] but for some reason, Win 7 wants them installed.

But once you upgrade to Win 7, the Vista driver CD that came with the Asus G50 no longer works. So, I'll try the Nvidia drivers after pumping up some courage. I hate the thought of crashing out.
My System SpecsSystem Spec
Reply

 Reinstall Win 7, many missing mystery drivers




Thread Tools





Similar help and support threads
Thread Forum
Missing qam channels after fresh reinstall
Hey. First props to the site, been here a few times and very helpful. I use a haudaphage 2250 tv tuner. I recently did a fresh install of windows seven. On previous install i had to of the "free hd channels" that the tuner can pick up. After fresh install, there gone and after several tv signal...
Media Center
BootMgr Missing, cannot reinstall Win7
I have tried reinstalling my windows 7 onto my SSD and am having no luck. I believe I have went through most guides / troubleshooting I could find on this website as well as others. After attempting to use my original cd with no luck, I followed the steps only to have the cd go no further than 73%...
Backup and Restore
The mystery of the missing files.
Hi, I've only just got onto windows 7 and I'm trying to get two machines setup. Both are running Windows 7 Home Premium. My problem is this... On one of the machines, I've got Sage Accounts installed. When I open the Sage software and then go to the Backup option it shows me a Sage...
Network & Sharing
Mystery hardware lacking drivers
Hello all. When I check Device Manager on my Asus laptop there are two categories expanded with the exclamation point warning icon beside them. Both are the same, under the "Other devices" category. Both are called "Base System Device". The icon looks a bit like a tower PC case - are these...
Hardware & Devices
Windows Explorer - the mystery of missing columns!
Hello all, I hope you had a great xmas/family time I had been having plenty of "not responding" apps and windows, so I did some registry clean thing online. Im not sure that caused the second problem, but its really weird and Ive never seen it before, in "details view", there is only an icon...
Software
two graphics drivers and a mystery
Okay this is what I see in my comp management>>Device Drivers. Are there supposed to be two graphics drivers? And the yellow triangle. I'm not too sure about that. Any suggestions??? I've got to leave for work so I'll check back tonight! Cheers :)
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App