Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Back to win 7

19 Sep 2015   #1
no1yak

Windows Pro x64
 
 
Back to win 7

Having used win 10 since the 29 July and having had more than enough problems with errors in the event viewer and also MS trying to download another update over an already activated copy of 10, I decided to return to win 7 pro. The first thing I noticed was how much faster 7 loaded and how much faster the response is under win 7 compared to 10. I know it's early days with 10 and things can only improve, but for now I will stay with my trusty win 7 pro.


My System SpecsSystem Spec
.
19 Sep 2015   #2
Djask

Windows 7 Ultimate x64
 
 

I had the same problems with Windows 10. The main problems were the automatic updates, and there was no way to remove all that preinstalled bloatware that came with it.
My System SpecsSystem Spec
21 Sep 2015   #3
brotherboard

Windows 10 Pro 64Bit
 
 

+1
I'm a windows 7 returnee as well. I'm done with Windows 10. I'm not even bothering with my Win 8.1 retail disk any more. I have removed all the telemetry garbage relating to those two O/S. I've read countless posts regarding how "fast" they are in comparison with 7 but did not notice any speed increase with them and my 7 installation zips along just fine.
I wonder how much the "speed increase" with the "latest & greatest" was perceived by users because newer has to be better right?
My System SpecsSystem Spec
.

21 Sep 2015   #4
Djask

Windows 7 Ultimate x64
 
 

Like they say, if it ain't broken, no need to fix it.
My System SpecsSystem Spec
21 Sep 2015   #5
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Yep most of the fast referrals were with startup and it was only because of fake shutdown which 8-8.1 and now 10 uses,
Turn fast start off/ hibernation and 8's and 10 are slow as snails starting up.

7 systems are only as slow as the msconfig startup list are long
My System SpecsSystem Spec
Reply

 Back to win 7




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Getting data back form back up internal drive
Now I know there is a tutorial - well I think there is - where you can send excess data to a large drive to save space on the C: drive as mine is rapidly filling (256GB SSD) and I don't want to end up with a recent situation with my old laptop where the dive became full and I couldn't do a thing...
Performance & Maintenance
Random BSOD--Several different codes back to back. New computer.
Computer seems stable and then will randomly BSOD-- Doesnt seem to be consistent with what im doing. A few of the BSOD's came after a 'error memory reference line' or something like that. Computer is new, I installed drivers with supplied disks from motherboard manufacturer (asus). At first I...
BSOD Help and Support
How do I get back drop down list...save as back?
When I was on 7100 RC x64 Ultimate, whenever I download something to a folder and if that folder already has several files in it all starting with abc...then when I type the first a, Windows would cleverly drop down a list of file names all starting with a and I can select from the drop down list...
General Discussion
Trying to Change back my windows 7 Icons back to default
Alright Guys I installed Iconpackager the latest version. I wanted to change my icons to something else so I did that. Now when I wanted to change them back to default I selected the windows default icons but when I did that all the icons were windows vista. If anyone knows my problem please let...
Themes and Styles
Microsoft strikes back at Google on e-mail back-up plan
Microsoft strikes back at Google on e-mail back-up plan | ZDNet
News
How to get the Audio Output Device back and re install back onto Windo
Hi, I've been on Window's 7 Ultimate 7 64bit for the past three months. Everything have been working smoothly. I've been having the sound perfectly until I recently wanted to listen to a youtube clip and there is no sound. It says "No Audio Output Device Installed". I have tried various...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App