Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: STILL cannot boot a non-UEFI CD on my UEFI Win 7 64-bit - any fix ??

21 Nov 2015   #1
glnz

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit
 
 
STILL cannot boot a non-UEFI CD on my UEFI Win 7 64-bit - any fix ??

-
A year later, and I discover again that I STILL cannot boot from a non-UEFI CD on my UEFI Win 7 Pro SP1 64-bit Dell Optiplex 7010 MT even though "Enable Legacy ROMs" is ENABLED in the BIOS and Secure Boot is OFF.

My original details are here - Cannot boot from CD-DVD in LEGACY mode - NOT Secure Boot NOT UEFI - General Hardware - Desktop - Dell Community

That thread from a year ago describes the issue but then goes off on a tangent into my (successful) experience in establishing dual-booting, but THIS ISSUE remains. My Dell Optiplex 7010 MT (which is now dual-booting Win 7 Pro SP1 64-bit and Win 10 Pro 64-bit) will NOT BOOT a legacy CD that is not UEFI even though "Enable Legacy ROMs" is CHECKED in the BIOS and Secure Boot is OFF. (My BIOS is A20.)

What is the fix??

Please reply here, not in my old Dell thread above. Thanks.
-


My System SpecsSystem Spec
.
21 Nov 2015   #2
glnz

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit
 
 

-
Update - I have now made TWO bootable CDs of Macrium Reflect. These two CDs show the problem.

First, in my old Dell Optiplex 755 Win XP Pro SP3 32-bit machine, I installed Macrium Reflect Free and made a bootable CD with the included Win PE. I assume it will boot in my XP machine. However, that CD will NOT boot in my other PC, which is my Dell Optiplex 7010 MT that dual-boots Win 7 Pro SP1 64-bit and Win 10 Pro 64-bit, even though the BIOS in this Dell Optiplex 7010 MT ENABLES Legacy ROMs.

Second, in that other PC (my Dell Optiplex 7010 MT that dual-boots Win 7 Pro SP1 64-bit and Win 10 Pro 64-bit), I again installed Macrium Reflect Free (with 64-bit architecture) and made a new bootable CD (with the lowest level of Win PE, which is 3.1), and that CD WILL boot in that second machine.

Why are we being tortured this way? I have other bootable CDs from my XP days - is there any way to get them to boot in the second (Win 7 Pro 64-bit) PC?

Thanks.
-
My System SpecsSystem Spec
21 Nov 2015   #3
glnz

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit
 
 

More - the second-to-last paragraph at this link seems to say that my NON-UEFI legacy bootable CDs should actually boot up, since I have Enable Legacy Option ROMs turned ON in my BIOS. So what am I doing wrong?

What exactly is a Legacy ROM option in the boot section of my BIOS - Gigabyte - Motherboards

Thanks.
My System SpecsSystem Spec
.

21 Nov 2015   #4
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

But are you actually booting in Legacy mode ?
My System SpecsSystem Spec
22 Nov 2015   #5
glnz

Dual boot - Win 7 Pro 64-bit and Win 10 Pro 64-bit
 
 

AddRAM - You mean when I turn the 7+10 PC on? It actually boots in UEFI. And I have the AHCI drivers enabled for the boot into Win 7. (See https://support.microsoft.com/en-us/kb/922976 .)

That wild man Speedstep has been trying to teach me something about UEFI at STILL cannot boot from legacy CD on UEFI Win 7 PC - DELL WHY NOT? - General Hardware - Desktop - Dell Community , but in my case Secure Boot is OFF. I thought that Enable Legacy Option ROMs being ON in my BIOS settings should fix this issue, but apparently not.

Thoughts?
My System SpecsSystem Spec
22 Nov 2015   #6
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Sorry I can`t help further as I always install in Legacy mode to a MBR disk.

But installing 7 on my new Sabertooth Z170 should be a challenge, I`ll get it, I always do
My System SpecsSystem Spec
Reply

 STILL cannot boot a non-UEFI CD on my UEFI Win 7 64-bit - any fix ??




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
UEFI USB Win 7 installed. How to check if it really is in UEFI?
Hi, I bought a new Asus desktop which came pre-installed with Windows 8. I've decided to ditch windows 8 and to install a SSD with windows 7 64 bit. I noticed that my motherboard can handle UEFI and I went ahead and created a bootable USB with Win 7 64bit. When I go into BIOS I can see...
Installation & Setup
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
Testing UEFI on a non UEFI sysytem can be done in VMWARE
Hi everyone (Copy of post I made on W8 Forums - but some people don't use those so I've posted here too). Some people might like to test the possibilities of UEFI systems even though their current machines aren't equipped with it. It IS possible to do this in a Virtual machine even if...
Virtualization
UEFI boot keeps changing; UEFI/Win7 handshaking confusion
Trying to understand handshaking between UEFI & Win 7. Have Win7 Pro sp1 64 installed on SSD, mb=Asus F2A85-V Pro. Example: boot to flashdrive to do Acronis backup of SSD; remove SDD, insert spinner; boot again to flashdrive to do Acronis restore to spinner (to test backup); remove flashdrive, boot...
Installation & Setup
Boot UEFI from wake on lan, or convert UEFI MBR to legacy.
Hi all, Currently having a wake on lan issue with a certain computer. The machine is setup correctly but the windows boot information is stored in a 100mb UEFI partition, and when the computer wakes on lan, it will not boot windows, just sit at a blank screen. When it wakes on lan it is...
General Discussion
What's the benefit of UEFI and install Windows in UEFI mode?
I am not sure if this subforum is the right place, if not, pleases help me transfer to the right forum... I recently just build a new setup with Asus P8Z77-V LK, this motherboard comes with UEFI boot and legacy BIOS boot support. So I tested install windows 7 in both mode, and I didn't find...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:54.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App