Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 repair disk for Z170 chipset

26 Mar 2016   #1
Spall

Windows 7 Ultimate 64
 
 
Windows 7 repair disk for Z170 chipset

Hey all,

Does anyone know how I can make a Win7 repair disk that contains the USB 3 drivers for my motherboard?

I recently had a problem and was unable to run repair because of lack of keyboard and mouse functionality.

I'm using an Asus Z170 Deluxe.

Thanks for your time,

-Spall


My System SpecsSystem Spec
.
26 Mar 2016   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi Spall,
have a read of this tutorial,
Device Manager - Access During Windows 7 Installation

Roy
My System SpecsSystem Spec
28 Mar 2016   #3
Spall

Windows 7 Ultimate 64
 
 

I appreciate the quick response! I've read that through a couple times now, and my brain isn't clicking on how that solves my issue.. however, I will admit I'm on some pretty good cold medicine the last couple days

Just to be clear, my motherboard doesn't have any USB2 or PS/2 ports. Everything goes through a USB3 controller. Windows 7 can't see USB3 natively. During the initial install, I had to have the USB3 drivers on a disk inserted in my second ODD.

However, when booting from a Windows Repair Disk (or even repair partition), those drivers don't exist and it won't see them on a second drive. This results in me having no keyboard or mouse capability, thus making boot into a repair volume useless.

I was wondering if there was a way to inject the necessary drivers when creating a repair disk.

Thanks again, and if I've missed what you were trying to point me at, I apologize.
My System SpecsSystem Spec
.

28 Mar 2016   #4
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Maybe im going blind to but the specs for that include USB2 ports (non blue inards),
  • USB PortsIntel® Z170 chipset :
    5 x USB 3.0/2.0 port(s) (1 at back panel, blue, Type-A, 4 at mid-board)
    Intel® Z170 chipset :
    5 x USB 2.0/1.1 port(s) (1 at back panel, black, Type-A, 4 at mid-board)
    ASMedia® USB 3.1 controller :
    5 x USB 3.1/3.0/2.0 port(s) (5 at back panel, teal blue, Type-A)
    ASMedia® USB 3.1 controller :
    1 x USB 3.1/3.0/2.0 port(s) (1 at back panel, , Type-C, Reversible)



  • Back I/O Ports1 x DisplayPort
    1 x HDMI
    5 x USB 3.1 (teal blue)Type-A
    1 x USB 3.1 ()Type-C
    1 x USB 3.0 (blue)
    1 x USB 2.0 (one port can be switched to USB BIOS Flashback)
    1 x Optical S/PDIF out
    1 x ASUS Wi-Fi GO! module (Wi-Fi 802.11 a/b/g/n/ac and Bluetooth v4.0/3.0+HS)
    1 x 8-channel Audio I/O
Internal I/O

1 x AAFP connector
2 x USB 3.0 connector(s) support(s) additional 4 USB 3.0 port(s)
2 x USB 2.0 connector(s) support(s) additional 4 USB 2.0 port(s)
1 x SATA Express connector: ,





above from ASUS site


Roy
My System SpecsSystem Spec
28 Mar 2016   #5
Spall

Windows 7 Ultimate 64
 
 

Well.. ok. Yes.. you're not blind.

I mispoke when I said it doesn't have any USB 2 ports. It doesn't have any usable ports until something that can deal with xHCI shows up.

EHCI was removed with Skylake.. so the USB controller is dead during install of Windows 7. 8 and 10 would work fine. That was solved by having two ODDs and the driver disk supplied by ASUS. The issue is that a Windows 7 Repair Disk just doesn't see the controller in the same way the install disk doesn't see the controller. There's no activity on USB at all after the BIOS lets go and until the drivers are loaded when Win7 boots up.. but the drivers aren't there in a repair disk.

For some reason Intel didn't want people to run 7 on Skylake and it seems some board manufacturers provided solutions. I'm just trying to delay the move to 10 as long as possible.. and I'm worried the next time I have a critical error I won't have any choice if I can't get a working repair disk or partition.

Sorry for the confusion.. and thanks again for even looking at my post
My System SpecsSystem Spec
28 Mar 2016   #6
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

My System SpecsSystem Spec
28 Mar 2016   #7
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

I had no issues when installing windows using the usb 2.0 ports on my Asus Z170, not sure why you`re having issues.
My System SpecsSystem Spec
28 Mar 2016   #8
Urthboundmisfit

Win 10 Pro x64, Win 7 Pro x64
 
 

This worked for me on a Lenovo Flex 3 w a /Skylake CPU, EDIT: 8th item down on the d/l list, integrated xHCI drivers, installed 7 via USB no problem

Windows USB Installation Tool: GIGABYTE - Support - Utility - Motherboard

Intel has a tool also, though I found the gigabyte tool much quicker:
https://downloadcenter.intel.com/dow...reator-Utility

If you prefer just d/l latest generic Intel USB3 drivers & use DISM to integrate into install USB
How to install Windows 7 from a USB 3.0 Thumb Drive (FAST installation!)

HTH
My System SpecsSystem Spec
29 Mar 2016   #9
Spall

Windows 7 Ultimate 64
 
 

I appreciate all the feedback in the thread..

However, Installation is not my issue. Windows 7 has been installed and running since November.

My issue is that I had a small glitch recently, and I could not use the Windows 7 repair disk I created as it can't see the controller (much the same way the install disk can't see it).

My question was: Does anyone know how I can create a 7 repair disk with appropriate drivers injected into it? The repair disk will boot.. it's just that there's no USB activity, and therefore I can't select anything.
My System SpecsSystem Spec
29 Mar 2016   #10
Urthboundmisfit

Win 10 Pro x64, Win 7 Pro x64
 
 

You can use an installation media (with the USB3 xHCI drivers integrated) to Boot to the System Recovery Options (Option 2)

Windows 7 repair disk for Z170 chipset-system_recovery_options.jpg


My System SpecsSystem Spec
Reply

 Windows 7 repair disk for Z170 chipset




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 UEFI install motherboard ASUS Sabertooth Z170 Mark 1
Hi all, I have new mobo Asus Sabertooth Z170 Mark 1. I want to install Windows 7 Home in UEFI mode, but I'm still not successful. Bios settings - SATA Mode Selection - Raid - 2 SSD disks set up in Intel RST as Raid 1 Newest Bios update from 7.1.2016 Boot settings: Launch CSM - Enabled ...
Installation & Setup
Trouble installing Windows 7, Z170 Chipset
Hi everyone. Just joined, seems like a great community :D. I'm having serious trouble doing a clean W7 install, and it's driving me nuts! I just upgraded my PC with a i7-6700K Skylake CPU, MSI Z170-A Pro MB, and Corsair Vengeance LPX DDR4 2133MHz 2x8GB RAM. At first I just plugged in my SSD with...
Installation & Setup
BSOD upon repair mode, UBS boot disk created but no repair option
Hi all - my laptop refuses to boot and when I start in repair mode I get the BSOD with just the cursor visible and nothing happens. If I reboot in safe mode then it hangs at windows\system\drivers\bootdefragdriver.sys I have researched and believe this driver is linked to Glarys Utilities,...
BSOD Help and Support
Why does Windows 7 Repair disk never seem to repair anything?
I have run the Win 7 repair cd several times and the message always comes back that the repair disk could not fix the problem. What is it good for? My installation goes down for apparently no reason-- earlier or later the same day a blue screen will happen and the Win 7 repair mode kicks in. ...
General Discussion
windows 7 repair disk help
i seem to remember a msdn add on to add more to the repair disk but cant seem to find it any can some one help me please.
Software
Windows 7 repair disk
Hi everyone. today i found that my windows 7 64 bit ultimate os was unable to boot. after many restart finally i used my system repair disk. disk did work and i m able to boot now. but can anyone give me some insight about what went wrong in the first place. just dont want this type of problem in...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:02.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App