Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Kbd not working except in BIOS and Safe Mode

11 Apr 2016   #1
taggartcomet

Windows 7 Pro X64
 
 
External Kbd not working except in BIOS and Safe Mode

I ran in to a weird situation today on a co-workers laptop. The computer is a Dell E6420. The external Logitech MK710 keyboard stopped working inside windows suddenly this morning. The mouse connected to the same receiver continued to work. The keyboard works inside of Safe mode and in the bios. I have gone through many troubleshooting steps but no external keyboard will not work on the computer while running in Windows. Strangely the quick launch buttons and volume controls still work on the Logitech keyboard but none of the keys work. Also, if the caps lock is pushed on the laptop keyboard the indicator on the MK710 screen will change so communication is occurring between the devices.

The laptop keyboard still works which makes the situation less painful. Here is what I have tried.

1. Replaced batteries since it is wireless.
2. Tried basic known-good Dell USB keyboard. Same results - cannot type in Windows
3. Removed all HID devices from device manager and rebooted.
4. Checked registry HKLM/System/CCS/control/Class and verified keyboard class is set to kbdclass
5. Update BIOS
6. Reset BIOS to defaults after updating.
7. verified regional keyboard settings are set to English - US
8. Disconnected logitech receiver, removed all HID devices again. Plugged in basic USB keyboard again with same result.

I am at my wits end. Any ideas will be greatly appreciated. Thank you.


My System SpecsSystem Spec
.
11 Apr 2016   #2
oscer1

win 7 64 bit
 
 

Hi welcome to the forum

have you tried a restore point before the problem started? you could try a clean boot to see if the keyboard will work. https://support.microsoft.com/en-us/kb/331796
My System SpecsSystem Spec
11 Apr 2016   #3
taggartcomet

Windows 7 Pro X64
 
 

I should have mentioned that. It was the first thing I wanted to try. Somehow system restore was turned off on his computer. I re-enabled it but no restore points prior to this morning.
My System SpecsSystem Spec
.

11 Apr 2016   #4
taggartcomet

Windows 7 Pro X64
 
 

Oscer, Thank you, thank you!! The link was exactly what I needed to figure it out. I am grateful for a push in the right direction. It turned out to be an old install of HitmanPro.Alert (ver 2.6.5.77 in case someone else has same problem). It had been running happily in the background until today. I went through the list and once that was removed everything is back to normal.
My System SpecsSystem Spec
11 Apr 2016   #5
oscer1

win 7 64 bit
 
 

that's good news glad you got it figured out.
My System SpecsSystem Spec
Reply

 External Kbd not working except in BIOS and Safe Mode




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Internet working in Safe Mode not in normal mode
I'm using windows 7 64-bit operating system with internet explorer 11, and Firefox. I can use my browsers while in safe mode to upload / download information. However, after starting windows normally the browsers no longer work, that is, when I start IE I get the "This page cannot be displayed"...
Browsers & Mail
PC working fine in safe mode but crashes (BSOD) in normal mode
Hello, From last 2 days I am facing constant crash in windows 7 normal mode (Lenovo notebook G580). but when I do boot the pc in safe mode with networking, crash never occurs. I am posting this thread in safe mode only from the same laptop. I have dmp file generated using verifier. and the same...
BSOD Help and Support
Browsers working in safe mode with networking but not in normal mode
Hi , I'm using windows7 32-bit operating system. I have internet explorer 8( it never worked since installation, always shows "No network connection") and Google chrome installed in my computer. I had been using Google chrome which crashed yesterday. I re-installed Chrome and now it says...
Browsers & Mail
Cannot access BIOS, Boot Menu, Safe Mode
I have a Dell Inspiron 570, with Win 7 Home Premium (SP1). I cannot access BIOS, Boot Menu, Safe Mode upon startup. I have tried using F2, F8, F12 numerous times and I have downloaded the latest BIOS update. I have read that I can remove the HDD and force the system into BIOS. I would like to not...
General Discussion
normal mode acting like safe mode and now internet not working
Hi all, my laptop has been acting crazy the past couple of days. First of all, I was watching a movie on it and it just shut down. when I tried restarting it in normal mode i would get to the welcome symbol after what seemed an eternity of loading, but then the screen just went black. when I...
General Discussion
Black border's around screen when in bios or safe mode
Ello folk's I just wanna pick your brain's a bit as i have this issue that has pickled me for a while now. Since i switched from AMD to Nvidia i have had a 2 inch black border around the display while in the bios and safe mode. When no display driver is installed too. While searching online i've...
Graphic Cards


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App