Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: DPC Latency when idle - Keyword *IDLE*

11 Jul 2016   #1
SomeUserName

Windows 7 Ultimate 64Bit (SP1)
 
 
DPC Latency when idle - Keyword *IDLE*

I've been having latency issues lately on P5Q pro turbo while streaming radio, netflix or watching youtube (The typical popping & stuttering I've been reading about). I don't know how long I have had it but I just started noticing a week or 2 ago. Been idle all night while I slept and turn the monitors on first thing today and still getting red spikes.

I have Atheros® L1E Gigabit LAN controller featuring AI NET 2 on a P5Q pro turbo motherboard and have tried driver versions 1.0.0.15, 1.0.0.16 and 1.0.0.18 versions of the Atheros AR8121/AR8113/AR8114 PCI ethernet controller. The driver version on the MB CD is 1.0.0.16.

I have downloaded this package from this site Drivers Informer: Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller overview Which says Win7 should be 1.0.0.49 but when I installed it, it only installed 1.0.0.18. It gave no option which one to install. I cant seem to install .49 version. Funny thing is version .18 isn't even listed in the above link.

NDIS 6.20 is the worst latency offender. Can I safely put NDIS 6.30 or 6.40 on Windows 7x64?

I have tried disabling LAN, video and sound in the device manager as well as a backup Logitech BT mouse driver.

I have 2 video card slots on my MB each with a card. I swapped the card positions around in case something was conflicting. According to How to Detect an IRQ Conflict | eHow I have no conflicting devices and no yellow exclamations.

Nothing seems to help. The ONLY thing that seems to put a temporary fix to the latency is rebooting. Then it will be good for a few hours and then its back.

This morning I have my highest numbers ever. I dont know what they mean except the higher the number the worse things are. Been messing with this for about 2 weeks now and seem to have made 0 progress. When I took the screen shot NDIS was 379us highest execution and now its up to 402us.

I am typing this in notepad before I put it here and in fact just after I wrote highest numbers ever in the above sentence, DPC latency checker went ALL red. This is the first time I have seen it go all red. I wasn't fast enough to get a screen shot but the spikes were between 4000us and 8000us.

Anything I can try next based on the information provided?




Attached Thumbnails
DPC Latency when idle - Keyword *IDLE*-lm.jpg   DPC Latency when idle - Keyword *IDLE*-dm.jpg  
My System SpecsSystem Spec
.
11 Jul 2016   #2
fireberd

Windows 10 64 bit
 
 

First, this really belongs in another forum section. Audio may be affected but its more some system or driver problem.

However, on the sound side, looking at the Device Manager listing, I don't really see a true hardware driver for your PC sound. I see ATI High Definition and NVIDIA High Definition but those are most likely HDMI audio drivers, not PC sound drivers. VIA, according to what I find on the ASUS site is the correct on-board audio.

https://www.asus.com/Motherboards/P5...Desk_Download/

Another Item I see is a wireless adapter. Wi-Fi is a know cause of audio dropout. Disable that or even unplug it if you are not using Wi-Fi. If you are using Wi-Fi, stop and use a wired LAN connection.

The so called driver sites do not always have the latest or even correct drivers. Best to use the ones from the motherboard vendor, or in the case of Intel devices direct from Intel.

Finally, download and run the free Resplendence Latency Mon program. It is much more than the limited DPC Latency Checker program.

Resplendence Software - LatencyMon: suitability checker for real-time audio and other tasks
My System SpecsSystem Spec
11 Jul 2016   #3
SomeUserName

Windows 7 Ultimate 64Bit (SP1)
 
 

So I found a program called driver easy and learned today that under no circumstances can windows driver seach be trusted. It always says the best driver is already installed.
There was 35 out of date drivers on my machine including an updated Atheros driver. They are now all up to date.
Then I checked another program called Iobit driver booster and it found MORE that DriverEasy missed and those are all up to date now too. Some of the drivers were dated as far back as 2006. While updating my drivers I did multiple reboots so I'll see how it after a few hours of use.

In response to the reply above:
I am hooked up to LAN. When I first moved here I had to buy a wireless stick so I had internet until my appointment to get my cable modem hooked up. The driver is still there but the stick is not in use.

If I recall the VIA HD driver was a Microsoft driver and DriverEasy found me the the actual VIA driver.
------------------------------------------------
If this should be in another section the feel free to move it to another place but hopefully all these updates fixes the problem. This evening will tell.


Attached Images
DPC Latency when idle - Keyword *IDLE*-atheros.jpg DPC Latency when idle - Keyword *IDLE*-via.jpg 
My System SpecsSystem Spec
.

11 Jul 2016   #4
fireberd

Windows 10 64 bit
 
 

I do not trust any of the driver sites. I ONLY use drivers from the motherboard vendor, hardware vendor or Microsoft.
I use my PC for my recording studio so I have to be careful of what drivers I use.

Download and run the Resplendence Latency Mon program as I previously suggested. It is the best program available for DPC latency.
My System SpecsSystem Spec
11 Jul 2016   #5
SomeUserName

Windows 7 Ultimate 64Bit (SP1)
 
 

I have been running LatenctMon. Thats where I got the 379ms highest execution time in my 1st post. Updating my drivers didnt seem to help as I still have stutters and pops. DPC Checker is hitting red again and LatencyMon still shows NDIS as the main offender. 6.5 hours running and now the highest execution is 40.498977(ms) for NDIS.sys 6.20. It was going good for a while until I used Netflix. Then the numbers soared.
My System SpecsSystem Spec
11 Jul 2016   #6
SomeUserName

Windows 7 Ultimate 64Bit (SP1)
 
 

If there is a better section this post can be put in, can an admin please move it there? This is more serious than I thought. The audio problem isn't just with streaming, it seems I'm also having trouble withe media player as well while watching a downloaded movie. Nothing is/was streaming. It was playing off the secondary HDD. The popping/stuttering/choppiness remains. Updating all the drivers didn't do a damn thing.
My System SpecsSystem Spec
12 Jul 2016   #7
fireberd

Windows 10 64 bit
 
 

I can't move posts. But, it really does belong in a system problem section. The sound is affected but that is a byproduct of whatever system issues you have.
My System SpecsSystem Spec
22 Jul 2016   #8
SomeUserName

Windows 7 Ultimate 64Bit (SP1)
 
 

?????
My System SpecsSystem Spec
Reply

 DPC Latency when idle - Keyword *IDLE*




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD after laptop sitting idle / Not sure how long of idle time
BSOD happens randomly, not all the time. Dump files attached
BSOD Help and Support
BSOD at idle multiple times in last week keyword 0x8000000000000002
While my machine has been idle iv been getting crashes, It seems diffrent from the last set of issues I had (driver related) attached all of the relevant files. thank for any help you can provide.
BSOD Help and Support
Display goes dark after 5 min idle; set to turn off after 30 min idle
My display turns off (goes to black screen) after 5 minutes idle, even though I have display set to turn off after 30 minutes idle and the computer to sleep after 1 hour idle (this was done under Power Options in the Control Panel). This just started after the last big Microsoft updates were...
General Discussion
BSOD - Crashes while computer idle/not idle (Unpredictable)
Windows 7 Enterprise 64bit Clean installation to windows 7 from Windows XP professional Hardware 18 months old OS installed 2 weeks ago I am currently facing the lovely BSOD error. The computer was recently upgraded from windows XP to Windows 7 enterprise 64bit , this was a fresh...
BSOD Help and Support
PC will not idle
Hello lads, I'm sorry if I'm not posting this in the right place, but I don't know where else this would fit. Since I upgraded my PC, I realized that it won't detect idleness. I set my monitor to turn off after 1 minute, but that doesn't happen. The same applies to anything I set to turn off,...
Hardware & Devices
win 7 ram at 50% when idle
my laptop's ram usage always displays around 50% even when idle. help! my laptop is Asus k50ij intel pentium T4400 4GB DDR2, win7 64-bit
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:34.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App