Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Some .exe don't start

09 Dec 2009   #1

Windows 7
 
 
Some .exe don't start

Hello.
I recently installed Windows 7 Professional on my laptop. All worked great until I found that some applications I used without any problem (For example Show Desktop.exe, a small utility wich minimizes all open windows or TeaksLogon.exe, another small utility wich let me change the background image when I log on with Windows 7) now doesn't work. When you double click on the exe you just don't see anything except the loading blue circle of my pointer for a few seconds. Opening the Windows Task Manager I can see in the active processes that the application starts and ends quickly.
I don't know what I could have done for make these applications don't work and I have no restore point. I tried to live with it but now it's becoming annoying and I wish there is a way to fix this issue. I wish I could solve it without formatting.

Well thanks for the help and sorry about my english, I'm not a native englishe speaker.

Edit: I may forgot to say: this is not a compatibility problem since all these applications worked well with windows 7 and I tried to run them in Xp, Vista and Windows 2000 mode.
This is the "Show Desktop" application I was talking about: http://ceiiular.deviantart.com/art/S...ktop-133022210

My System SpecsSystem Spec
09 Dec 2009   #2

Windows 7 Professional x64
 
 

Welcome to the Forums!
What anti-virus do you have? Try using Microsoft Security Essentials or Malwarebytes to scan for viruses.

Did these programs work in Windows 7 before, or another OS?
My System SpecsSystem Spec
09 Dec 2009   #3

Windows 7
 
 

Quote   Quote: Originally Posted by Jonathan_King View Post
Welcome to the Forums!
What anti-virus do you have? Try using Microsoft Security Essentials or Malwarebytes to scan for viruses.

Did these programs work in Windows 7 before, or another OS?
Hello and thanks.
I'm using Avast as antivirus and Ad-Aware.
These programs worked in Windows 7 before. It happened something like this
- I first installed Windows 7
- I had no problem with these programs
- After 2 weeks they stopped to work
My System SpecsSystem Spec
.


09 Dec 2009   #4

Windows 7 Professional x64
 
 

Sounds like a virus. Try MSE or Malwarebytes to scan for viruses. You can also try a system restore if the problem happened recently.
My System SpecsSystem Spec
09 Dec 2009   #5

Windows 7 x64 Ultimate
 
 

If you look in your admin tools, event viewer, probanly under applications, there may be more information about why the program failed to start.

It's quite likely it's dependent on a library that got uninstalled or moved or something. Sometimes you'll get a very confusing "The programs configuration is not correct" dialog box which means specifically that a CRT or other basic library version is not installed that the program needs, or sometimes you get nothing at all, the program just fails to load due to a missing resource.
My System SpecsSystem Spec
09 Dec 2009   #6

Windows 7
 
 

Quote   Quote: Originally Posted by fseal View Post
If you look in your admin tools, event viewer, probanly under applications, there may be more information about why the program failed to start.

It's quite likely it's dependent on a library that got uninstalled or moved or something. Sometimes you'll get a very confusing "The programs configuration is not correct" dialog box which means specifically that a CRT or other basic library version is not installed that the program needs, or sometimes you get nothing at all, the program just fails to load due to a missing resource.
Well I'm looking in the event viewer but I don't see any "event" or any log here.
My System SpecsSystem Spec
10 Dec 2009   #7

Windows 7
 
 

And when I try to load the events log I get a "Snap-In" error.
My System SpecsSystem Spec
10 Dec 2009   #8

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Try the Reliability Monitor.
My System SpecsSystem Spec
10 Dec 2009   #9

Windows 7
 
 

Oh alright, now I can see the logs!

Here's the logs for 3 different programs:

Quote:
Firma del problema
Nome evento problema: APPCRASH
Nome applicazione: Show Desktop.exe
Versione applicazione: 1.0.20.17
Timestamp applicazione: 4a902ecb
Nome modulo con errori: StackHash_3250
Versione modulo con errori: 0.0.0.0
Timestamp modulo con errori: 00000000
Codice eccezione: c0000005
Offset eccezione: 0001102e
Versione SO: 6.1.7600.2.0.0.256.1
ID impostazioni locali: 1040
Informazioni aggiuntive 1: 3250
Ulteriori informazioni 2: 325055436168101a578479ab72a66d1a
Ulteriori informazioni 3: c8b0
Ulteriori informazioni 4: c8b0deb27397de66dbbb0cb7ca788765

Ulteriori informazioni sul problema:
ID bucket: 1586779069
Quote:
Firma del problema
Nome evento problema: APPCRASH
Nome applicazione: ChanThreadWatch.exe
Versione applicazione: 1.2.0.2
Timestamp applicazione: 4a903246
Nome modulo con errori: StackHash_3250
Versione modulo con errori: 0.0.0.0
Timestamp modulo con errori: 00000000
Codice eccezione: c0000005
Offset eccezione: 0001102e
Versione SO: 6.1.7600.2.0.0.256.1
ID impostazioni locali: 1040
Informazioni aggiuntive 1: 3250
Ulteriori informazioni 2: 325055436168101a578479ab72a66d1a
Ulteriori informazioni 3: c8b0
Ulteriori informazioni 4: c8b0deb27397de66dbbb0cb7ca788765

Ulteriori informazioni sul problema
ID bucket: 1597491618
Quote:
Firma del problema
Nome evento problema: APPCRASH
Nome applicazione: TweaksLogon.exe
Versione applicazione: 1.1.3371.36752
Timestamp applicazione: 49caea35
Nome modulo con errori: StackHash_3250
Versione modulo con errori: 0.0.0.0
Timestamp modulo con errori: 00000000
Codice eccezione: c0000005
Offset eccezione: 0001102e
Versione SO: 6.1.7600.2.0.0.256.1
ID impostazioni locali: 1040
Informazioni aggiuntive 1: 3250
Ulteriori informazioni 2: 325055436168101a578479ab72a66d1a
Ulteriori informazioni 3: c8b0
Ulteriori informazioni 4: c8b0deb27397de66dbbb0cb7ca788765

Ulteriori informazioni sul problema
ID bucket: 1586071755
My System SpecsSystem Spec
10 Dec 2009   #10

Windows 7
 
 

With the Reliability Monitor I can see that these programs started to crash on 24/11/09. The fact is that it seems I didn't install anything before it they started to crash.

Here's anyway the first log of the ShowDesktop crash:

Quote:
Descrizione
Faulting application name: Show Desktop.exe, version: 1.0.20.17, time stamp: 0x4a902ecb
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x00011017
Faulting process id: 0x1100
Faulting application start time: 0x01ca6ca11f664c70
Faulting application path: C:\Data\Downloads\Show_Desktop_by_CeIIular\Show Desktop.exe
Faulting module path: unknown
Report Id: 5e4acacd-d894-11de-8b92-d163af6a93df
My System SpecsSystem Spec
Reply

 Some .exe don't start





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:47 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33