Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot start diagnostic policy service

12 Dec 2009   #1
GlobesStudios

Windows 7 Ultimate x64
 
 
Cannot start diagnostic policy service

i tried to diagnose my internet connection, and it informed me that the diagnostic policy service was not running. so i went over to services.msc right clicked the diagnostic policy service and got the following error: im at loss |:




Attached Images
 
My System SpecsSystem Spec
.

12 Dec 2009   #2
rajinisback09

Windows 7 Ultmate 32 bit 6.1.7600 Build 7600
 
 

Just a thought, what if you disable it then reboot then try to start it?
Raj
My System SpecsSystem Spec
12 Dec 2009   #3
GlobesStudios

Windows 7 Ultimate x64
 
 

how do i disable it..?
My System SpecsSystem Spec
.


12 Dec 2009   #4
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Right cick it, select Properties and then select disabled in the dropdown window. The default setting is automatic.
My System SpecsSystem Spec
12 Dec 2009   #5
GlobesStudios

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by rajinisback09 View Post
Just a thought, what if you disable it then reboot then try to start it?
Raj
nope didn't help, same error
My System SpecsSystem Spec
18 Dec 2009   #6
GlobesStudios

Windows 7 Ultimate x64
 
 

Bump x_x
My System SpecsSystem Spec
18 Dec 2009   #7
GlobesStudios

Windows 7 Ultimate x64
 
 

how in 5 days does not one person have an answer?
My System SpecsSystem Spec
18 Dec 2009   #8
seekermeister

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Sometimes you can liken posting on forum to going fishing. If you don't get any bites, it might mean that there are no fish in the pond, at least not with mouths big enough to swallow the size of your hook. At that point, you should go looking for another fishing hole, or go deeper into the ocean of Googling.

The only thought that occurs to me is a question, what happens if you start the service manually in the services.msc?
My System SpecsSystem Spec
18 Dec 2009   #9
richc46

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Quote   Quote: Originally Posted by GlobesStudios View Post
i tried to diagnose my internet connection, and it informed me that the diagnostic policy service was not running. so i went over to services.msc right clicked the diagnostic policy service and got the following error: im at loss |:
This is not the answer that you are looking for and it may not work, but why not bite the bullet, go back 2 weeks or so and do a system restore.

Thats what SR is for, but no one even tries.

My friend lost her entire internet connection (Vista HP), I suggested SR and now all is working fine.

Give it a try, its easy and you can cancel the restore if it does not work out.
My System SpecsSystem Spec
19 Dec 2009   #10
GlobesStudios

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by richc46 View Post
Quote   Quote: Originally Posted by GlobesStudios View Post
i tried to diagnose my internet connection, and it informed me that the diagnostic policy service was not running. so i went over to services.msc right clicked the diagnostic policy service and got the following error: im at loss |:
This is not the answer that you are looking for and it may not work, but why not bite the bullet, go back 2 weeks or so and do a system restore.

Thats what SR is for, but no one even tries.

My friend lost her entire internet connection (Vista HP), I suggested SR and now all is working fine.

Give it a try, its easy and you can cancel the restore if it does not work out.
for some reason i only have a restore point from 2 days ago.. i clicked show more and that's it.. don't know why.. this problem occurred like a month ago
My System SpecsSystem Spec
Reply

 Cannot start diagnostic policy service




Thread Tools





Similar help and support threads
Thread Forum
Windows Diagnostic Service Policy is not running
Hi as the title above says I am having trouble with the windows diagnostic service policy not running. When trying to fix it using troubleshooting it does not do anything. I have set all 3 diagnostics to automatic as some threads have suggested however when I try to enable the diagnostic service...
General Discussion
Diagnostic Policy Service not working
Hello All I am looking for help with a problem I am having with my laptop Dell Inspiron 1545 O/S Windows 7 Home Pemium. It has stopped connecting to the internet through the house wireless router although all other devices in the house can connect. If I try to run troubleshooter I cannot and get...
Network & Sharing
Can't run Diagnostic Policy Service because of Error 5
This started happening when I accidentally turned off my computer whilst it was booting. I have tried sfc /scannow, I have done the CMD thing (net localgroup Administrator) and have tried manually starting the service, to no avail. Here is a screenshot of what I think appears to be the...
Performance & Maintenance
Cannot connect to the Internet. Diagnostic Policy Service not start.
First time posting. Running an Asus Notebook U50F Series with Windows 7 Home Premium, 64 bit, 2 Gig processor w/ 4 GB RAM. I lost the ability to connect to my wireless router or to connect via an Ethernet cable connected to the router. Other devices can connect wirelessly and hard wired so...
Network & Sharing
Unable to connect to Internet-diagnostic policy service off
Background: several weeks ago laptop stopped connecting with internet. Troubleshooter said that the Diagnostic Policy Service was off. Went to admin>services> diagnostic Policy service, no joy, already set in automatic. (Error 5) At the time the laptop stopped connecting the free microsoft...
Network & Sharing
Diagnostic Policy Service cannot be started
I've searched the forum but most error text is different. Mine is simple.. It says I've tried multiple things however I cant get it fixed.. I tried system restore but system restore took 4 days and SURPRISINGLY, the restore failed.. I am planning to do system image restore.. Any help will...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App