Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: high CPU load

21 Dec 2009   #1

Windows 7 - Ultimate
high CPU load


I was using windows 7 since 1 month, but today I had a problem with the cpu of my laptop it's so Hot and making a high sound I don't Know why.

is there anything I could do to fix this ?


My System SpecsSystem Spec
21 Dec 2009   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Probably the fan get it fixed. You may also want to use a cooling pad. I would get this solved soon or you may suffer expensive damage.
My System SpecsSystem Spec

 high CPU load

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
svchost.exe(netsvcs) problem cpu load high
Hello, I have a problem. In the task manager -> system resources, I see that a process called svchost.exe(netsvcs) (if I'm correct) is using about 50% of cpu. The cpu is AMD dual core 2.81GHz. This doesn't always happen. Right now, it uses 48 %. Should I be concerned? Is it a legitimate process...
Performance & Maintenance
BSOD playing games under high load, High-end Intel/Nvidia custom PC
Hi all, This is my first computer build. For the most part it is playing games fine, but three times now in the last several weeks I have gotten BSODs, in Crysis 3, Battlefield 4. I didn't have the presence of mind to write down the error code. I have attached the /zip file generated by SF. ...
BSOD Help and Support
svchost.exe high cpu load problem
Hello everyone! Since this is my first post I wish you all the best and thanks for your help. I really appreciate it. My problem is the following: Since 2 days my cpu load is always at maximum load. I searched the web and found out that many people have the same problem. The funny thing...
Performance & Maintenance
High memory load (~80% idle)
I just installed my new HTPC. This is the spec: ============= AMD A6 with dedicated AGU (ATI Radeon 6530 hd) 4 GB memory Crucial 64 GB SSD Win7 Professional 64 bit I dedicated 512 MB for the AGU.
Performance & Maintenance
High CPU load without any reason !!!
Hi, 1st I have Intel C2D E7200 2.53GHz 3MB Cach and 4GB of DDR2 RAM 2nd now i am using Windows 7 HomePremium 64-bit and installed the RC version of SP1 i am used to use Firefox all the time and it's always opened with about 10 or more tabs and beside this KIS,IDM,Yahoo! Messenger,Media...
Performance & Maintenance
High CPU load when copying files over network
Hiya, I've just installed the Win7 RC on my lab-pc. It's a 2,4GHz Celeron, 1GB DDR-RAM, everything installend on some old 160GB PATA-HDD. Two hi-speed USB Keys are used for ReadyBoost (love that feature). Everything works like a charm, except the file transfer from my WXP machine. I mount...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:49.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App