Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Aero Peek and Alt-Tab Not Working Correctly


15 Jan 2010   #1

Windows 7
 
 
Aero Peek and Alt-Tab Not Working Correctly

Not sure if this is the right place for this post.

Don't think any changes were made between the time they were working and the time they were not. I could be wrong, though.

If I am using a program and I move my mouse over to the taskbar and mouse over another program I have running the preview is displayed only briefly (on the order of milliseconds). If I click the taskbar first, then hover over an icon the preview is displayed correctly and if I mouse over the preview the window is brought to the front. However, if I click the preview the program is only sporadically brought to the front.

I also noticed that Alt-Tab is not working correctly either. When I hit alt-tab the selection menu is again only flashed on screen even while holding Alt.

Restarting computer doesn't fix it.

Already ran the troubleshooter and no problems were found.

Did a system restore to before the problems were there but that did not solve the issue either.

Checked performance settings and everything is enabled.

Like I said earlier I can't think of anything that was changed between the time when it was working and the time that it was not. I literally got up from my computer, sat down in another chair in my office, read a book for a couple hours, came back and it did not work.

My System SpecsSystem Spec
.

15 Jan 2010   #2

Windows 7
 
 

Hmm, I also noticed that tooltips are not working in any program either, unless I have clicked the taskbar then mouse over the tool tip in an open window.

They are doing the same thing. When I mouse over a tooltip it flashed briefly, not even enough time to read it.

Thought maybe it could be a mouse or keyboard problem, switched them both out, still no fix.

Man, I don't have a clue.
My System SpecsSystem Spec
15 Jan 2010   #3

Windows 7
 
 

Checked my video card drivers as well as the Desktop Window Manager. Video card up to date, DWM working properly.

It's so strange, I may have done a bad job explaining the problem because it looks like it works but then something else is happening to close out of the preview or the alt tab or tooltip. If I keep moving my mouse back and forth on the same taskbar icon the preview keeps flashing on and off really really quickly!

I wonder if some registry value didn't get changed or something. Perhaps the time that the preview is supposed to stay visible before minimizing again. But if that were they case then a system restore should have fixed the problem.
My System SpecsSystem Spec
.


15 Jan 2010   #4

Windows 7 Ultimate RTM (Technet)
 
 

This is going to sound crazy, but I've seen it on a several machines in the past. It sounds like an "electronically stuck" key. In essence a keystroke is being repeated with no key actually pressed. Tap all of your esc, shift, alt and ctrl keys (not caps lock) several times each...be sure you do both the left and right ones, and each one separately. Tap each one about 10 times and once you're done, see if the problem persists.
My System SpecsSystem Spec
16 Jan 2010   #5

Windows 7
 
 

I agree with you, that is exactly what it sounds like. It was my first impulse as well. I tried hooking a new mouse and keyboard in but the problem persisted.
My System SpecsSystem Spec
16 Jan 2010   #6

Windows 7
 
 

Hahaha!

Wasn't the mouse, wasn't the keyboard. It was the volume control on my headset! I keep it in my hutch with my old college texts but my cat knocked over my calculus book onto the headset. I thought nothing of it at the time and didn't even bother to put the book back upright. I knew that damnable book would come back to get me!
My System SpecsSystem Spec
16 Jan 2010   #7

Windows 7 Ultimate RTM (Technet)
 
 

Quote   Quote: Originally Posted by Moff158 View Post
Hahaha!

Wasn't the mouse, wasn't the keyboard. It was the volume control on my headset! I keep it in my hutch with my old college texts but my cat knocked over my calculus book onto the headset. I thought nothing of it at the time and didn't even bother to put the book back upright. I knew that damnable book would come back to get me!
LOL...well, at least you got it sorted! Close out the thread if you haven't already
My System SpecsSystem Spec
04 Feb 2010   #8

windows 7
 
 

HAHA Same problem same fix. THANKS!@!
My System SpecsSystem Spec
17 Dec 2010   #9

Windows 7 Home Premium x64
 
 

hello to all.....i found this forum and i hope someone can help me resolve this issue once and for all.

i'm having the same exact problem that moff158 mentioned in his initial (first) post above.

If I am using a program and I move my mouse over to the taskbar and mouse over another program I have running the preview is displayed only briefly (on the order of milliseconds). If I click the taskbar first, then hover over an icon the preview is displayed correctly and if I mouse over the preview the window is brought to the front. However, if I click the preview the program is only sporadically brought to the front.

I also noticed that Alt-Tab is not working correctly either. When I hit alt-tab the selection menu is again only flashed on screen even while holding Alt.

there is definitely a problem with the aero peek feature. sometimes it works and other times it does not work.

as macgyver mentioned above, it seems as if there is an electronically stuck key somewhere, but there is nothing stuck on my keyboard.

PLEASE PLEASE PLEASE HELP???? don't know what else to do to fix this problem....been troubleshooting for hours and nothing works.
My System SpecsSystem Spec
22 Dec 2010   #10

Windows 7 Ultimate 64-bit
 
 
Aero Peek Flashing Blinking

Okay, this took me a week to figure out...
I replaced video drivers, apps, etc.
Nothing worked.

I unplugged my Logitech USB headset (with volume control)...

Ta-da! Fixed!
My System SpecsSystem Spec
Reply

 Aero Peek and Alt-Tab Not Working Correctly




Thread Tools



Similar help and support threads for2: Aero Peek and Alt-Tab Not Working Correctly
Thread Forum
Aero Peek not working General Discussion
Aero Peek not working? General Discussion
aero peek is not working Themes and Styles
Aero Peek not ALWAYS working General Discussion
Solved Aero peek not working correctly in my windows 7 General Discussion
Aero peek not working General Discussion
BUG: Aero Peek enabled but not working General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:19 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33