Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Icons No Start Menu Win7 upgrade


28 Jan 2010   #1

Windows 7 Pro
 
 
No Icons No Start Menu Win7 upgrade

Okay, I'm going to stay calm (HA!) and plead for help! I upgraded from XP to Windows 7 one week ago. I used PC Mover to do the upgrade since MS didn't offer a direct upgrade from XP. I had a few compatibility problems but managed to fix all but my HP Officejet 7310xi. Then, while trying to fix my printer problem and having to reboot my system many, many times I suddenly lost ALL icons except the ones in the lower right of the task bar (Quick start?) and my START icon doesn't work. It won't open at all. I can right click and use the context menus, I have a desktop background, all my shortcuts titles (the text) are there but not a single icon. This is also true for all of my folders including My Computer and Control Panel. Here is what I have tried so far:

- Made sure my profile is set as Admin. before making changes.

- Updated my graphics card driver.

- right clicked desktop and made sure the 'show icons' is clicked

- Made sure windows explorer was running.

- emptied all temp folders/caches and rebooted

- created another user profile and tried logging on with that to see if it is user related. I couldn't even log on as that user.

- went to c:/users/myname/AppData/local/IconCache. I thought this was going to solve the problem because I didn't have a folder named IconCache or Icon or anything close to that. I checked the other profile and it DID so I copied and pasted it into mine. Rebooted - no luck.

- tried restoring computer to previous date - no luck.

This just started yesterday for some reason - all the icons and start menu were fine until then. I can open my programs from the shortcuts on the desktop if I click on the text area -in the area where the icon would normally be, it is blank but is spaced out as though there was an icon there. (I hope that makes sense). Much more frustrating than missing icons is that the START menu won't open! I press the Start button (icon) and nothing - I tried using the windows key on my keyboard - nothing.

Here are my system basics:

Dell XPS 410
Intel Pentium 2.80 GHz, 32-bit OS
Dual Core RAID 500 GB each
RAM 2.00 GB
NVIDIA GEFORCE 8400GS Graphics Card
Windows 7 Professional OS

If you need any more info than that PLEASE let me know. I welcome any help or suggestions!!!

Thank you!


My System SpecsSystem Spec
.

28 Jan 2010   #2

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I don't know anything about PC Mover, but it sounds as though you used it to install Windows 7 on top of your XP system, like some have done with Vista. Upgrading is not a good idea, even when using MS's native method. Generally, when things start going awry, the only good solution is to do a clean install of Windows 7. If you have data that you want to retain, it should be saved on a separate partition prior to formatting the OS partition. If you have multiple harddrives, I strongly recommend that you do the new install on a different harddrive than the one that it is now on, and while doing the install, disconnect all other harddrives until finished. Doing it in this fashion, you will not have a boot menu, you will choose which OS to boot by using the F8 BBS Popup Menu to select the harddrive.

EDIT: I just noticed that you double posted this question...please delete the other thread.
My System SpecsSystem Spec
28 Jan 2010   #3

Windows 7 Ultimate 64bit
 
 

Im pretty sure explorer went funny on you.

If you have a disc,try this
Repair Install
My System SpecsSystem Spec
.


28 Jan 2010   #4

Vista Ult64, Win7600
 
 

Hi you could also try this if Minotars suggestion doesn't help, which I'm sure it will.


icon-cache-rebuildhttp://www.sevenforums.com/tutorials/49819-icon-cache-rebuild.html?ltr=I
My System SpecsSystem Spec
28 Jan 2010   #5
Lee

Win 7 Pro x64, VM Win XP, Win7 Pro Sandbox, Kubuntu 11
 
 

If Minotar, or jfar suggestions don't work you may have to reinstall. If a reinstall is called for then I would recommend you do a clean install. The upgrade path from XP to Win 7 is not the best way to go. Sorry to hear about you problems, but this is something we here at the Forums have seen since the final release back in October. We can only say that a clean install is the only way to go.
My System SpecsSystem Spec
28 Jan 2010   #6

Windows 7 Pro
 
 
SOLVED: no icons, no start menu

First, I want to say a huge THANK YOU to you all for answering me so fast - I was blown away!

Second, I started with MINOTAUR's repair suggestion and VOILA -It Worked!!!!

I am up and running normal with all icons and start menu in place and everything appears to be working beautifully. ('Scuse me while I cry a little here...I'm so happy).

One question: My original post apparently got on the forum twice - I don't know how it did that and I don't know how to delete the 'other' one. I'm new to forums, I've never used one before this (I will from now on!) so I'm not sure how to do some of these things. If you'll tell me how to do the delete I will happily take care of it.

THANK YOU so very much! This forum is a life saver!
My System SpecsSystem Spec
28 Jan 2010   #7

Windows 7 Pro
 
 
SOLVED: no icons, no start menu

First, I want to say a huge THANK YOU to you all for answering me so fast - I was blown away!

Second, I started with MINOTAUR's repair suggestion and VOILA -It Worked!!!!

I am up and running normal with all icons and start menu in place and everything appears to be working beautifully. ('Scuse me while I cry a little here...I'm so happy).

One question: My original post apparently got on the forum twice - I don't know how it did that and I don't know how to delete the 'other' one. I'm new to forums, I've never used one before this (I will from now on!) so I'm not sure how to do some of these things. If you'll tell me how to do the delete I will happily take care of it.

THANK YOU so very much! This forum is a life saver!
My System SpecsSystem Spec
28 Jan 2010   #8

Windows 7 Pro
 
 

Hey, it did it again...posted my comment twice! What am I doing wrong? I always use the preview before I submit so I can fix any typos - ? Halp!
My System SpecsSystem Spec
29 Jan 2010   #9

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by krabkat View Post
Hey, it did it again...posted my comment twice! What am I doing wrong? I always use the preview before I submit so I can fix any typos - ? Halp!
Glad you got it sorted
Perhaps your clicking the button twice by accident?It could be a simple thing

Oh..the bold bitlol
Quote:
always use the preview before I submit so I can fix any typos - ? Halp!
My System SpecsSystem Spec
Reply

 No Icons No Start Menu Win7 upgrade




Thread Tools



Similar help and support threads for2: No Icons No Start Menu Win7 upgrade
Thread Forum
Start Menu Icons Can't Be Removed General Discussion
Icons missing in Start Menu General Discussion
Can i add icons to the start menu? Customization
Solved Start menu icons Customization
Start Menu Icons General Discussion
All icons in Win7 x64 Start Menu are deleted ? General Discussion
Start-menu icons won't set... General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:49 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33