Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Autoplay Menu - Missing/Incorrect Items

24 Feb 2010   #1
AbSoluTc

Windows 7 Pro 64bit
 
 
Autoplay Menu - Missing/Incorrect Items

This is a fresh, newly done machine from scratch. I notice these 2 bottom items when I plug in my iPhone to sync. I can't seem to figure out why they are showing in the list with those icons, let alone why they are there to begin with. I attempted to remove them through the registry and that was a no go. Caused autoplay to stop working for my phone period. I uninstalled the the MS Office document scanning option from office and that had no effect.

Pic below.

What am I missing? Any help would be appreciated.

Thanks






Attached Images
 
My System SpecsSystem Spec
.

25 Feb 2010   #2
azterk

Windows
 
 

Very good program Autoplay Repair.
OrangeBlue / Software / Autoplay Repair
My System SpecsSystem Spec
25 Feb 2010   #3
FZ21Z

Windows 7 Ultimate x64
 
 

You can delete them from the registry...

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\Handlers\

I've just removed Adobe Bridge from my autoplay menu. The attachments are before and after snips...


Attached Thumbnails
-reg.png   -regaft.png  
Attached Images
  
My System SpecsSystem Spec
.


25 Feb 2010   #4
AbSoluTc

Windows 7 Pro 64bit
 
 

The autoplay fixer program does not see any issues. It also does not see those two things.

As posted in my original post, removing those two entries from the registry, causes autoplay to no longer work with my phone. If I remove then, autoplay does not pop up when I connect the phone. Putting the registry keys back, that phone works.

I have no idea what the issue is or why it's doing that. Restarts after removing the registry keys result in the same issue. Nothing.
My System SpecsSystem Spec
25 Feb 2010   #5
FZ21Z

Windows 7 Ultimate x64
 
 

What if you remove the entries from the registry, and try to configure the options in Control Panel\All Control Panel Items\AutoPlay?
My System SpecsSystem Spec
25 Feb 2010   #6
AbSoluTc

Windows 7 Pro 64bit
 
 

Just deleted both registry keys again and set to open folder when I plug in my phone. Nada, nothing. iTunes will sync up just fine, but windows 7 does nothing. It's rather odd to be honest.

The keys in the registry are like this..

First key:


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\Handlers\WIA_ {5133AC0F-6018-409C-BD14-456A78EF595C}]
"DefaultIcon"="C:\\Program Files (x86)\\Common Files\\Microsoft Shared\\MODI\\12.0\\MSPSCAN.EXE,1"
"Action"="Microsoft Office Document Scanning"
"InitCmdLine"="/WiaCmd;C:\\Program Files (x86)\\Common Files\\Microsoft Shared\\MODI\\12.0\\MSPSCAN.EXE;"
"Provider"="Microsoft Office Document Scanning"
"CLSID"="{A55803CC-4D53-404c-8557-FD63DBA95D24}"


Second key:


[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AutoplayHandlers\Handlers\WIA_ {7F79E229-4B44-4A21-83C6-DFF1FFBB12FC}]
"DefaultIcon"="C:\\Program Files (x86)\\Common Files\\Microsoft Shared\\MODI\\12.0\\MSPSCAN.EXE,1"
"Action"="Microsoft Office Document Scanning"
"InitCmdLine"="/WiaCmd;C:\\Program Files (x86)\\Common Files\\Microsoft Shared\\MODI\\12.0\\MSPSCAN.EXE;"
"Provider"="Microsoft Office Document Scanning"
"CLSID"="{A55803CC-4D53-404c-8557-FD63DBA95D24}"
My System SpecsSystem Spec
25 Feb 2010   #7
FZ21Z

Windows 7 Ultimate x64
 
 

Did you try to configure it after in autoplay options.
My System SpecsSystem Spec
25 Feb 2010   #8
AbSoluTc

Windows 7 Pro 64bit
 
 

Yes. Now it seems autoplay is no longer working for the phone. Lol. Might have to restart.
My System SpecsSystem Spec
25 Feb 2010   #9
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

Could this be your problem?

Microsoft Icons...?
My System SpecsSystem Spec
25 Feb 2010   #10
AbSoluTc

Windows 7 Pro 64bit
 
 

Quote   Quote: Originally Posted by WindowsStar View Post
Could this be your problem?

Microsoft Icons...?

No.

The issue I see is, the registry entries are duplicated. Not sure why there needs to be 2 of them. Removing either one results in the phone no longer having autoplay pop up.

Now it is not working at all. Even with the registry settings in there like it was before. I even reinstalled the MS Office Tools - Document and Scanning stuff. Still did nothing.

Removing the ",1" at the end of the DEFAULT ICON line in the registry makes the icon show up. Great. However, autoplay does not work and why are there two of the same things in there? Lastly, why is it when I delete them altogether, the phone quits autoplaying?

Ugh.
My System SpecsSystem Spec
Reply

 Autoplay Menu - Missing/Incorrect Items




Thread Tools





Similar help and support threads
Thread Forum
New Context Menu - Remove & Restore Default Menu Items
How to Remove and Restore the Default "New" Context Menu Items in Windows 7 and Windows 8 This will show you how to either remove or restore the default New context menu items in Windows 7 and Windows 8. These include the NEW - Folder, Shortcut, Bitmap image, Contact, Journal Document, Rich...
Tutorials
Context Menu Items Missing - Fix when more than 15 Files are Selected
Restore Missing "Open", "Print", and "Edit" Context Menu Items when more than 15 Files are Selected This will show how to restore the missing Open, Print, and Edit context menu (right click) items for when you have more than 15 files selected in Vista, Windows 7, and Windows 8. This will...
Tutorials
Random items missing from start menu all of a sudden
First of all, not sure if this is the right place to post this. If not, correct me please. anyway, today when I booted on my computer a few items were missing from the start menu. Ran Malwarebytes and came up clean. So far I noticed paint.net, movie maker and media player are gone. They are on the...
General Discussion
Missing start menu items
Something has caused some items in my startmenu to get deleted. In particular Media Center and some in the Admin Tools folder. I have put some back manually by creating my own shortcuts to the executable files but is there a way to do a repair with the Windows disk that will just look for...
Performance & Maintenance
Context Menu of Jumplist Items Missing "Open file location"?
Is there anyway to add the "Open file location" to the context menus of files that appear in jumplists? For example, my media player is pinned to the task bar. Right clicking on it brings up the jumplist with a list of recent TV episodes I've watched. It would be nice to have the ability to...
General Discussion
Custom Items on Start Menu Context Menu
We have a custom application which users are used to launching by right clicking on the start menu and selecting it from there. We have made this customisation in both XP and Vista by adding an entry in: HKEY_CLASSES_ROOT\Folder\shell However when I try to do this in Windows 7 nothing...
Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:18.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App