Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Weird Windows 7 Registry Issue - HKEY_CLASSES_ROOT

04 Oct 2010   #31

Windows 7 Ultimate 64

TuneUp Utilities 2010's Windows Customizer, the application that can change Windows behaveior, logon behaveior, drives shown in Computer, QoS Service etc. can indeed corrupt the permissions of HKCR, particularly when using it to edit the options appearing in the "New" dialog but also others.

My System SpecsSystem Spec
18 Oct 2010   #32

Windows 7 Home Pre

I would like too thank you guys for this post. My Ex Father-In-Law had this prob and it seems too have cured the probleme.
My System SpecsSystem Spec
07 May 2011   #33

Windows 7 Ulimate x64

FYI: If the owner is missing from a key(s), you must run this in two steps.

subinacl HKEY_CLASSES_ROOT /setowner=Administrators
subinacl HKEY_CLASSES_ROOT /grant=Administrators=f /grant=System=f /grant=Users=r

That worked for me. The single line version did not.
My System SpecsSystem Spec

08 May 2011   #34

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)

Running the:

secedit /configure /CFG %SystemRoot%\inf\defltbase.inf /DB defltbase.sdb /verbose /areas REGKEYS

command resets all Registry Keys to the out-of-the-box settings just like when you installed the OS.

There is no need to add the above permissions, and in fact you may change some keys that are NOT supposed to have those permissions set. Microsoft was tricky when setting up the reg permissions in Windows 7 to help protect the OS. -WS
My System SpecsSystem Spec
08 May 2011   #35

Windows 7 Ulimate x64

Thanks allot! Great advice. I used it and all is well.

I found that the subinacl had a problem anyway - took two runs for some reason it did not fix the lowest subkey... anyway - your suggestion is the way to go.


P.S. Does Apple know that it is doing this to machines? In my case this occurrs when attempting to install the latest iTunes+Quicktime version. Messes up permissions on the new keys entered for quicktime and appears to damage the top level perms as well. Or is this caused by something like - my having the UAC turned off because it is irritating.
My System SpecsSystem Spec

 Weird Windows 7 Registry Issue - HKEY_CLASSES_ROOT

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
do you have this weird registry key?
Hi i have never installed paragon software , but i found this weird registry key yesterday ,in hardware manager i found unknow device and one is related to PARAGONBLOCKDEVICEHKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Enum\Root\PARAGONBLOCKDEVICE i uninstalled the unknown device but i have...
General Discussion
weird chinese registry key in registry
Hi I have Windows Seven utlitmate with SP2, clean installed. Three days ago, MSE noticed and prevent a virus while surfing. I did several indeep scans (MSE), then some online scan (Microsoft, F=secure and Eset) then 3 differents malwares removers, Malwarebit, super malware and Iobit) all...
System Security
Weird issue with Windows 7 & Boot Up?
Hi all, Having some issues with my machine which I suspect may relate to a motherboard issue. At first I thought that my graphics card had failed as its getting on a bit now, although its been a total workhorse (nVidia GeForce 8800GTX). My computer would start but no signal to monitor. So...
Hardware & Devices
Windows 7 boot problems (possible registry issue?)
Okay, I realize I shouldn't have messed with the registry, but I did ("I'm curious as a cat, that's why my friends call me whiskers!" sorry, SNL reference...). Now, I am not really sure how to fix my problem. My problem: Windows 7 (64 bit) reboots itself before it gets to the login screen. ...
BSOD Help and Support
hkey_classes_root]magnet\url pregvalue
I actually found this forum from searching for solutions to a problem so I'm hoping I can get some help here. Though it doesn't show up as a problem in my McAfee or CCleaner, my NoAdware program is finding this one problem: hkey_classes_root]magnet\url pregvalue I delete it but then it...
System Security
Weird Firefox issue: New Windows for No Reason
I can't figure out if this is Windows 7 or Firefox 3.5 I don't notice it happening on my XP installation but it could just be coincidence. Sometimes I'll be moving my mouse around kind of fast and click something and all the sudden my tab will disappear and open up in a new window. I can't...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:45.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App