Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Fonts not installing correctly


22 Mar 2010   #1

Windows 7
 
 
Fonts not installing correctly

I often need to upload and utilize various fonts in my line of work, I recently used the install as shortcut feature from an outside folder that ultimately screwed everything up in the fonts themselves. I have a total of 20 fonts that show up in the folder whereas there used to be 430 something. When I try and install them, the folder says that they are already installed, but they are not...and they are not able to be pulled up from any of the programs I am using either.

I dont have a restore point as I just spent the past couple days REINSTALLING from the last issue I was having, just to fall into another one. I found an previous version of the fonts folder by right clicking and choosing properties. I can see all the fonts and everything, but again, installing does not work.

I am logged in as the Administrator of the computer, and I have tried copying and replacing the entire fonts folder, rather than simply installing them...basically the entire fonts folder will be overwritten rather than installed, but I am having issues because it keeps telling me that I do not have permission. I have tried to go under the windows folder properties and assign the administrators full control, but that did not work at all, it still says I do not have permission.

So my question, how the hell do I give myself permission to overwrite the fonts folder. I can see how not having permission to overwrite in the Windows folder is a good thing, but how can I bypass this so I can have access?

My System SpecsSystem Spec
.

22 Mar 2010   #2

Windows 7 Enterprise 64-bit
 
 

Try taking ownership of the folder first, then overwrite it if you'd like.

Take Ownership Shortcut
My System SpecsSystem Spec
22 Mar 2010   #3

Windows 7
 
 

I was able to take ownership of the folders and bypasses the permissions, but the problem still exists. Only 20 fonts show up, although there are now a BUNCH showing up in Photoshop, which is really bogging it down.
My System SpecsSystem Spec
.


22 Mar 2010   #4

Windows 7 Enterprise 64-bit
 
 

By "install as shortcut", do you mean you created a symbolic link? As in, it acts like it's in the folder, but it's really located elsewhere? If so, you need to break that link or move the original files.
My System SpecsSystem Spec
22 Mar 2010   #5

Windows 7
 
 

That is actually what caused the problem in the first place. I apparently overwrote a whole series of fonts that were in the main folder. I was under the assumption that the fonts would be linked elsewhere but would not overwrite the default fonts...I mistakenly overwrote them and I remember the prompt coming up telling me as well. I just selected "do for all" and let it do its thing. After my entire systems resources came to a screeching halt, I decided a large amount of fonts is probably not my best choice...so I deleted the folder...and apparently all the fonts from the main folder with it.

The problem is, I think those fonts still exist as a shortcut somewhere on the system, because I cannot rewrite into the fonts folder as most of them were in the large fonts folder...but that folder is deleted from my system, so I have no clue where the hell they are all at. All I know is that my system is acting up and my resources are once again being eaten alive.

I am in the process of backing up my programs and essential files and folders that I need and will reinstall the OS and then do a restore. I hopeful that I will not have as much of a headache doing that.
My System SpecsSystem Spec
22 Mar 2010   #6

Windows 7
 
 

It took over an hour, but simply reinstalling Windows 7 as an upgrade over itself fixed the problem...it just took forever.
My System SpecsSystem Spec
22 Mar 2010   #7

Windows 7 Enterprise 64-bit
 
 

I'm glad it all worked out for you in the end. Well, at least you learned now. Making a mistake is probably the most common way of learning something.
My System SpecsSystem Spec
Reply

 Fonts not installing correctly




Thread Tools



Similar help and support threads for2: Fonts not installing correctly
Thread Forum
Problem installing new fonts General Discussion
3TB internal HD not installing correctly Hardware & Devices
Twitter not displaying correctly, fonts are all garbled (like sticks) Browsers & Mail
Firefox - fonts not displaying correctly - screenshots included Browsers & Mail
Solved installing fonts Customization
Error installing fonts Software
Windows 7 isn't displaying foreign fonts correctly General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:28 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33