Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't eject external USB HDD

16 Apr 2010   #1

Windows 7
 
 
Can't eject external USB HDD

I often open content on my (Toshiba) portable hard drive from applications on the local hard drive. In WinXP, I didn't have any problems ejecting the portable drive once I was done and closed the application. ...To be clear, when I did get an "in use" error message, I would simply go into Task Manager and see what offending application processes were still running; once they were stopped, the drive ejected.

Now on Windows 7, the system will not let me properly eject the drive even though the Task Manager shows that I have no applications open on the computer. Each time I try, whether from the taskbar icon or the Devices window, it gives the message that the device cannot be ejected at this time because it's in use. As DaPiit said, this is really annoying because attaching and ejecting USB devices is something I do many times per day! The Windows 7 is not on my machine - I still run WinXP, and this more than anything else is making me REALLY consider finally switching to a Mac instead. (And I've been a Windows user for over 15 years...)

Any ideas what might be going on? Is there some Windows process that needs to be stopped that I don't know about? I'm really reluctant to just "pull the plug" every time I need to remove the drive. Thanks!


My System SpecsSystem Spec
.

16 Apr 2010   #2

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Obviously, it shouldn't be necessary, but instead of just pulling the plug, reboot and pull the plug
My System SpecsSystem Spec
16 Apr 2010   #3

W7 Ult. x64 | OS X
 
 

Read this article from MS:
Problem Ejecting USB Mass Storage Device

Also, download Process Explorer:
Process Explorer
My System SpecsSystem Spec
.


16 Apr 2010   #4
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Maybe you are ready for a Mac. But before you do that, you could try Download Unlocker 1.8.9 - FileHippo.com
My System SpecsSystem Spec
16 Apr 2010   #5

Windows 7 32 bit
 
 

Download Sync from SysInternals

Sync

After stuff has stopped copying to/from the USB drive, open a command prompt and type
Sync

It will flush the buffers of all the HD or you can explicitly put the drive letters if you want.

Once the activity LED stops, the buffers should be flushed. You shouldn't lose any data. Unplug it. I've been doing it that way for a couple of yeas now. I have USB Safely Remove since I got it on a giveaway. But even that doesn't work sometimes. I just do the "sync trick" and I haven't had any corrupted data yet.

edit: It's just a command line exe file. Copy it to a directory that's in your Path such as Windows\System32. Myself I have a directory called Utils I added to the path so that I can just dump small exe utilities in there. If you don't know how to set Path search on setting user environment variables. There's a little edit applet thingy in the Computer properties notebook.
My System SpecsSystem Spec
07 Apr 2011   #6

windows 7 pro x86
 
 

check to see if windows sideshow apps are running -you can search 'sideshow' from start menu
i had my g15 keyboard applet running - which kept windows media player running in the background (locking the ext drive). it was also annoying because i could watch an internet movie, in wm then close it, but if i launch wmplayer again, the same movie is playing! weirddd

i'm never sure how important it is to eject my externals but i imagine its all related to indexing- i once heard from a friend that if you just tap the hard disk or usb stick 5 or 6 times before just pulling it out, you 200% wont damage the device, but he used a mac

HOPE IT WORKS
My System SpecsSystem Spec
Reply

 Can't eject external USB HDD




Thread Tools



Similar help and support threads for2: Can't eject external USB HDD
Thread Forum
How to eject an external eSata drive? Hardware & Devices
Solved unable to 'safely eject' my new external drive. Hardware & Devices
Unable to safely eject external drives etc Hardware & Devices
My external drive is missing when I try to remove or eject Hardware & Devices
External hard drive won't eject Hardware & Devices
problem to eject external drives Software
Solved Can't eject USB connect external hard drive Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:02 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33