Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Second Partition Access Denied


19 Apr 2010   #1

Windows 7 (32-Bits)
 
 
Second Partition Access Denied

Hi everyone! I hope the post is in the appropriate section of the forum!

You are about to hear the stupidest thing ever done. I recently formatted my laptop and installed 64-Bits version of my Windows 7 Home Premium copy as I am planning to install more RAMs. Before I had 32-Bits version and I had partitioned the HDD into two so that I install Win 7 into C and I keep my personal files such as pictures, movies, work files, etc. in D. Whenever I installed 64-Bits, I had file permission problems in partition D, obviously. However, I solved that problem and I was able to use my old files except a couple of music folders. When I was trying to get permissions for those too, I removed the permissions to the partition D itself. Now, my partition is not accessible. Diskeeper 2010 is able to see the partition D and it is obvious that files are still there.

I would really appreciate if some one could help to gain permissions to partition D so that I can access the partition and use my files. All of my important files are in partition D.

Thank you very much for your quick reply...

My System SpecsSystem Spec
.

19 Apr 2010   #2

Windows 7 Ultimate x64 SP1
 
 

Diskeeper an cause some weird issues, so I wouldn't use it, but that's not really related to this issue at hand. I don't see a need to install a third party defragger anymore, but that's just my opinion.

Anyway, it sounds like what you would want to do is take ownership of the drive. I can only replicate this issue if I switched usernames and/or passwords (which is one reaosn why I use the same combo on my home systems all the time.) I don't have a copy of Home Premium installed at the moment, so there's a chance you may not have the options to take ownership. If that's the case, I'd use a Linux CD or a BartPE CD to copy off the data to an external drive, delete the D partition, and then recreate it and move your data back.
My System SpecsSystem Spec
19 Apr 2010   #3

W7 Ult. x64 | OS X
 
 

I doubt it'll work, but enabling the root Administrative account might let you see and reset the permissions of the drive.

Start > Search "cmd" > Right Click cmd.exe & Run as Admin...
Run Command: net user administrator /active:yes
Log in Using that Account

While you're in there, get a snapshot of your Disk Management window

Start > Run > compmgmt.msc > Disk Management
My System SpecsSystem Spec
.


19 Apr 2010   #4

Windows 7 (32-Bits)
 
 

Thank you very much for the quick replies

@DeaconFrost: I understand your point and I guess using a Live Linux CD and getting all the data would be the best solution.

@notsograymatter: I tried what you said but it does not work

I wish there is an easier way of doing this...
My System SpecsSystem Spec
19 Apr 2010   #5

Windows 7 (32-Bits)
 
 

Do you have any other options?
My System SpecsSystem Spec
19 Apr 2010   #6

W7 Ult. x64 | OS X
 
 

Nope, you're going to have to find a way into the disk with a live cd.

Before you do that, post a screen shot of your disk management screen, highlight that partition if you can see it.
My System SpecsSystem Spec
19 Apr 2010   #7

Windows 7 (32-Bits)
 
 

Here is a screen-shot of the the Disk Management screen...


Attached Thumbnails
Second Partition Access Denied-capture.png  
My System SpecsSystem Spec
19 Apr 2010   #8

Windows 7 (32-Bits)
 
 

I solved the problem with Stellar Phoenix Windows Data Recovery. I recovered all of my files and will delete and create the partition again.

Thank you very much for the help.
My System SpecsSystem Spec
19 Apr 2010   #9

W7 Ult. x64 | OS X
 
 

Yeah, I was about to say that it looks like your data is still there, you just deleted the roadmap to it. Glad you figured it out.
My System SpecsSystem Spec
Reply

 Second Partition Access Denied




Thread Tools



Similar help and support threads for2: Second Partition Access Denied
Thread Forum
Trying to delete a primary partition in diskmanagement - Access Denied General Discussion
Solved chkdsk failure primary partition (access denied) Performance & Maintenance
Partition Access Denied General Discussion
HDD Partition Access is Denied Installation & Setup
partition on hdd is not accessible. Access is denied Installation & Setup
Access to partition denied after install. Installation & Setup
partition access denied after bad upgrade Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:53 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33