Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Every new library is missing "iconReference"

30 Apr 2010   #1
micnolmad

windows 7 home premium 64
 
 
Every new library is missing "iconReference"

Every time I make a new library the icon is the same general one. If I set the lib type to one of the specific ones the icon stays the same. If I open the lib in notepad I can verify that the iconReference xml tag is missing. What can I do to fix this? I have just run a scan for corrupted windows files which came up clean.

-micnolmad


My System SpecsSystem Spec
.

30 Apr 2010   #2
Airbot

Windows 7 Ultimate x64 SP1
 
 

Take a look thru this -

Quote:
NOTE: If this is a new Library that you have created, then the line will not be there and you will need to add the <iconReference>"path to icon w/file extension"</iconReference> line directly under the <isLibraryPinned>-1</isLibraryPinned> line entry.
Libraries Icons - Change
Libraries Icon - Change Default Icon
My System SpecsSystem Spec
30 Apr 2010   #3
micnolmad

windows 7 home premium 64
 
 

So are you saying new libraries are suppose to have the same generic icon?
My System SpecsSystem Spec
.


30 Apr 2010   #4
Airbot

Windows 7 Ultimate x64 SP1
 
 

I didn't say that anywhere. I was responding to your missing iconreference line, and how to fix it, but yes, every new library you make will have the same generic icon for it. You'll have to change them to custom if you want. With the tutorials I posted.
My System SpecsSystem Spec
30 Apr 2010   #5
micnolmad

windows 7 home premium 64
 
 

No need to get defensive. It was just a question for confirmation. Thank you for helping.
My System SpecsSystem Spec
30 Apr 2010   #6
Airbot

Windows 7 Ultimate x64 SP1
 
 

No problem. Welcome aboard.
My System SpecsSystem Spec
Reply

 Every new library is missing "iconReference"




Thread Tools





Similar help and support threads
Thread Forum
"Local Area Connection" missing in "Change adapter Settings".. Plz hlp
I have to set up a Broadband connection. But Local Area connection icon is missing. Someone told "drivers" could be missing... I installed few. But the problem is as it was.. please guide me in this regards.. Thank you Screen shots Attached
Network & Sharing
Folder for "Videos" library won't work on same drive as "Recorded TV"
Interesting discovery. W7 Pro x64. I was copying content from my desktop PC to my laptop in anticipation of an upcoming weekend trip. The content consists of both (a) entire recent copy-freely WTV recordings, and (b) MPEG videos (actually previously edited from copy-freely WTV recordings using...
Media Center
"Select Proper Boot Device" now "NTLDR is missing"
Computer Specs: CPU: I5-2400 MB: Asus Pz868 Ram: Corsair 8GB Vengeance LP Using on board VIdeo For now Maxtor HD Sata WD Raptor Sata HP Lightscribe DVD-r Drive Sata Problem I was having once I completed my new build with old system parts was as listed in title. It started out as select...
BSOD Help and Support
"Include in library" option suddenly missing from Windows Explorer
For no apparent reason, the function "include in library" in Windows Explorer (right click on a folder to include it in a library) is not longer there. It used to be. But now when I right click on a folder in Windows Explorer, it's simply not there anymore. Does anybody know how to restore it? Or...
General Discussion
WMP briefly opens in "Library" then switches to "Now Playing"
Well, can't get more specific than the title. This little anomaly happened sometime this afternoon probably when I downloaded Spotify. Anyway, when I open Windows Media Player I usually expect to be taken straight to the Library by default. Not anymore. Now I get a brief, momentary flash of the...
Music, Pictures & Video
Can't rename "Documents" library to "Comics"
So here's what happened: I was using my "Documents" library as a shortcut to my comics folder. I did this because I wanted my comics folder to be accessible through the upper right section of the start menu. So I renamed it to "Comics", and all was well. That is, until I installed the...
Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App