Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Partition service help


01 May 2010   #1

Windows 7 Ultimate 64-bit Build 7600
 
 
Partition service help

Hi

I am having a problem with the virtual disk manager, windows 7 ultimate x64.

When i try to shrink any partition i get the error
Quote   Quote: Originally Posted by Windows (",)
the service cannot be started, either because it was diabled or because it has no enabled devices associated with it
I have checked the required services as per Dwarf's post on a similar topic.
Quote   Quote: Originally Posted by Dwarf
The service that you are having trouble with is Virtual Disk. This is dependant on the following services: Plug and Play and Remote Procedure Call (RPC). Check each of these services in turn and make sure that they are not disabled.

Virtual Disk [Manual] dependant on Plug and Play and Remote Procedure Call (RPC)

Plug and Play [Automatic] not dependant on another service

Remote Procedure Call (RPC) [Automatic] dependant on DCOM Server Process Launcher and RPC Endpoint Mapper

DCOM Server Process Launcher [Automatic] not dependant on another service

RPC Endpoint Mapper [Automatic] not dependant on another service
None are disabled but i still get the error..? Could anyone shed some light on this?
Cheers!


My System SpecsSystem Spec
.

01 May 2010   #2

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Have you tried using a third party app, like Partition Wizard? I'm not certain about VHD, but it handles everything else very well.
My System SpecsSystem Spec
02 May 2010   #3

Windows 7 Ultimate 64-bit Build 7600
 
 

Thanks for the tip but to be honest, partitioning was not my main concern.
I started to have certain problems with the OS in the last couple of days even though i did no tweaking or messing around.
My drive icons turning into blank images for example, and other strange oddities including the virtual disk manager problem, messed up file associations and system restore being turned off .

I don't know why this has happened and i won't find out as i've backed up and prepared for a format.
It's unlikely i have a virus as i've done thorough checks of everything service-wise, processes and registry entries.

But the major concern is the system restore so a reformat is my only option!
My System SpecsSystem Spec
.


03 May 2010   #4

Windows 7 Ultimate 64-bit Build 7600
 
 

Edit: Just came across this post and it may provide the reason why restore was turned off. No good for me, but incase anyone else has a similar problem.

Code:
http://social.answers.microsoft.com/Forums/en/w7repair/thread/6eb3551b-58d0-46de-83ab-214a0022716b
My System SpecsSystem Spec
Reply

 Partition service help




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:26 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33