Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: W7 x64 can only use 4gb Memory?


02 May 2010   #1

Windows 7 64-bit
 
 
W7 x64 can only use 4gb Memory?

Hi !

I have a somewhat wierd problem with my Windows 7 installation. I have Windows7 Ultimate x64 and 6 gigbytes of memory. But still when i open up my computer properties page, it tells me it can't use more than 4 gigs of memory. What's wrong here?




Something ain't right here?



Cheers, Toby91


My System SpecsSystem Spec
.

02 May 2010   #2

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Check in your BIOS to see if you have an option for Interrupt 19, if so, enable it.
My System SpecsSystem Spec
02 May 2010   #3

Windows 7 64-bit
 
 

Cannot seem to find it. Any specific category to look in?

My specs are

Gigabyte EX58 UD3R S1366 Mainboard

Intel Core i7 920

Corsair TWIN3X 1333MHz DDR3, 6GB

ATI Radeon HD 5870
My System SpecsSystem Spec
.


02 May 2010   #4

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I have a totally different MB/BIOS (Asus/AMI), so I can't be sure that you have it, or where it would be, but in mine, I think that it is in Advanced Settings. I'm just going by my memory, which isn't all that great. Kind of like this issue (memory hole). Try checking the FAQs at the Gigabyte website. They should reference it somewhere, if they use it?
My System SpecsSystem Spec
02 May 2010   #5

Windows 8.1 Pro RTM x64
 
 

See if this helps. RAM issue
My System SpecsSystem Spec
02 May 2010   #6

Windows 7 64-bit
 
 

That did not help. I checked my bios, it tells me that 4096mb of memory is installed? Why doesn't my last 2gb stick show up? What can i do to fix this?
My System SpecsSystem Spec
02 May 2010   #7

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I have to apologise, because what I said before is wrong. I had to go into my BIOS to check and under the Advance tab>CPU Configuration>MTRR Mapping, the setting need in my case is "Discrete".
My System SpecsSystem Spec
02 May 2010   #8

Windows 7 64-bit
 
 

I have found my problem!

It seems to have been caused by my overclock to 4 GHZ, that included that i had to crank up the memory a little bit, but setting memory values back to normal and cpu back to 3.8 it now shows up as 6gb of memory again

But thanks for helping!
My System SpecsSystem Spec
Reply

 W7 x64 can only use 4gb Memory?




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:36 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33